development/gforth: Added (GNU Forth interpreter)

Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
This commit is contained in:
Zbigniew Baniewski 2013-03-03 02:13:02 -06:00 committed by Robby Workman
parent d1c095f1fe
commit 60f0f57cfe
5 changed files with 139 additions and 0 deletions

View File

@ -0,0 +1,12 @@
diff -Nur gforth-0.7.2/Makefile.in gforth-0.7.2.new/Makefile.in
--- gforth-0.7.2/Makefile.in 2013-02-24 17:38:34.965892542 +0000
+++ gforth-0.7.2.new/Makefile.in 2013-02-25 13:36:38.227716339 +0000
@@ -60,7 +60,7 @@
MASSAGE_EXE = @MASSAGE_EXE@
INSTALL_SCRIPT = @INSTALL_SCRIPT@
INSTALL_DATA = @INSTALL_DATA@
-INSTALL_INFO = @INSTALL_INFO@
+INSTALL_INFO =
LN_S = @LN_S@
M4 = @M4@
GCC = @CC@

View File

@ -0,0 +1,7 @@
GNU Forth interpreter that is ANSI compliant.
NOTE: If you Compile or otherwise install the Ffcall package, GForth will
also have the ability to call libraries of C software. Ffcall must be
installed first in order for GForth to detect this, however.
However, GForth can run on its own without Ffcall. For this reason, Ffcall
is not listed as a dependency.

View File

@ -0,0 +1,91 @@
#!/bin/sh
# Slackware build script for gforth
# Written by Zbigniew Baniewski, <Zbigniew.Baniewski@gmail.com>
PRGNAM=gforth
VERSION=0.7.2
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
fi
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
fi
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
patch -p0 < $CWD/01-Makefile.in.patch
cd $PRGNAM-$VERSION
chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
# Fix old-style flag
sed -i "s/-m486/-mtune=i486/g" configure.in
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
--prefix=/usr \
--libdir=/usr/lib${LIBDIRSUFFIX} \
--mandir=/usr/man \
--infodir=/usr/info \
--build=$ARCH-slackware-linux
make
make install DESTDIR=$PKG
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
rm -f $PKG/usr/info/dir
gzip -9 $PKG/usr/info/*.info*
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
doc/gforth.ps AUTHORS BUGS COPYING* ChangeLog NEWS* README* \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}

View File

@ -0,0 +1,10 @@
PRGNAM="gforth"
VERSION="0.7.2"
HOMEPAGE="http://www.gnu.org/software/gforth/"
DOWNLOAD="http://www.complang.tuwien.ac.at/forth/gforth/gforth-0.7.2.tar.gz"
MD5SUM="96f2354ec8c4005e1a54035586ed683e"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
MAINTAINER="Zbigniew Baniewski"
EMAIL="Zbigniew.Baniewski@gmail.com"

View File

@ -0,0 +1,19 @@
# HOW TO EDIT THIS FILE:
# The "handy ruler" below makes it easier to edit a package description.
# Line up the first '|' above the ':' following the base package name, and
# the '|' on the right side marks the last column you can put a character in.
# You must make exactly 11 lines for the formatting to be correct. It's also
# customary to leave one space after the ':' except on otherwise blank lines.
|-----handy-ruler------------------------------------------------------|
gforth: gforth (GNU Forth interpreter)
gforth:
gforth: GNU Forth interpreter that is ANSI compliant.
gforth:
gforth: http://www.gnu.org/software/gforth/
gforth:
gforth:
gforth:
gforth:
gforth:
gforth: