system/sandbox: Fixed build on 32 bit.
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
This commit is contained in:
parent
cb8db2ed5c
commit
60d190b0bd
|
@ -24,7 +24,7 @@
|
|||
|
||||
PRGNAM=sandbox
|
||||
VERSION=${VERSION:-2.13}
|
||||
BUILD=${BUILD:-1}
|
||||
BUILD=${BUILD:-2}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
if [ -z "$ARCH" ]; then
|
||||
|
@ -69,11 +69,13 @@ find -L . \
|
|||
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
|
||||
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
|
||||
|
||||
# Fix build with slibtool
|
||||
# https://bugs.gentoo.org/656184
|
||||
zcat $CWD/slibtool.patch.gz | patch -p1
|
||||
# Remove -nodefaultlibs to avoid compiler failures for 32-bit with slibtool.
|
||||
# GNU libtool swallows anything not on their list of "known" linker flags.
|
||||
# https://bugs.gentoo.org/657184
|
||||
patch -p1 < $CWD/slibtool.patch
|
||||
|
||||
autoreconf -fi
|
||||
|
||||
CFLAGS="$SLKCFLAGS" \
|
||||
CXXFLAGS="$SLKCFLAGS" \
|
||||
./configure \
|
||||
|
|
|
@ -0,0 +1,11 @@
|
|||
diff -ur sandbox-2.13.orig/libsandbox/Makefile.am sandbox-2.13/libsandbox/Makefile.am
|
||||
--- sandbox-2.13.orig/libsandbox/Makefile.am 2018-02-19 05:50:18.000000000 -0000
|
||||
+++ sandbox-2.13/libsandbox/Makefile.am 2018-06-03 12:58:04.270611236 -0000
|
||||
@@ -20,7 +20,6 @@
|
||||
# and destructor will not be executed ...
|
||||
libsandbox_la_LDFLAGS = \
|
||||
-no-undefined \
|
||||
- -nodefaultlibs \
|
||||
-avoid-version \
|
||||
$(LDFLAG_VER),libsandbox.map
|
||||
libsandbox_la_SOURCES = \
|
Binary file not shown.
Loading…
Reference in New Issue