libraries/libwhisker2: Updated for version 2.5
This commit is contained in:
parent
1886b8fd55
commit
5e3ea9bb43
|
@ -0,0 +1,116 @@
|
|||
diff -Naur libwhisker2-2.5.orig/Makefile libwhisker2-2.5/Makefile
|
||||
--- libwhisker2-2.5.orig/Makefile 2010-01-24 05:35:26.000000000 +0100
|
||||
+++ libwhisker2-2.5/Makefile 2010-02-01 11:52:36.495699604 +0100
|
||||
@@ -10,6 +10,7 @@
|
||||
|
||||
install:
|
||||
export DESTDIR
|
||||
+ export MAN3PATH
|
||||
perl Makefile.pl install
|
||||
|
||||
clean:
|
||||
@@ -20,4 +21,5 @@
|
||||
|
||||
uninstall:
|
||||
export DESTDIR
|
||||
+ export MAN3PATH
|
||||
perl Makefile.pl uninstall
|
||||
diff -Naur libwhisker2-2.5.orig/Makefile.pl libwhisker2-2.5/Makefile.pl
|
||||
--- libwhisker2-2.5.orig/Makefile.pl 2010-01-24 05:35:26.000000000 +0100
|
||||
+++ libwhisker2-2.5/Makefile.pl 2010-02-01 12:24:51.045033735 +0100
|
||||
@@ -29,6 +29,8 @@
|
||||
# ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
|
||||
# POSSIBILITY OF SUCH DAMAGE.
|
||||
|
||||
+use File::Path;
|
||||
+
|
||||
$VERSION = '2.5'; # version of the app
|
||||
$PACKAGE = 'LW2'; # name of the app
|
||||
$TARGET = 'LW2.pm'; # target build filename
|
||||
@@ -42,6 +44,7 @@
|
||||
$HASPOD = 1; # does it have embedded POD?
|
||||
|
||||
$DESTDIR = ''; # installation directory prefix
|
||||
+$MAN3PATH = ''; # man page installation prefix
|
||||
|
||||
#### supported build options #########################################
|
||||
|
||||
@@ -131,6 +134,8 @@
|
||||
|
||||
# adjust DESTDIR, if needed
|
||||
$DESTDIR = $ENV{DESTDIR} if(defined $ENV{DESTDIR});
|
||||
+# adjust MAN3PATH, if needed
|
||||
+$MAN3PATH = $ENV{MAN3PATH} if(defined $ENV{MAN3PATH});
|
||||
|
||||
# parse command line build options
|
||||
while($COMMAND = shift @ARGV){
|
||||
@@ -171,7 +176,7 @@
|
||||
command_build() if(!-e $TARGET);
|
||||
die("Can not install without Config.pm") if($MODULES{Config}==0);
|
||||
$CWD=&cwd if($MODULES{Cwd}>0);
|
||||
- my $where=$DESTDIR . $Config{'man3direxp'};
|
||||
+ my $where=$DESTDIR . $MAN3PATH;
|
||||
my $t = $TARGET;
|
||||
if($LIBRARY){
|
||||
$t="$PACKAGE.3pm";
|
||||
@@ -182,8 +187,8 @@
|
||||
if(!-e $where){
|
||||
print STDOUT "WARNING!\n\n",
|
||||
"The local man3 site directory does not exist:\n",
|
||||
- "$where\n\nPlease create this directory and try again.\n\n";
|
||||
- exit;
|
||||
+ "$where\n\n";
|
||||
+ mkpath $where;
|
||||
}
|
||||
|
||||
my $parser = Pod::Man->new (
|
||||
@@ -219,7 +224,7 @@
|
||||
sub command_uninstall_pod {
|
||||
die("Can not uninstall without Config.pm") if($MODULES{Config}==0);
|
||||
$CWD=&cwd if($MODULES{Cwd}>0);
|
||||
- my $where=$DESTDIR . $Config{'man3direxp'};
|
||||
+ my $where=$DESTDIR . $MAN3PATH;
|
||||
my $t = $TARGET;
|
||||
if($LIBRARY){
|
||||
$t="$PACKAGE.3pm";
|
||||
@@ -243,12 +248,12 @@
|
||||
command_build() if(!-e $TARGET);
|
||||
die("Can not install without Config.pm") if($MODULES{Config}==0);
|
||||
$CWD=&cwd if($MODULES{Cwd}>0);
|
||||
- my $where=$DESTDIR . $Config{'installsitelib'};
|
||||
+ my $where=$DESTDIR . $Config{'installvendorlib'};
|
||||
if(!-e $where){
|
||||
print STDOUT "WARNING!\n\n",
|
||||
"The local perl site directory does not exist:\n",
|
||||
- "$where\n\nPlease create this directory and try again.\n\n";
|
||||
- exit;
|
||||
+ "$where\n\n";
|
||||
+ mkpath $where;
|
||||
}
|
||||
open(IN,'<'.$TARGET)||puke($TARGET);
|
||||
chdir($where);
|
||||
@@ -271,7 +276,7 @@
|
||||
sub command_uninstall_library {
|
||||
die("Can not uninstall without Config.pm") if($MODULES{Config}==0);
|
||||
$CWD=&cwd if($MODULES{Cwd}>0);
|
||||
- my $where=$DESTDIR . $Config{'installsitelib'};
|
||||
+ my $where=$DESTDIR . $Config{'installvendorlib'};
|
||||
chdir($where);
|
||||
if(-e $TARGET){
|
||||
unlink $TARGET;
|
||||
@@ -401,12 +406,12 @@
|
||||
sub command_install_compat {
|
||||
die("Can not install without Config.pm") if($MODULES{Config}==0);
|
||||
$CWD=&cwd if($MODULES{Cwd}>0);
|
||||
- my $where=$DESTDIR . $Config{'installsitelib'};
|
||||
+ my $where=$DESTDIR . $Config{'installvendorlib'};
|
||||
if(!-e $where){
|
||||
print STDOUT "WARNING!\n\n",
|
||||
"The local perl site directory does not exist:\n",
|
||||
- "$where\n\nPlease create this directory and try again.\n\n";
|
||||
- exit;
|
||||
+ "$where\n\n";
|
||||
+ mkpath $where;
|
||||
}
|
||||
open(IN,'<'.'compat/LW.pm')||puke('compat/LW.pm');
|
||||
chdir($where);
|
Binary file not shown.
|
@ -2,7 +2,7 @@
|
|||
|
||||
# Slackware build script for libwhisker2
|
||||
#
|
||||
# Copyright 2009-2010 Marco Bonetti <sid77@slackware.it>
|
||||
# Copyright 2010-2011 Marco Bonetti <sid77@slackware.it>
|
||||
# All rights reserved.
|
||||
#
|
||||
# Redistribution and use of this script, with or without modification, is
|
||||
|
@ -23,7 +23,7 @@
|
|||
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
|
||||
PRGNAM=libwhisker2
|
||||
VERSION=2.4
|
||||
VERSION=2.5
|
||||
ARCH=${ARCH:-i486}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
@ -32,15 +32,18 @@ CWD=$(pwd)
|
|||
TMP=${TMP:-/tmp/SBo}
|
||||
PKG=$TMP/package-$PRGNAM
|
||||
OUTPUT=${OUTPUT:-/tmp}
|
||||
|
||||
DOCS="CHANGES DISTRIBUTION KNOWNBUGS LICENSE README docs scripts"
|
||||
|
||||
# Not used at all :-/
|
||||
if [ "$ARCH" = "i486" ]; then
|
||||
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
|
||||
LIBDIRSUFFIX=""
|
||||
elif [ "$ARCH" = "i686" ]; then
|
||||
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
|
||||
LIBDIRSUFFIX=""
|
||||
elif [ "$ARCH" = "x86_64" ]; then
|
||||
SLKCFLAGS="-O2 -fPIC"
|
||||
LIBDIRSUFFIX="64"
|
||||
fi
|
||||
|
||||
set -e
|
||||
|
@ -54,7 +57,7 @@ tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
|
|||
cd $PRGNAM-$VERSION
|
||||
|
||||
# Patch Makefiles
|
||||
zcat $CWD/Makefiles.patch.gz | patch -p1
|
||||
cat $CWD/Makefiles.patch | patch -p1
|
||||
|
||||
chown -R root:root .
|
||||
find . \
|
||||
|
@ -69,8 +72,10 @@ make DESTDIR=$PKG \
|
|||
install
|
||||
|
||||
( cd $PKG
|
||||
find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
|
||||
find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
|
||||
find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
|
||||
xargs strip --strip-unneeded 2> /dev/null || true
|
||||
find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
|
||||
xargs strip --strip-unneeded 2> /dev/null
|
||||
)
|
||||
|
||||
( cd $PKG/usr/man
|
||||
|
@ -91,4 +96,4 @@ mkdir -p $PKG/install
|
|||
cat $CWD/slack-desc > $PKG/install/slack-desc
|
||||
|
||||
cd $PKG
|
||||
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
|
||||
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
|
||||
|
|
|
@ -1,8 +1,10 @@
|
|||
PRGNAM="libwhisker2"
|
||||
VERSION="2.4"
|
||||
VERSION="2.5"
|
||||
HOMEPAGE="http://www.wiretrip.net/rfp/lw.asp"
|
||||
DOWNLOAD="http://downloads.sourceforge.net/whisker/libwhisker2-2.4.tar.gz"
|
||||
MD5SUM="bdc618fa52bee38171c12e00bd99e18d"
|
||||
DOWNLOAD="http://downloads.sourceforge.net/whisker/libwhisker2-2.5.tar.gz"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM="7cc1718dddde8f9a439d5622ae2f37eb"
|
||||
MD5SUM_x86_64=""
|
||||
MAINTAINER="Marco Bonetti"
|
||||
EMAIL="sid77@slackware.it"
|
||||
APPROVED="dsomero"
|
||||
|
|
Loading…
Reference in New Issue