graphics/tuxpaint: Patched for new SDL2_Pango.

Signed-off-by: Dave Woodfall <dave@slackbuilds.org>

Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
Tim Dickson 2022-08-21 10:26:41 +01:00 committed by Willy Sudiarto Raharjo
parent 82e8c1f81c
commit 5c06499fd6
No known key found for this signature in database
GPG Key ID: 3F617144D7238786
3 changed files with 29 additions and 4 deletions

View File

@ -9,8 +9,9 @@ and has entertaining, child-oriented additions such as sound effects.
tuxpaint-config is now also included as a gui tool to configure
tuxpaint.
Note: Please uninstall inkscape before creating this package to avoid
a couple of file artifacts outside the package directory. inkscape can
be reinstalled once this package is created.
Note: Please uninstall inkscape before creating this package if you
want to avoid a couple of file artifacts outside the package directory.
inkscape can be reinstalled once this package is created.
This is the sdl2 version of the program. Note: dependencies have changed
note: this build update (3) is needed for using SDL2_Pango>0.9.0

View File

@ -13,13 +13,14 @@
# - stop spamming the real /usr (ugh).
# 20220610 tim dickson: updated to 0.9.28 . sticking with sdl1 version for now
# 20220629 tim dickson: changed to the sdl2 version
# 20220820 tim dickson: added patch to work with newer SDL2_Pango. should be fixed upstream in next release
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=tuxpaint
VERSION=${VERSION:-0.9.28}
CONFVER=${CONFVER:-0.0.19}
BUILD=${BUILD:-2}
BUILD=${BUILD:-3}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@ -79,6 +80,10 @@ mkdir trans
# using the xdg-icon-resource and xdg-desktop-menu tools: these don't
# support DESTDIR or any other way to control where the files get
# installed (meaning they install to the real /usr, not $PKG/usr).
#patch to fix working with newer SDL2_Pango. remove for next version update
patch <$CWD/tuxpaint_SDL2_Pango.patch
sed -i '/^linux_ARCH_INSTALL/s,install-xdg ,,' Makefile
make PREFIX=/usr LIBDIRSUFFIX=$LIBDIRSUFFIX OPTFLAGS="$SLKCFLAGS"

View File

@ -0,0 +1,19 @@
--- a/Makefile
+++ b/Makefile
@@ -294,6 +294,7 @@
# SDL Pango is needed to render complex scripts like Thai and Arabic
SDL2_PANGO_LIB:=$(call linktest,SDL2_Pango,-lSDL2_Pango,$(SDL_LIBS))
+SDL2_PANGO_CFLAGS:=$(shell $(PKG_CONFIG) --cflags SDL2_Pango)
NOPANGOFLAG:=$(if $(SDL2_PANGO_LIB),,-DNO_SDLPANGO$(warning -lSDL2_Pango failed, no scripts for you!))
SDL_LIBS+=$(SDL_MIXER_LIB) $(SDL2_PANGO_LIB)
@@ -341,6 +342,7 @@
-Waggregate-return \
-Wstrict-prototypes -Wmissing-prototypes \
$(shell src/test-option.sh -Wstrict-aliasing=2) \
+ $(SDL2_PANGO_CFLAGS) \
$(ARCH_CFLAGS)
DEFS:=-DVER_DATE=\"$(VER_DATE)\" -DVER_VERSION=\"$(VER_VERSION)\" \