audio/dcd: Added to 12.2 repository

This commit is contained in:
Luis Henrique 2010-05-12 23:27:49 +02:00 committed by Robby Workman
parent f72e8ab50f
commit 5b5c262d44
5 changed files with 134 additions and 0 deletions

20
audio/dcd/Makefile.diff Normal file
View File

@ -0,0 +1,20 @@
--- Makefile 2003-08-27 22:44:07.000000000 -0300
+++ Makefile.new 2009-02-14 23:00:24.000000000 -0300
@@ -21,7 +21,7 @@ PREFIX = /usr
# with that, you don't even need to uncomment the next line.
# CDROM = /dev/cdrom
# Or, if you use devfs, uncomment this line:
-CDROM = /dev/cdroms/cdrom0
+# CDROM = /dev/cdroms/cdrom0
@@ -51,8 +51,6 @@ NETWORK = 1
ifdef DEBUG
EXTRA_CFLAGS = -DDEBUG=${DEBUG} -Wall -pedantic -g
-else
-EXTRA_CFLAGS = -O2 # -march=k6 # the arch optimization is for dave!
endif
ifdef CDROM

13
audio/dcd/README Normal file
View File

@ -0,0 +1,13 @@
dcd (console CD player)
dcd: a Linux CD player by a slacker, for slackers.
dcd was started because I got tired of having to dedicate a whole
console to workbone, and the CD players available for X were, at
the time, universally lacking in features. They're a bit better
now, though.
dcd plays CDs, lets you set up CD playlists, and does most of what
a conventional CD player does, in a (hopefully) intuitive manner.
This requires libmusicbrainz.

74
audio/dcd/dcd.SlackBuild Normal file
View File

@ -0,0 +1,74 @@
#!/bin/sh
# Slackware build script for dcd
# Written by Luis Henrique <lmello.009@gmail.com>
PRGNAM=dcd
VERSION=${VERSION:-0.99.2}
ARCH=${ARCH:-i486}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
fi
set -e # Exit on most errors
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
# Patch the Makefile to fix the cdrom device dcd looks for (/dev/cdrom):
patch -p0 < $CWD/Makefile.diff
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
make
# Install the package:
ginstall -m 755 -d $PKG/usr/bin
ginstall -m 755 -s dcd $PKG/usr/bin
ginstall -m 755 -d $PKG/usr/man/man1
ginstall -m 644 dcd.1 $PKG/usr/man/man1
( cd $PKG
find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
xargs strip --strip-unneeded 2> /dev/null || true
find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
xargs strip --strip-unneeded 2> /dev/null
)
( cd $PKG/usr/man
find . -type f -exec gzip -9 {} \;
for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
)
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a BUGS COPYING INSTALL README README.LZO $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz

8
audio/dcd/dcd.info Normal file
View File

@ -0,0 +1,8 @@
PRGNAM="dcd"
VERSION="0.99.2"
HOMEPAGE="http://dcdplayer.sourceforge.net"
DOWNLOAD="http://downloads.sourceforge.net/dcdplayer/dcd-0.99.2.tar.gz"
MD5SUM="94d8e5bdcd1961998d4c3bd80155e5d7"
MAINTAINER="Luis Henrique"
EMAIL="lmello.009@gmail.com"
APPROVED="rworkman"

19
audio/dcd/slack-desc Normal file
View File

@ -0,0 +1,19 @@
# HOW TO EDIT THIS FILE:
# The "handy ruler" below makes it easier to edit a package description. Line
# up the first '|' above the ':' following the base package name, and the '|'
# on the right side marks the last column you can put a character in. You must
# make exactly 11 lines for the formatting to be correct. It's also
# customary to leave one space after the ':'.
|-----handy-ruler-------------------------------------------------------|
dcd: dcd (console CD player)
dcd:
dcd: dcd - a Linux CD player by a slacker, for slackers.
dcd:
dcd: dcd was started because I got tired of having to dedicate a whole
dcd: console to workbone, and the CD players available for X were, at
dcd: the time, universally lacking in features. They're a bit better
dcd: now, though.
dcd:
dcd: dcd plays CDs, lets you set up CD playlists, and does most of what
dcd: a conventional CD player does, in a (hopefully) intuitive manner.