development/protobuf3: Updated for version 26.0.

Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
Willy Sudiarto Raharjo 2024-03-16 21:28:52 +07:00
parent 4920d12c38
commit 593954e1ec
No known key found for this signature in database
GPG Key ID: 3F617144D7238786
4 changed files with 14 additions and 42 deletions

View File

@ -1,16 +0,0 @@
diff -ruN a/python/setup.py b/python/setup.py
--- a/python/setup.py 2022-12-13 01:03:12.000000000 +0100
+++ b/python/setup.py 2023-04-06 22:12:36.199029178 +0200
@@ -220,10 +220,10 @@
return False
-if __name__ == '__main__':
+if True:
ext_module_list = []
warnings_as_errors = '--warnings_as_errors'
- if GetOptionFromArgv('--cpp_implementation'):
+ if True:
# Link libprotobuf.a and libprotobuf-lite.a statically with the
# extension. Note that those libraries have to be compiled with
# -fPIC for this to work.

View File

@ -2,7 +2,7 @@
# Slackware build script for protobuf3
# Copyright 2017-2022 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
# Copyright 2017-2024 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=protobuf3
VERSION=${VERSION:-25.3}
VERSION=${VERSION:-26.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@ -81,10 +81,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
patch -p1 < $CWD/protobuf3.patch
patch -p1 < $CWD/protobuf-21.12-pep517.patch
patch -p1 < $CWD/soversion.patch
sed -e "s|c++14|c++17|" -i python/setup.py
mkdir -p build
cd build
@ -101,13 +98,14 @@ cd build
make install/strip DESTDIR=$PKG
cd ..
# Install the python bindings
cd python
LDFLAGS+=" -L$TMP/$SRCNAM-$VERSION/build" \
PROTOC="$TMP/$SRCNAM-$VERSION/build/protoc" \
python3 -m build --wheel --no-isolation
python3 -m installer --destdir "$PKG" dist/*.whl
cd ..
# Install the python bindings:
#cd python
#cp -a dist/setup.py .
#LDFLAGS+=" -L$TMP/$SRCNAM-$VERSION/build" \
#PROTOC="$TMP/$SRCNAM-$VERSION/build/protoc" \
#python3 -m build --wheel --no-isolation
#python3 -m installer --destdir "$PKG" dist/*.whl
#cd ..
rm -rf $PKG/usr/lib${LIBDIRSUFFIX}/*.la

View File

@ -1,10 +1,10 @@
PRGNAM="protobuf3"
VERSION="25.3"
VERSION="26.0"
HOMEPAGE="https://github.com/google/protobuf"
DOWNLOAD="https://github.com/google/protobuf/archive/v25.3/protobuf-25.3.tar.gz"
MD5SUM="5e82b6696d6bcacc2e60313f187f3551"
DOWNLOAD="https://github.com/google/protobuf/archive/v26.0/protobuf-26.0.tar.gz"
MD5SUM="44068557aabb2b774a29260740bbccc4"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="abseil-cpp python3-build python3-wheel"
REQUIRES="abseil-cpp"
MAINTAINER="Willy Sudiarto Raharjo"
EMAIL="willysr@slackbuilds.org"

View File

@ -1,10 +0,0 @@
--- protobuf-3.10.1/src/google/protobuf/text_format.h.orig 2019-10-13 10:42:21.345593616 +0700
+++ protobuf-3.10.1/src/google/protobuf/text_format.h 2019-10-13 10:42:34.151188015 +0700
@@ -42,6 +42,7 @@
#include <memory>
#include <string>
#include <vector>
+#include <cmath>
#include <google/protobuf/stubs/common.h>
#include <google/protobuf/descriptor.h>