system/isomaster: Initial import

This commit is contained in:
Erik Hanson 2010-05-11 15:18:39 +02:00 committed by Michiel van Wessem
parent ea6339beab
commit 58b15e22bd
6 changed files with 89 additions and 0 deletions

View File

@ -0,0 +1,18 @@
--- Makefile 2007-03-18 12:41:13.000000000 -0500
+++ Makefile.new 2007-03-25 23:06:35.000000000 -0500
@@ -1,5 +1,5 @@
# Other paths are relative to this.
-PREFIX ?= /usr/local
+PREFIX ?= /usr
# Where to install the executable.
BINPATH ?= $(PREFIX)/bin
@@ -14,7 +14,7 @@
export LOCALEDIR ?= $(PREFIX)/share/locale
# Where to install the man page.
-MYMANPATH ?= $(PREFIX)/share/man/man1
+MYMANPATH ?= $(PREFIX)/man/man1
# Where to install the .desktop file
DESKTOPPATH ?= $(PREFIX)/share/applications

4
system/isomaster/README Normal file
View File

@ -0,0 +1,4 @@
ISO Master is an open-source, easy to use, graphical CD image editor for
Linux and BSD. Basically you can use this program to extract files from an
ISO, add files to an ISO, and create bootable ISOs - all in a graphical
user interface. It can open both ISO and NRG files but can only save as ISO.

View File

@ -0,0 +1,3 @@
if [ -x usr/bin/update-desktop-database ]; then
usr/bin/update-desktop-database &> /dev/null
fi

View File

@ -0,0 +1,45 @@
#!/bin/sh
# Slackware build script for ISO Master
# Written by Erik Hanson erik@slackbuilds.org
PRGNAM=isomaster
VERSION=0.8.1
ARCH=${ARCH:-i486}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
CWD=`pwd`
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
fi
rm -rf $PKG
mkdir -p $TMP $PKG
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2 || exit 1
cd $PRGNAM-$VERSION
chown -R root:root .
chmod -R u+w,go+r-w,a-s .
# No autotools, do manually.
patch -p0 < $CWD/Makefile.patch || exit 1
CFLAGS="$SLKCFLAGS" make || exit 1
make install DESTDIR=$PKG || exit 1
strip --strip-unneeded $PKG/usr/bin/*
gzip -9 $PKG/usr/man/man?/*
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION $PKG/install
cp -a CHANGELOG.TXT CREDITS.TXT LICENCE.TXT README.TXT TODO.TXT $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz

View File

@ -0,0 +1,8 @@
PRGNAM="isomaster"
VERSION="0.8.1"
HOMEPAGE="http://littlesvr.ca/isomaster/index.php"
DOWNLOAD="http://littlesvr.ca/isomaster/releases/isomaster-0.8.1.tar.bz2"
MD5SUM="32066d9358f7f2601c3dc5344687f572"
MAINTAINER="Erik Hanson"
EMAIL="erik@slackbuilds.org"
APPROVED="BP{k}"

View File

@ -0,0 +1,11 @@
isomaster: ISO Master - an easy to use, graphical CD image editor.
isomaster:
isomaster: ISO Master is an open-source, easy to use, graphical CD image
isomaster: editor for Linux and BSD. Basically you can use this program to
isomaster: extract files from an ISO, add files to an ISO, and create
isomaster: bootable ISOs - all in a graphical user interface. It can open
isomaster: both ISO and NRG files but can only save as ISO.
isomaster:
isomaster:
isomaster: http://littlesvr.ca/isomaster/index.php
isomaster: