graphics/mangohud: Updated for version 0.6.9.
Signed-off-by: bedlam <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
55c94b6328
commit
58a577351c
|
@ -2,7 +2,7 @@
|
|||
|
||||
# Slackware build script for mangohud
|
||||
|
||||
# Copyright 2022 Steven Voges <svoges.sbo@gmail.com>
|
||||
# Copyright 2022-2023 Steven Voges <Oregon, USA>
|
||||
# All rights reserved.
|
||||
#
|
||||
# Redistribution and use of this script, with or without modification, is
|
||||
|
@ -26,16 +26,16 @@ cd $(dirname $0) ; CWD=$(pwd)
|
|||
|
||||
PRGNAM=mangohud
|
||||
SRCNAM=MangoHud
|
||||
VERSION=${VERSION:-0.6.8}
|
||||
SRCVER=${SRCVER:-0.6.8}
|
||||
IMGUIVER=${IMGUIVER:-1.81}
|
||||
SPDLOGVER=${SPDLOGVER:-1.8.5}
|
||||
VERSION=${VERSION:-0.6.9}
|
||||
SRCVER=${SRCVER:-0.6.9}
|
||||
IMGUI=${IMGUI:-1.81}
|
||||
SPDLOG=${SPDLOG:-1.8.5}
|
||||
VULKANHEADERS=${VULKANHEADERS:-1.2.158}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
PKGTYPE=${PKGTYPE:-tgz}
|
||||
COMPAT32=${COMPAT32:-no}
|
||||
XNVCTRL=${XNVCTRL:-disabled}
|
||||
SYSVULKAN=${SYSVULKAN:-enabled}
|
||||
MANGOAPP=${MANGOAPP:-true}
|
||||
|
||||
if [ -z "$ARCH" ]; then
|
||||
|
@ -77,15 +77,20 @@ cd $TMP
|
|||
rm -rf $SRCNAM-$SRCVER
|
||||
tar xvf $CWD/$SRCNAM-$SRCVER.tar.?z
|
||||
cd $SRCNAM-$SRCVER/subprojects
|
||||
tar xvf $CWD/imgui-$IMGUIVER.tar.gz
|
||||
unzip $CWD/imgui_$IMGUIVER-1_patch.zip
|
||||
tar xvf $CWD/spdlog-$SPDLOGVER.tar.gz
|
||||
unzip $CWD/spdlog_$SPDLOGVER-1_patch.zip
|
||||
tar xvf $CWD/Vulkan-Headers-$VULKANHEADERS.tar.gz
|
||||
unzip $CWD/vulkan-headers_$VULKANHEADERS-2_patch.zip
|
||||
tar xvf $CWD/imgui-$IMGUI.tar.gz
|
||||
unzip $CWD/imgui_$IMGUI-1_patch.zip
|
||||
tar xvf $CWD/spdlog-$SPDLOG.tar.gz
|
||||
unzip $CWD/spdlog_$SPDLOG-1_patch.zip
|
||||
cd ..
|
||||
chown -R root:root .
|
||||
|
||||
#Slackware 15.0 ships meson 59.4, and mangohud requires 60.0, so we patch it.
|
||||
patch -p0 <$CWD/meson594.patch
|
||||
sed -i "s/0.60.0/0.59.4/g" meson.build
|
||||
#Fix install_tag warnings that may become errors in the future.
|
||||
sed -i "/install_tag/d" data/meson.build
|
||||
sed -i "/install_tag/d" src/meson.build
|
||||
|
||||
find -L . \
|
||||
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
|
||||
|
@ -93,7 +98,6 @@ find -L . \
|
|||
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
|
||||
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
|
||||
|
||||
|
||||
mkdir build
|
||||
cd build
|
||||
CFLAGS="$SLKCFLAGS" \
|
||||
|
@ -107,7 +111,6 @@ cd build
|
|||
--mandir=/usr/man \
|
||||
--prefix=/usr \
|
||||
--sysconfdir=/etc \
|
||||
-Duse_system_vulkan=$SYSVULKAN \
|
||||
-Dwith_xnvctrl=$XNVCTRL \
|
||||
-Dmangoapp=$MANGOAPP
|
||||
ninja
|
||||
|
@ -131,9 +134,8 @@ if [ "$COMPAT32" = "yes" ]; then
|
|||
--mandir=/usr/man \
|
||||
--prefix=/usr \
|
||||
--sysconfdir=/etc \
|
||||
-Duse_system_vulkan=$SYSVULKAN \
|
||||
-Dwith_xnvctrl=$XNVCTRL \
|
||||
-Dmangoapp=$MANGOAPP
|
||||
-Dmangoapp=false
|
||||
ninja
|
||||
DESTDIR=$PKG ninja install
|
||||
cd ..
|
||||
|
@ -157,6 +159,5 @@ mkdir -p $PKG/install
|
|||
cat $CWD/slack-desc > $PKG/install/slack-desc
|
||||
cat $CWD/doinst.sh > $PKG/install/doinst.sh
|
||||
|
||||
|
||||
cd $PKG
|
||||
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
|
||||
|
|
|
@ -1,18 +1,22 @@
|
|||
PRGNAM="mangohud"
|
||||
VERSION="0.6.8"
|
||||
VERSION="0.6.9"
|
||||
HOMEPAGE="https://github.com/flightlessmango/MangoHud"
|
||||
DOWNLOAD="https://github.com/flightlessmango/MangoHud/archive/v0.6.8/MangoHud-0.6.8.tar.gz \
|
||||
DOWNLOAD="https://github.com/flightlessmango/MangoHud/archive/v0.6.9/MangoHud-0.6.9.tar.gz \
|
||||
https://github.com/KhronosGroup/Vulkan-Headers/archive/v1.2.158/Vulkan-Headers-1.2.158.tar.gz \
|
||||
https://github.com/mesonbuild/wrapdb/releases/download/vulkan-headers_1.2.158-2/vulkan-headers_1.2.158-2_patch.zip \
|
||||
https://github.com/ocornut/imgui/archive/v1.81/imgui-1.81.tar.gz \
|
||||
https://github.com/mesonbuild/wrapdb/releases/download/imgui_1.81-1/imgui_1.81-1_patch.zip \
|
||||
https://github.com/gabime/spdlog/archive/v1.8.5/spdlog-1.8.5.tar.gz \
|
||||
https://github.com/mesonbuild/wrapdb/releases/download/spdlog_1.8.5-1/spdlog_1.8.5-1_patch.zip"
|
||||
MD5SUM="414f8b321ec9e548e4f9ebed4f0d645c \
|
||||
MD5SUM="da45749b0052832d6d40e119f8a64a5b \
|
||||
44245ecbc0c428b1c8db58089eb59821 \
|
||||
4c47a8c306c495f94d2ec2fe8f611178 \
|
||||
9b48ac38829b538233f99c0aa8cacf50 \
|
||||
ea266ae77ac14290ceb2eafa56c1de83 \
|
||||
8755cdbc857794730a022722a66d431a \
|
||||
73a3c3149a4aa2b105aeef3a1d45bcb0"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES="glfw3 nlohmann_json %README%"
|
||||
REQUIRES="glfw3 nlohmann_json"
|
||||
MAINTAINER="Steven Voges"
|
||||
EMAIL="svoges.sbo@gmail.com"
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- meson.build 2022-07-31 18:27:11.000000000 -0700
|
||||
+++ meson.build 2022-08-14 01:07:17.385862414 -0700
|
||||
@@ -2,7 +2,7 @@
|
||||
['c', 'cpp'],
|
||||
version : 'v0.6.8',
|
||||
license : 'MIT',
|
||||
- meson_version: '>=0.60.0',
|
||||
+ meson_version: '>=0.59.4',
|
||||
default_options : ['buildtype=release', 'c_std=c99', 'cpp_std=c++14', 'warning_level=2']
|
||||
)
|
||||
|
Loading…
Reference in New Issue