desktop/lxqt-panel: Do not install files that conflict with lxqt-menu-data

Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
isaackwy 2024-01-02 03:07:34 -08:00 committed by Willy Sudiarto Raharjo
parent 3c9dd7d662
commit 56cbcd0be0
No known key found for this signature in database
GPG Key ID: 3F617144D7238786
2 changed files with 23 additions and 0 deletions

View File

@ -0,0 +1,20 @@
--- a/menu/CMakeLists.txt
+++ b/menu/CMakeLists.txt
@@ -8,17 +8,3 @@
)
add_custom_target(desktop_directories_files ALL DEPENDS ${DIRECTORY_FILES})
#************************************************
-
-install(FILES
- ${DIRECTORY_FILES}
- DESTINATION "${CMAKE_INSTALL_DATAROOTDIR}/desktop-directories"
- COMPONENT Runtime
-)
-
-install(FILES
- lxqt-applications.menu
- lxqt-applications-compact.menu
- lxqt-applications-simple.menu
- DESTINATION "${LXQT_ETC_XDG_DIR}/menus"
- COMPONENT Runtime
-)

View File

@ -82,6 +82,9 @@ find -L . \
# Build with libsysstat as optional dependency (enable System Stats plugin)
[ ${LIBSYSSTAT:-no} = yes ] && ENABLE_SYSSTAT=YES || ENABLE_SYSSTAT=NO
# lxqt-panel should not install files already included within lxqt-menu-data
patch -p1 < $CWD/lxqt-do_not_require_lxmenu_data.patch
mkdir build
cd build
cmake \