libraries/libreadline-java: Updated for version 0.8.2.

Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
Andrew Clemons 2017-06-30 13:09:58 +07:00 committed by Willy Sudiarto Raharjo
parent e7a9adca11
commit 563f93ecdc
6 changed files with 10 additions and 219 deletions

View File

@ -23,8 +23,8 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=libreadline-java
VERSION=${VERSION:-0.8.0}
BUILD=${BUILD:-3}
VERSION=${VERSION:-0.8.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@ -63,25 +63,6 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION-src.tar.gz
cd $PRGNAM-$VERSION
# allow building with clang
patch -p1 < $CWD/patches/8cf1b175458acd54cf2f4c2eee166dd8cdfe5e80.patch
sed -i 's/^CC/#CC/' src/native/Makefile
# fix collision with getline(3)
patch -p1 < $CWD/patches/8f1e8f8357c48088f72952860ede68f54dc61d8e.patch
# fix building against newer libedit
patch -p1 < $CWD/patches/c87604b44853663b6d101088db8f894aa4cfb6e3.patch
# make build respect our CFLAGS
sed -i -e "s/\(-fPIC -DPOSIX\)/\1 $SLKCFLAGS/" src/native/Makefile
# allow running on anything >= jdk1.6
sed -i -e "s/JC_FLAGS =/JC_FLAGS = -target 1.6 -source 1.6/" Makefile
# fix building docs with JDK8
sed -i -e 's/\(-version -author org.gnu.readline\)/\1 -Xdoclint:none/' Makefile
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@ -96,6 +77,8 @@ if pkg-config --exists libedit ; then
fi
for target in jar build-native apidoc ; do
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
make -j1 "$target" T_LIBS="$T_LIBS"
done
@ -108,7 +91,7 @@ find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | gr
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -r api $PKG/usr/doc/$PRGNAM-$VERSION
cp -a COPYING.LIB ChangeLog NEWS README README.1st TODO $PKG/usr/doc/$PRGNAM-$VERSION
cp -a COPYING.LIB ChangeLog NEWS README README.1st TODO.md $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install

View File

@ -1,8 +1,8 @@
PRGNAM="libreadline-java"
VERSION="0.8.0"
HOMEPAGE="http://java-readline.sourceforge.net/"
DOWNLOAD="https://sourceforge.net/projects/java-readline/files/libreadline-java-0.8.0-src.tar.gz"
MD5SUM="501720ddded45eaedf429b7cc356107c"
VERSION="0.8.2"
HOMEPAGE="https://github.com/aclemons/java-readline"
DOWNLOAD="https://github.com/aclemons/java-readline/releases/download/v0.8.2/libreadline-java-0.8.2-src.tar.gz"
MD5SUM="951c4bd5554a5640af3d5c81f753e2fc"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="jdk"

View File

@ -1,50 +0,0 @@
From 8cf1b175458acd54cf2f4c2eee166dd8cdfe5e80 Mon Sep 17 00:00:00 2001
From: Andrew Clemons <andrew.clemons@gmail.com>
Date: Sat, 10 Jun 2017 15:38:14 +1200
Subject: [PATCH] Fix compilation with clang
---
src/native/Makefile | 9 ++++-----
src/native/org_gnu_readline_Readline.c | 12 ++++++------
2 files changed, 10 insertions(+), 11 deletions(-)
diff --git a/src/native/org_gnu_readline_Readline.c b/src/native/org_gnu_readline_Readline.c
index 2877a16..1cf8493 100644
--- a/src/native/org_gnu_readline_Readline.c
+++ b/src/native/org_gnu_readline_Readline.c
@@ -341,7 +341,7 @@ JNIEXPORT void JNICALL Java_org_gnu_readline_Readline_initReadlineImpl
}
/* -------------------------------------------------------------------------- */
-/* Reset readline's internal states and terminal.
+/* Reset readline's internal states and terminal. */
/* -------------------------------------------------------------------------- */
#ifndef JavaGetline
@@ -356,7 +356,7 @@ JNIEXPORT void JNICALL Java_org_gnu_readline_Readline_cleanupReadlineImpl
/* -------------------------------------------------------------------------- */
-/* Report, if we have a terminal
+/* Report, if we have a terminal */
/* -------------------------------------------------------------------------- */
#ifndef JavaGetline
@@ -666,7 +666,7 @@ const char *java_completer(char *text, int state) {
jtext = (*jniEnv)->NewStringUTF(jniEnv,text);
if (jniMethodId == 0) {
- return;
+ return ((const char *) NULL);
}
completion = (*jniEnv)->CallObjectMethod(jniEnv, jniObject,
@@ -721,7 +721,7 @@ JNIEXPORT void JNICALL Java_org_gnu_readline_Readline_setCompleterImpl
#endif
/* -------------------------------------------------------------------------- */
-/* Returns rl_line_buffer
+/* Returns rl_line_buffer */
/* -------------------------------------------------------------------------- */
#ifndef JavaGetline

View File

@ -1,117 +0,0 @@
From 8f1e8f8357c48088f72952860ede68f54dc61d8e Mon Sep 17 00:00:00 2001
From: Andrew Clemons <andrew.clemons@gmail.com>
Date: Sat, 10 Jun 2017 19:28:41 +1200
Subject: [PATCH] Fix collision with getline(3).
---
src/native/getline.c | 16 ++++++++--------
src/native/getline.h | 6 +++---
2 files changed, 11 insertions(+), 11 deletions(-)
diff --git a/src/native/getline.c b/src/native/getline.c
index f9b3304..58e26e3 100644
--- a/src/native/getline.c
+++ b/src/native/getline.c
@@ -41,7 +41,7 @@ char* rl_readline_name;
/********************* exported interface ********************************/
-char *getline(); /* read a line of input */
+char *get_line(); /* read a line of input */
void gl_setwidth(); /* specify width of screen */
void gl_histadd(); /* adds entries to hist */
void gl_strwidth(); /* to bind gl_strlen */
@@ -387,7 +387,7 @@ gl_init()
hist_init();
}
if (isatty(0) == 0 || isatty(1) == 0)
- gl_error("\n*** Error: getline(): not interactive, use stdio.\n");
+ gl_error("\n*** Error: get_line(): not interactive, use stdio.\n");
gl_char_init();
gl_init_done = 1;
}
@@ -414,7 +414,7 @@ int w;
}
char *
-getline(prompt)
+get_line(prompt)
char *prompt;
{
int c, loc, tmp;
@@ -585,7 +585,7 @@ int c;
int i;
if (gl_cnt >= BUF_SIZE - 1)
- gl_error("\n*** Error: getline(): input buffer overflow\n");
+ gl_error("\n*** Error: get_line(): input buffer overflow\n");
if (gl_overwrite == 0 || gl_pos == gl_cnt) {
for (i=gl_cnt; i >= gl_pos; i--)
gl_buf[i+1] = gl_buf[i];
@@ -608,7 +608,7 @@ gl_yank()
if (len > 0) {
if (gl_overwrite == 0) {
if (gl_cnt + len >= BUF_SIZE - 1)
- gl_error("\n*** Error: getline(): input buffer overflow\n");
+ gl_error("\n*** Error: get_line(): input buffer overflow\n");
for (i=gl_cnt; i >= gl_pos; i--)
gl_buf[i+len] = gl_buf[i];
for (i=0; i < len; i++)
@@ -617,7 +617,7 @@ gl_yank()
} else {
if (gl_pos + len > gl_cnt) {
if (gl_pos + len >= BUF_SIZE - 1)
- gl_error("\n*** Error: getline(): input buffer overflow\n");
+ gl_error("\n*** Error: get_line(): input buffer overflow\n");
gl_buf[gl_pos + len] = 0;
}
for (i=0; i < len; i++)
@@ -657,7 +657,7 @@ gl_newline()
int loc = gl_width - 5; /* shifts line back to start position */
if (gl_cnt >= BUF_SIZE - 1)
- gl_error("\n*** Error: getline(): input buffer overflow\n");
+ gl_error("\n*** Error: get_line(): input buffer overflow\n");
if (gl_out_hook) {
change = gl_out_hook(gl_buf);
len = strlen(gl_buf);
@@ -916,7 +916,7 @@ char *buf;
char *p = buf;
int len;
- /* in case we call gl_histadd() before we call getline() */
+ /* in case we call gl_histadd() before we call get_line() */
if (gl_init_done < 0) { /* -1 only on startup */
hist_init();
gl_init_done = 0;
diff --git a/src/native/getline.h b/src/native/getline.h
index a10bb47..e8dc8b2 100644
--- a/src/native/getline.h
+++ b/src/native/getline.h
@@ -9,7 +9,7 @@
extern char* rl_readline_name; /* unused by getline */
#define add_history(buffer) gl_histadd(buffer)
-#define readline(buffer) getline(buffer)
+#define readline(buffer) get_line(buffer)
#define clear_history() hist_init()
#define using_history() hist_init()
@@ -18,7 +18,7 @@ extern char* rl_readline_name; /* unused by getline */
typedef size_t (*gl_strwidth_proc)(char *);
-char *getline(char *); /* read a line of input */
+char *get_line(char *); /* read a line of input */
void gl_setwidth(int); /* specify width of screen */
void gl_histadd(char *); /* adds entries to hist */
void gl_strwidth(gl_strwidth_proc); /* to bind gl_strlen */
@@ -30,7 +30,7 @@ extern int (*gl_tab_hook)(char *, int, int *);
#else /* not __STDC__ */
-char *getline();
+char *get_line();
void gl_setwidth();
void gl_histadd();
void gl_strwidth();

View File

@ -1,25 +0,0 @@
From c87604b44853663b6d101088db8f894aa4cfb6e3 Mon Sep 17 00:00:00 2001
From: Andrew Clemons <andrew.clemons@gmail.com>
Date: Sat, 10 Jun 2017 16:10:00 +1200
Subject: [PATCH] Fix building against new libedit
---
src/native/org_gnu_readline_Readline.c | 4 ----
1 file changed, 4 deletions(-)
diff --git a/src/native/org_gnu_readline_Readline.c b/src/native/org_gnu_readline_Readline.c
index 1cf8493..edc246c 100644
--- a/src/native/org_gnu_readline_Readline.c
+++ b/src/native/org_gnu_readline_Readline.c
@@ -708,11 +708,7 @@ JNIEXPORT void JNICALL Java_org_gnu_readline_Readline_setCompleterImpl
rl_completion_entry_function = NULL;
return;
}
-#ifdef JavaEditline
- rl_completion_entry_function = (CPFunction *) java_completer;
-#else
rl_completion_entry_function = (rl_compentry_func_t *) java_completer;
-#endif
}
else {
rl_completion_entry_function = NULL;

View File

@ -12,7 +12,7 @@ libreadline-java: Java-Readline is a port of GNU Readline for Java. Or, to be mo
libreadline-java: precise, it is a JNI-wrapper to Readline. It is distributed under the
libreadline-java: LGPL.
libreadline-java:
libreadline-java: http://java-readline.sourceforge.net/
libreadline-java: https://github.com/aclemons/java-readline
libreadline-java:
libreadline-java:
libreadline-java: