academic/tophat: Fix Build.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
f6f216c1ea
commit
55988a5e80
|
@ -0,0 +1,24 @@
|
|||
Description: Resolves build failure with seqan 1.4
|
||||
Bug-Closed: http://bugs.debian.org/733352
|
||||
Author: Manuel Holtgrewe <manuel.holtgrewe@fu-berlin.de>
|
||||
--- a/src/segment_juncs.cpp
|
||||
+++ b/src/segment_juncs.cpp
|
||||
@@ -2050,10 +2050,13 @@ void juncs_from_ref_segs(RefSequenceTabl
|
||||
typedef map<uint32_t, IntronMotifs> MotifMap;
|
||||
|
||||
MotifMap ims;
|
||||
-
|
||||
- seqan::DnaStringReverseComplement rev_donor_dinuc(donor_dinuc);
|
||||
- seqan::DnaStringReverseComplement rev_acceptor_dinuc(acceptor_dinuc);
|
||||
-
|
||||
+
|
||||
+ typedef seqan::ModifiedString<
|
||||
+ seqan::ModifiedString<seqan::DnaString const, seqan::ModView<seqan::FunctorComplement<seqan::Dna> > >,
|
||||
+ seqan::ModReverse> ConstDnaStringReverseComplement;
|
||||
+ ConstDnaStringReverseComplement rev_donor_dinuc(donor_dinuc);
|
||||
+ ConstDnaStringReverseComplement rev_acceptor_dinuc(acceptor_dinuc);
|
||||
+
|
||||
if (talkative)
|
||||
fprintf(stderr, "Collecting potential splice sites in islands\n");
|
||||
|
||||
|
|
@ -62,25 +62,41 @@ cd $TMP
|
|||
rm -rf $PRGNAM-$VERSION
|
||||
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
|
||||
cd $PRGNAM-$VERSION
|
||||
tar xvf $CWD/seqan-v1.4.2.tar.gz
|
||||
chown -R root:root .
|
||||
find -L . \
|
||||
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
|
||||
-o -perm 511 \) -exec chmod 755 {} \; -o \
|
||||
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
|
||||
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
|
||||
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
|
||||
|
||||
CFLAGS="$SLKCFLAGS" \
|
||||
sed -e 's|-gdwarf-2||' \
|
||||
-e '/define.*esyscmd/d' \
|
||||
-e 's/svnversion/Unversioned directory/' \
|
||||
-i configure.ac
|
||||
|
||||
sed -e 's|make $(SAMPROG)|make -e $(SAMPROG)|' \
|
||||
-i src/Makefile.am
|
||||
|
||||
# fixes seqan issues, Thanks to ARCH
|
||||
rm -rf src/SeqAn-1.3
|
||||
patch -p1 < $CWD/fix_build_w_seqan1.4.patch
|
||||
sed -e "s|-I./SeqAn-1.3|-I$TMP/$PRGNAM-$VERSION/seqan-seqan-v1.4.2/core/include|" configure.ac
|
||||
|
||||
autoreconf -fi
|
||||
CFLAGS="$SLKCFLAGS -I$TMP/$PRGNAM-$VERSION/seqan-seqan-v1.4.2/core/include" \
|
||||
CXXFLAGS="$SLKCFLAGS" \
|
||||
./configure \
|
||||
--prefix=/usr \
|
||||
--libdir=/usr/lib${LIBDIRSUFFIX} \
|
||||
--sysconfdir=/etc \
|
||||
--with-boost-libdir=/usr/lib${LIBDIRSUFFIX} \
|
||||
--localstatedir=/var \
|
||||
--mandir=/usr/man \
|
||||
--build=$ARCH-slackware-linux
|
||||
|
||||
make
|
||||
sed -i 's|-L/usr/lib||' Makefile src/Makefile
|
||||
|
||||
make -j1
|
||||
make install DESTDIR=$PKG
|
||||
|
||||
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
|
||||
|
|
|
@ -1,8 +1,10 @@
|
|||
PRGNAM="tophat"
|
||||
VERSION="2.1.0"
|
||||
HOMEPAGE="http://ccb.jhu.edu/software/tophat/"
|
||||
DOWNLOAD="http://ccb.jhu.edu/software/tophat/downloads/tophat-2.1.0.tar.gz"
|
||||
MD5SUM="34afa379b030c6672a31bbe3689745bc"
|
||||
DOWNLOAD="http://ccb.jhu.edu/software/tophat/downloads/tophat-2.1.0.tar.gz \
|
||||
https://github.com/seqan/seqan/archive/seqan-v1.4.2.tar.gz"
|
||||
MD5SUM="34afa379b030c6672a31bbe3689745bc \
|
||||
7b0080b01feeb223e054dabef53d6fc5"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES=""
|
||||
|
|
Loading…
Reference in New Issue