libraries/qt-assistant-compat: Added (Qt Assistant compatibility)

Signed-off-by: Niels Horn <niels.horn@slackbuilds.org>
This commit is contained in:
Petar Petrov 2011-10-19 23:08:30 -02:00 committed by Niels Horn
parent ebd7439e5f
commit 5327d32896
5 changed files with 193 additions and 0 deletions

View File

@ -0,0 +1,4 @@
This package contains the Qt Assistant compatibility version, based
on Assistant Document Profile (.adp) files, and the associated
QtAssistantClient library, for compatibility with applications
providing help in that format.

View File

@ -0,0 +1,48 @@
Description: several workarounds for the build system which is completely broken
Author: Fathi Boudra <fabo@debian.org>
--- a/compat.pro
+++ b/compat.pro
@@ -66,8 +66,6 @@ TRANSLATIONS = translations/assistant_ad
translations/assistant_adp_zh_CN.ts \
translations/assistant_adp_zh_TW.ts
-unix:!contains(QT_CONFIG, zlib):LIBS += -lz
-
contains(CONFIG, static): {
win32 {
exists($$[QT_INSTALL_PLUGINS]/imageformats/qjpeg.lib) {
@@ -81,3 +79,7 @@ contains(CONFIG, static): {
}
}
}
+
+target.path = $$[QT_INSTALL_BINS]
+INSTALLS += target
+
--- a/lib/lib.pro
+++ b/lib/lib.pro
@@ -16,8 +16,8 @@ HEADERS = qassistantclient.h \
qassistantclient_global.h
SOURCES = qassistantclient.cpp
-DESTDIR = ../../../../lib
-DLLDESTDIR = ../../../../bin
+DESTDIR = lib
+DLLDESTDIR = bin
unix {
QMAKE_CFLAGS += $$QMAKE_CFLAGS_SHLIB
@@ -62,7 +62,7 @@ win32 {
}
qt_install_headers {
- assistant_headers.files = $$SYNCQT.HEADER_FILES $$SYNCQT.HEADER_CLASSES
+ assistant_headers.files = qassistantclient.h qassistantclient_global.h
assistant_headers.path = $$[QT_INSTALL_HEADERS]/QtAssistant
INSTALLS += assistant_headers
}
--- /dev/null
+++ b/lib/QtAssistant/qassistantclient_global.h
@@ -0,0 +1 @@
+#include "../qassistantclient_global.h"

View File

@ -0,0 +1,112 @@
#!/bin/sh
# Slackware build script for qt-assistant-compat
# Written by Petar Petrov, <ppetrov@paju.oulu.fi> and
# hereby submitted to the public domain
# Based on the qt-assistant-compat package PKGBUILD from Arch
# Extra. Maintainer and packager is Ronald van Haren. Thank you!
# http://www.archlinux.org/packages/extra/i686/qt-assistant-compat/
# THIS SLACKBUILD IS DISTRIBUTETD IN THE HOPE OF BEING
# USEFUL BUT WITHOUT ANY WARRANTY. THE AUTHOR IS _NOT_
# RESPONSIBLE FOR ANY DAMAGE OR DATA LOSS CAUSED BY IT.
PRGNAM=qt-assistant-compat
VERSION=${VERSION:-4.6.3}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
SRCNAM=qt-assistant-qassistantclient-library-compat-src
SRCDIR=qt-assistant-qassistantclient-library-compat-version
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) export ARCH=i486 ;;
arm*) export ARCH=arm ;;
*) export ARCH=$( uname -m ) ;;
esac
fi
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
fi
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $SRCDIR-$VERSION
tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
cd $SRCDIR-$VERSION
chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
# The patch is from Archlinux, as mentioned above.
# For Archlinux it has been taken from Debian. Thank you both!
patch -Np1 -i $CWD/debian_patches_01_build_system.diff
cd lib
qmake CONFIG+=create_prl
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
make
make install INSTALL_ROOT=$PKG
cd ..
# Convert XML-based translations files from the TS
# format into the "compiled" QM format
lrelease translations/assistant_adp_*.ts
qmake CONFIG+=create_prl
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
make
make install INSTALL_ROOT=$PKG
# Fix wrong path in prl file
sed -i -e /^QMAKE_PRL_BUILD_DIR/d $PKG/usr/lib${LIBDIRSUFFIX}/qt/lib/libQtAssistantClient.prl
cd translations
mkdir -p $PKG/usr/lib${LIBDIRSUFFIX}/qt/translations
cp assistant_adp_*.qm $PKG/usr/lib${LIBDIRSUFFIX}/qt/translations/
cd ..
cd features
install -D -m644 assistant.prf $PKG/usr/lib${LIBDIRSUFFIX}/qt/mkspecs/features/assistant.prf
cd -
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
LGPL_EXCEPTION.txt LICENSE.LGPL LICENSE.GPL3 \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}

View File

@ -0,0 +1,10 @@
PRGNAM="qt-assistant-compat"
VERSION="4.6.3"
HOMEPAGE="http://doc.qt.nokia.com/4.6/qassistantclient.html"
DOWNLOAD="ftp://ftp.qt.nokia.com/qt/source/qt-assistant-qassistantclient-library-compat-src-4.6.3.tar.gz"
MD5SUM="a20148e0488d5c12ab35ccc107dcc64d"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MAINTAINER="Petar Petrov"
EMAIL="ppetrov@paju.oulu.fi"
APPROVED="Niels Horn"

View File

@ -0,0 +1,19 @@
# HOW TO EDIT THIS FILE:
# The "handy ruler" below makes it easier to edit a package description. Line
# up the first '|' above the ':' following the base package name, and the '|'
# on the right side marks the last column you can put a character in. You must
# make exactly 11 lines for the formatting to be correct. It's also
# customary to leave one space after the ':'.
|-----handy-ruler------------------------------------------------------|
qt-assistant-compat: qt-assistant-compat (Qt Assistant compatibility)
qt-assistant-compat:
qt-assistant-compat: This package contains the Qt Assistant compatibility version, based
qt-assistant-compat: on Assistant Document Profile (.adp) files, and the associated
qt-assistant-compat: QtAssistantClient library, for compatibility with applications
qt-assistant-compat: providing help in that format.
qt-assistant-compat:
qt-assistant-compat:
qt-assistant-compat:
qt-assistant-compat:
qt-assistant-compat: Home: http://doc.qt.nokia.com/4.6/qassistantclient.html