audio/yoshimi: Updated for version 1.5.9.
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
This commit is contained in:
parent
0c2574dc2f
commit
5271b151a9
|
@ -1,54 +0,0 @@
|
|||
From 86532198f0467c6d29090ce7ad95bcb36cd697f6 Mon Sep 17 00:00:00 2001
|
||||
From: Andrew Deryabin <andrew@audioplugins.org>
|
||||
Date: Tue, 3 Feb 2015 06:08:57 +0000
|
||||
Subject: [PATCH 1/2] Fix for fltk < 1.3
|
||||
|
||||
---
|
||||
src/main.cpp | 21 ++++++++++++++++++++-
|
||||
1 file changed, 20 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/main.cpp b/src/main.cpp
|
||||
index ab995ad..18a36d2 100644
|
||||
--- a/src/main.cpp
|
||||
+++ b/src/main.cpp
|
||||
@@ -30,6 +30,8 @@ using namespace std;
|
||||
#include <list>
|
||||
#include <pthread.h>
|
||||
#include <semaphore.h>
|
||||
+#include <cstdio>
|
||||
+#include <unistd.h>
|
||||
|
||||
#include <FL/Fl.H>
|
||||
#include <FL/Fl_Window.H>
|
||||
@@ -97,10 +99,27 @@ static void *mainGuiThread(void *arg)
|
||||
|
||||
map<SynthEngine *, MusicClient *>::iterator it;
|
||||
fl_register_images();
|
||||
+#if (FL_MAJOR_VERSION == 1 && FL_MINOR_VERSION < 3)
|
||||
+ char *fname = tmpnam(NULL);
|
||||
+ if(fname)
|
||||
+ {
|
||||
+ FILE *f = fopen(fname, "wb");
|
||||
+ if(f)
|
||||
+ {
|
||||
+ fwrite(yoshimi_logo_png, sizeof(yoshimi_logo_png), 1, f);
|
||||
+ fclose(f);
|
||||
+ }
|
||||
+ }
|
||||
+ Fl_PNG_Image pix(fname);
|
||||
+ if(fname)
|
||||
+ unlink(fname);
|
||||
+#else
|
||||
+ Fl_PNG_Image pix("yoshimi_logo_png", yoshimi_logo_png, sizeof(yoshimi_logo_png));
|
||||
+#endif
|
||||
Fl_Window winSplash(400, 300, "yoshimi splash screen");
|
||||
Fl_Box box(0, 0, 400,300);
|
||||
//Fl_Pixmap pix(yoshimi_logo);
|
||||
- Fl_PNG_Image pix("yoshimi_logo_png", yoshimi_logo_png, sizeof(yoshimi_logo_png));
|
||||
+
|
||||
box.image(pix);
|
||||
Fl_Box boxLb(10, 300-30, 400-20, 30);
|
||||
boxLb.box(FL_NO_BOX);
|
||||
--
|
||||
2.2.2
|
||||
|
|
@ -1,3 +1,9 @@
|
|||
if [ -x /usr/bin/update-desktop-database ]; then
|
||||
/usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
|
||||
fi
|
||||
|
||||
if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
|
||||
if [ -x /usr/bin/gtk-update-icon-cache ]; then
|
||||
/usr/bin/gtk-update-icon-cache -f usr/share/icons/hicolor >/dev/null 2>&1
|
||||
fi
|
||||
fi
|
||||
|
|
|
@ -5,13 +5,13 @@
|
|||
# Written by Zbigniew Baniewski, <Zbigniew [dot] Baniewski [at] gmail [dot] com>
|
||||
|
||||
PRGNAM=yoshimi
|
||||
VERSION=${VERSION:-1.3.2}
|
||||
VERSION=${VERSION:-1.5.9}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
if [ -z "$ARCH" ]; then
|
||||
case "$( uname -m )" in
|
||||
i?86) ARCH=i486 ;;
|
||||
i?86) ARCH=i586 ;;
|
||||
arm*) ARCH=arm ;;
|
||||
*) ARCH=$( uname -m ) ;;
|
||||
esac
|
||||
|
@ -22,8 +22,8 @@ TMP=${TMP:-/tmp/SBo}
|
|||
PKG=$TMP/package-$PRGNAM
|
||||
OUTPUT=${OUTPUT:-/tmp}
|
||||
|
||||
if [ "$ARCH" = "i486" ]; then
|
||||
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
|
||||
if [ "$ARCH" = "i586" ]; then
|
||||
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
|
||||
LIBDIRSUFFIX=""
|
||||
elif [ "$ARCH" = "i686" ]; then
|
||||
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
|
||||
|
@ -42,7 +42,7 @@ rm -rf $PKG
|
|||
mkdir -p $TMP $PKG $OUTPUT
|
||||
cd $TMP
|
||||
rm -rf $PRGNAM-$VERSION
|
||||
tar jxvf $CWD/${PRGNAM}-${VERSION}.tar.bz2
|
||||
tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
|
||||
cd $PRGNAM-$VERSION
|
||||
chown -R root:root .
|
||||
find -L . \
|
||||
|
@ -51,33 +51,33 @@ find -L . \
|
|||
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
|
||||
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
|
||||
|
||||
cat $CWD/0001-Fix-for-fltk-1.3.patch | patch -p1
|
||||
|
||||
cd src
|
||||
# Both "DDefaultAudio/Midi..." lines can be removed for default JACK audio/MIDI
|
||||
sed -i \
|
||||
-e "s|\${CMAKE_INSTALL_DATAROOTDIR}/doc/yoshimi|/usr/doc/$PRGNAM-$VERSION|" \
|
||||
CMakeLists.txt
|
||||
|
||||
mkdir -p build
|
||||
cd build
|
||||
cmake \
|
||||
-DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
|
||||
-DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
|
||||
-DCMAKE_INSTALL_PREFIX:PATH=/usr \
|
||||
-DDefaultAudio:STRING=alsa \
|
||||
-DDefaultMidi:STRING=alsa \
|
||||
.
|
||||
-DCMAKE_INSTALL_MANDIR=/usr/man \
|
||||
-DCMAKE_BUILD_TYPE=Release ..
|
||||
|
||||
make VERBOSE=1
|
||||
make install DESTDIR=$PKG
|
||||
cd ..
|
||||
|
||||
# Move man pages to correct location
|
||||
#mv $PKG/usr/share/man $PKG/usr/
|
||||
cd ../..
|
||||
|
||||
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
|
||||
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
|
||||
|
||||
#find $PKG/usr/man -type f -exec gzip -9 {} \;
|
||||
#for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
|
||||
find $PKG/usr/man -type f -exec gzip -9 {} \;
|
||||
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
|
||||
|
||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp -a Changelog COPYING INSTALL README.txt $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp -a Changelog COPYING INSTALL README.txt \
|
||||
$PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||
|
||||
mkdir -p $PKG/install
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
PRGNAM="yoshimi"
|
||||
VERSION="1.3.2"
|
||||
VERSION="1.5.9"
|
||||
HOMEPAGE="http://yoshimi.sourceforge.net/"
|
||||
DOWNLOAD="http://downloads.sourceforge.net/yoshimi/1.1/yoshimi-1.3.2.tar.bz2"
|
||||
MD5SUM="48aefa60c1f451b6ea39a4a36583f8ab"
|
||||
DOWNLOAD="http://downloads.sourceforge.net/yoshimi/1.5/yoshimi-1.5.9.tar.bz2"
|
||||
MD5SUM="5368486f9b1525ac9026e0934bbcb9ac"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES="mxml fltk lv2 jack-audio-connection-kit"
|
||||
|
|
Loading…
Reference in New Issue