development/bzr: Updated for version 1.14
This commit is contained in:
parent
3783237f6f
commit
512f39e2a6
|
@ -2,5 +2,7 @@ Bazaar (bzr) is a decentralized revision control system, designed
|
|||
to be easy for developers and end users alike. Bazaar is part of the
|
||||
GNU project to develop a complete free operating system.
|
||||
|
||||
This requires docutils, which is also available from SlackBuilds.org,
|
||||
but it is only a build dependency - it is not needed for running bzr.
|
||||
This optionally requires docutils for docs generation, but it is only a
|
||||
build dependency - it is not needed for running bzr. Even without the
|
||||
docutils package installed, there will still be some documentation with
|
||||
the package, so you probably don't need it.
|
||||
|
|
|
@ -2,7 +2,7 @@
|
|||
|
||||
# Slackware build script for bzr
|
||||
|
||||
# Copyright 2006-2008 Robby Workman Northport, AL, USA
|
||||
# Copyright 2006-2009 Robby Workman Northport, AL, USA
|
||||
# All rights reserved.
|
||||
#
|
||||
# Redistribution and use of this script, with or without modification, is
|
||||
|
@ -23,9 +23,9 @@
|
|||
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
|
||||
PRGNAM=bzr
|
||||
VERSION=1.5
|
||||
VERSION=1.14
|
||||
ARCH=${ARCH:-i486}
|
||||
BUILD=${BUILD:-2}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
CWD=$(pwd)
|
||||
|
@ -56,13 +56,8 @@ find . \
|
|||
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
||||
-exec chmod 644 {} \;
|
||||
|
||||
# Fix suggested by guys from #bzr at irc.freenode.net
|
||||
# Thanks to zpcspm@gmail.com for pointing this out to me
|
||||
patch tools/rst2html.py < $CWD/rst2html.py.patch
|
||||
|
||||
# Generate docs
|
||||
make docs
|
||||
|
||||
# Generate docs - this will fail if python docutils is not installed
|
||||
make docs 2>/dev/null || true
|
||||
python setup.py install --root=$PKG
|
||||
|
||||
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
|
||||
|
@ -74,8 +69,9 @@ find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
|
|||
)
|
||||
|
||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp -a BRANCH.TODO COPYING.txt INSTALL NEWS README TODO doc/* \
|
||||
$PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp -a \
|
||||
BRANCH.TODO COPYING.txt INSTALL NEWS README TODO doc/* \
|
||||
$PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||
|
||||
mkdir -p $PKG/install
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
PRGNAM="bzr"
|
||||
VERSION="1.5"
|
||||
VERSION="1.14"
|
||||
HOMEPAGE="http://bazaar-vcs.org/"
|
||||
DOWNLOAD="https://launchpad.net/bzr/1.5/1.5/+download/bzr-1.5.tar.gz"
|
||||
MD5SUM="fa82e556401802537eeb8e50ecc8b4e7"
|
||||
DOWNLOAD="https://launchpad.net/bzr/1.14/1.14/+download/bzr-1.14.tar.gz"
|
||||
MD5SUM="1180a563b525e196ac1cb89110d05432"
|
||||
MAINTAINER="Robby Workman"
|
||||
EMAIL="rw@rlworkman.net"
|
||||
APPROVED="David Somero"
|
||||
APPROVED="Erik Hanson"
|
||||
|
|
|
@ -1,12 +0,0 @@
|
|||
--- /tmp/ttt/bzr-1.5/tools/rst2html.py 2008-05-16 22:21:24.000000000 +0000
|
||||
+++ rst2html.py 2008-08-06 16:46:29.000000000 +0000
|
||||
@@ -20,7 +20,8 @@
|
||||
from docutils.core import publish_cmdline, default_description
|
||||
|
||||
|
||||
-if docutils.__version__ <= '0.4.1':
|
||||
+if True:
|
||||
+#if docutils.__version__ <= '0.4.1':
|
||||
from docutils.parsers.rst.states import Body
|
||||
# we have some option names that contain dot; which is not allowed by
|
||||
# python-docutils 0.4-4 -- so monkeypatch in a better pattern
|
|
@ -5,15 +5,15 @@
|
|||
# make exactly 11 lines for the formatting to be correct. It's also
|
||||
# customary to leave one space after the ':'.
|
||||
|
||||
|-----handy-ruler--------------------------------------------------------|
|
||||
|-----handy-ruler-------------------------------------------------------|
|
||||
bzr: bzr (Bazaar revision control system)
|
||||
bzr:
|
||||
bzr:
|
||||
bzr: Bazaar (``bzr``) is a decentralized revision control system, designed
|
||||
bzr: to be easy for developers and end users alike. Bazaar is part of the
|
||||
bzr: GNU project to develop a complete free operating system.
|
||||
bzr:
|
||||
bzr:
|
||||
bzr: Homepage: http://bazaar-vcs.org/
|
||||
bzr:
|
||||
bzr:
|
||||
bzr:
|
||||
bzr:
|
||||
bzr:
|
||||
bzr:
|
||||
bzr:
|
||||
bzr:
|
||||
|
|
Loading…
Reference in New Issue