network/smuxi: Updated for version 0.8.10.
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
This commit is contained in:
parent
47a2a9abc6
commit
50b5afdab4
|
@ -5,7 +5,7 @@
|
|||
# Written by crocket (crockabiscuit@yahoo.com)
|
||||
|
||||
PRGNAM=smuxi
|
||||
VERSION=${VERSION:-0.7.1}
|
||||
VERSION=${VERSION:-0.8.10}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
|
@ -53,9 +53,6 @@ find . \
|
|||
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
||||
-exec chmod 644 {} \;
|
||||
|
||||
patch -p1 < $CWD/xbuild_on_mono2_6.patch
|
||||
autoreconf
|
||||
|
||||
CFLAGS="$SLKCFLAGS" \
|
||||
CXXFLAGS="$SLKCFLAGS" \
|
||||
./configure \
|
||||
|
@ -71,14 +68,6 @@ CXXFLAGS="$SLKCFLAGS" \
|
|||
make
|
||||
make install DESTDIR=$PKG
|
||||
|
||||
# Create the png image from svg since KDE menus don't support SVG well.
|
||||
PIXMAP=$PKG/usr/share/pixmaps
|
||||
convert -transparent white $PKG/usr/share/pixmaps/smuxi-frontend-gnome.svg \
|
||||
$PKG/usr/share/pixmaps/smuxi-frontend-gnome.png
|
||||
# Adjust the Desktop setting
|
||||
sed -i "s|.svg|.png|g" \
|
||||
$PKG/usr/share/applications/smuxi-frontend-gnome.desktop
|
||||
|
||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp -a \
|
||||
BUGS CREDITS FEATURES LICENSE PROFILING README TODO \
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
PRGNAM="smuxi"
|
||||
VERSION="0.7.1"
|
||||
VERSION="0.8.10"
|
||||
HOMEPAGE="http://www.smuxi.org/"
|
||||
DOWNLOAD="http://www.smuxi.org/jaws/data/files/smuxi-0.7.1.tar.gz"
|
||||
MD5SUM="02f7b0789a18f09157c5207c19525844"
|
||||
DOWNLOAD="http://www.smuxi.org/jaws/data/files/smuxi-0.8.10.tar.gz"
|
||||
MD5SUM="73ea97133186a42aee235592770f96e3"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES="gtk-sharp log4net nini smartirc4net"
|
||||
|
|
|
@ -1,13 +0,0 @@
|
|||
diff --git a/lib/Twitterizer.Framework/Makefile.am b/lib/Twitterizer.Framework/Makefile.am
|
||||
index 8de6969..1116489 100644
|
||||
--- a/lib/Twitterizer.Framework/Makefile.am
|
||||
+++ b/lib/Twitterizer.Framework/Makefile.am
|
||||
@@ -6,7 +6,7 @@ ASSEMBLY_NAME = Twitterizer.Framework.dll
|
||||
ASSEMBLY_TARGET = $(OUTPUT_DIR)/$(ASSEMBLY_NAME)
|
||||
KEY_FILE = $(srcdir)/Twitterizer.Framework.snk
|
||||
BUILD_FILE = $(srcdir)/Twitterizer.Framework.vs2008.csproj
|
||||
-XBUILD_FLAGS = /p:Configuration=Debug /p:NoWarn=CS0168 /p:OutputPath=$(abspath $(OUTPUT_DIR)) /p:BaseIntermediateOutputPath=$(abspath $(OBJECT_DIR))/
|
||||
+XBUILD_FLAGS = /p:Configuration=Debug /p:NoWarn=0168 /p:OutputPath=$(abspath $(OUTPUT_DIR)) /p:BaseIntermediateOutputPath=$(abspath $(OBJECT_DIR))/
|
||||
|
||||
# magic automake variables
|
||||
if ENABLE_ENGINE_TWITTER
|
Loading…
Reference in New Issue