graphics/vulkan-sdk: Removed (added to Slackware).

Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
This commit is contained in:
Matteo Bernardini 2021-01-02 10:39:41 +01:00 committed by Robby Workman
parent 0d376d636f
commit 508ee2d062
5 changed files with 0 additions and 278 deletions

View File

@ -1,11 +0,0 @@
Vulkan supports multiple GPUs and multiple global contexts (VkInstance).
The ICD loader is necessary to support multiple GPUs and the VkInstance
level Vulkan commands. Additionally, the loader manages inserting Vulkan
layer libraries, including validation layers between the application and
the ICD.
qt5 is an optional dependency for vkconfig.
This will not provide a vulkan driver which must be acquired elsewhere.
This SlackBuild will compile vulkan-sdk from source.

View File

@ -1,19 +0,0 @@
# HOW TO EDIT THIS FILE:
# The "handy ruler" below makes it easier to edit a package description.
# Line up the first '|' above the ':' following the base package name, and
# the '|' on the right side marks the last column you can put a character in.
# You must make exactly 11 lines for the formatting to be correct. It's also
# customary to leave one space after the ':' except on otherwise blank lines.
|-----handy-ruler------------------------------------------------------|
vulkan-sdk: vulkan-sdk (Vulkan ICD Loader and Validation Layers)
vulkan-sdk:
vulkan-sdk: Vulkan supports multiple GPUs and multiple global contexts
vulkan-sdk: (VkInstance). The ICD loader is necessary to support multiple GPUs
vulkan-sdk: and the VkInstance level Vulkan commands. Additionally, the loader
vulkan-sdk: manages inserting Vulkan layer libraries, including validation layers
vulkan-sdk: between the application and the ICD.
vulkan-sdk:
vulkan-sdk: Homepage: https://www.khronos.org/vulkan/
vulkan-sdk:
vulkan-sdk:

View File

@ -1,13 +0,0 @@
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d15214545..fe277fcd6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -138,7 +138,7 @@ if(CMAKE_COMPILER_IS_GNUCC OR CMAKE_C_COMPILER_ID MATCHES "Clang")
# all compilers until they all accept the C++17 standard
if(CMAKE_COMPILER_IS_GNUCC)
set(COMMON_COMPILE_FLAGS "${COMMON_COMPILE_FLAGS} -Wno-stringop-truncation -Wno-stringop-overflow")
- if(CMAKE_CXX_COMPILER_VERSION GREATER_EQUAL 7.1)
+ if(CMAKE_CXX_COMPILER_VERSION VERSION_EQUAL 7.1 OR CMAKE_CXX_COMPILER_VERSION VERSION_GREATER 7.1)
set(COMMON_COMPILE_FLAGS "${COMMON_COMPILE_FLAGS} -Wimplicit-fallthrough=0")
endif()
endif()

View File

@ -1,217 +0,0 @@
#!/bin/sh
# Slackware build script for vulkan-sdk
# Copyright 2016, 2017 Heinz Wiesinger, Amsterdam, The Netherlands
# Copyright 2016, 2017, 2018 Patrick J. Volkerding, Sebeka, MN, USA
# Copyright 2019-2020 Hunter Sezen California, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
# notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=vulkan-sdk
VERSION=${VERSION:-1.2.162.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
fi
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
SRC=$TMP/$PRGNAM-$VERSION
OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i586" ]; then
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
fi
set -eu
# VulkanTools from LunarG doesn't support an external jsoncpp
JSONCPP_VERSION=${JSONCPP_VERSION:-1.8.0}
chdir () { cd -- "$SRC/$1"; printf %s\\n '' "Building $1" ''; }
cmake_build () {
mkdir -p build
cd build
cmake \
-DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib$LIBDIRSUFFIX \
-DCMAKE_SKIP_RPATH=TRUE \
-DCMAKE_BUILD_TYPE=Release \
"${@:-}" ..
make
make install DESTDIR=$PKG
}
copydocs () {
dir="$1"
mkdir -p -- "$PKG/usr/doc/$PRGNAM-$VERSION/$dir"
shift
for i do
cp -a -- "$dir-sdk-$VERSION/$i" "$PKG/usr/doc/$PRGNAM-$VERSION/$dir/"
done
}
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
mkdir $PRGNAM-$VERSION
cd $PRGNAM-$VERSION
tar xvf $CWD/Vulkan-Loader-sdk-$VERSION.tar.gz
tar xvf $CWD/Vulkan-ValidationLayers-sdk-$VERSION.tar.gz
tar xvf $CWD/VulkanTools-sdk-$VERSION.tar.gz
tar xvf $CWD/gfxreconstruct-sdk-$VERSION.tar.gz
(
cd VulkanTools-sdk-$VERSION/submodules
tar xvf $CWD/jsoncpp-$JSONCPP_VERSION.tar.gz
rm -rf jsoncpp
mv jsoncpp-$JSONCPP_VERSION jsoncpp
)
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
#####################
### vulkan-loader ###
#####################
chdir Vulkan-Loader-sdk-$VERSION
# Require an older cmake version.
sed -i 's/3.10.2/3.5.2/' CMakeLists.txt
# cmake 3.5.2 does not have GREATER_EQUAL
patch -p1 < $CWD/vulkan-loader-cmake.patch
cmake_build \
-DBUILD_TESTS=OFF \
-DBUILD_WSI_XCB_SUPPORT=ON \
-DBUILD_WSI_XLIB_SUPPORT=ON \
-DBUILD_WSI_WAYLAND_SUPPORT=OFF \
-DVULKAN_HEADERS_INSTALL_DIR=/usr
###############################
### vulkan-validationlayers ###
###############################
chdir Vulkan-ValidationLayers-sdk-$VERSION
# Require an older cmake version.
sed -i 's/3.10.2/3.5.2/' CMakeLists.txt
cmake_build \
-DCMAKE_INSTALL_DATADIR=share \
-DBUILD_LAYER_SUPPORT_FILES=ON \
-DBUILD_TESTS=OFF \
-DBUILD_WERROR=OFF \
-DBUILD_WSI_XCB_SUPPORT=ON \
-DBUILD_WSI_XLIB_SUPPORT=ON \
-DBUILD_WSI_WAYLAND_SUPPORT=OFF \
-DGLSLANG_INSTALL_DIR=/usr \
-DSPIRV_HEADERS_INSTALL_DIR=/usr \
-DVULKAN_HEADERS_INSTALL_DIR=/usr
###################
### vulkantools ###
###################
chdir VulkanTools-sdk-$VERSION
# Generate missing jsoncpp sources
(
cd submodules/jsoncpp
python3 ./amalgamate.py
)
# Require an older cmake version.
find . -type f -name CMakeLists.txt | xargs grep -l '3\.10\.2' |
xargs sed -i 's/3.10.2/3.5.2/'
cmake_build \
-DBUILD_GMOCK=OFF \
-DBUILD_WSI_XCB_SUPPORT=ON \
-DBUILD_WSI_XLIB_SUPPORT=ON \
-DBUILD_WSI_WAYLAND_SUPPORT=OFF \
-DINSTALL_GTEST=OFF \
-DVULKAN_HEADERS_INSTALL_DIR=/usr \
-DVULKAN_LOADER_INSTALL_DIR=$PKG/usr \
-DVULKAN_VALIDATIONLAYERS_INSTALL_DIR=$PKG/usr
######################
### gfxreconstruct ###
######################
chdir gfxreconstruct-sdk-$VERSION
# Require an older cmake version.
sed -i 's/3.10.2/3.5.2/' CMakeLists.txt
# cmake 3.5.2 does not have FILTER for the list command
sed -i '/generate_target_source_files(/d' cmake/CodeStyle.cmake
cmake_build \
-DBUILD_WERROR=OFF \
-DVULKAN_HEADER=/usr/include/vulkan
cd -- "$SRC"
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" |
grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
copydocs Vulkan-Loader CODE_OF_CONDUCT.md CONTRIBUTING.md GOVERNANCE.md \
LICENSE.txt README.md
copydocs Vulkan-ValidationLayers CODE_OF_CONDUCT.md CONTRIBUTING.md \
GOVERNANCE.md LAYER_CONFIGURATION.md LICENSE.txt README.md
copydocs VulkanTools CONTRIBUTING.md GOVERNANCE.md LICENSE.txt README.md
copydocs gfxreconstruct CONTRIBUTING.md LICENSE.txt LICENSE_ThirdParty.txt \
README.md USAGE_android.md USAGE_desktop.md
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}

View File

@ -1,18 +0,0 @@
PRGNAM="vulkan-sdk"
VERSION="1.2.162.0"
HOMEPAGE="https://www.khronos.org/vulkan/"
DOWNLOAD="https://github.com/KhronosGroup/Vulkan-Loader/archive/sdk-1.2.162.0/Vulkan-Loader-sdk-1.2.162.0.tar.gz \
https://github.com/KhronosGroup/Vulkan-ValidationLayers/archive/sdk-1.2.162.0/Vulkan-ValidationLayers-sdk-1.2.162.0.tar.gz \
https://github.com/LunarG/VulkanTools/archive/sdk-1.2.162.0/VulkanTools-sdk-1.2.162.0.tar.gz \
https://github.com/LunarG/gfxreconstruct/archive/sdk-1.2.162.0/gfxreconstruct-sdk-1.2.162.0.tar.gz \
https://github.com/open-source-parsers/jsoncpp/archive/1.8.0/jsoncpp-1.8.0.tar.gz"
MD5SUM="97de90f2b599979ea492a3ed92c025fb \
5c0c6daedacd2d535bb0cd41dcbd2995 \
aa116fff3ef50d7c299bc168953eacec \
7d48f5d115f8baad2ed800769545f21a \
6d6cbd82b5fe4a9cbae4ffef01f9e9fc"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="Vulkan-Headers glslang"
MAINTAINER="Hunter Sezen"
EMAIL="orbea@riseup.net"