network/youtube-dl: Updated for version 2015.05.20.
Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com>
This commit is contained in:
parent
2d81155c77
commit
4ef38f374c
|
@ -1,8 +1,8 @@
|
|||
--- youtube-dl-2015.03.09/Makefile.orig 2015-03-11 01:22:06.331608738 +0200
|
||||
+++ youtube-dl-2015.03.09/Makefile 2015-03-11 01:33:42.747902336 +0200
|
||||
@@ -4,22 +4,23 @@
|
||||
--- youtube-dl-2015.05.20/Makefile.orig 2015-05-25 04:09:16.056234902 +0300
|
||||
+++ youtube-dl-2015.05.20/Makefile 2015-05-25 04:13:42.180907886 +0300
|
||||
@@ -4,22 +4,22 @@
|
||||
rm -rf youtube-dl.1.temp.md youtube-dl.1 youtube-dl.bash-completion README.txt MANIFEST build/ dist/ .coverage cover/ youtube-dl.tar.gz youtube-dl.zsh youtube-dl.fish *.dump *.part *.info.json *.mp4 *.flv *.mp3 *.avi CONTRIBUTING.md.tmp youtube-dl youtube-dl.exe
|
||||
find -name "*.pyc" -delete
|
||||
find . -name "*.pyc" -delete
|
||||
|
||||
-PREFIX ?= /usr/local
|
||||
+PREFIX ?=
|
||||
|
@ -11,7 +11,6 @@
|
|||
SHAREDIR ?= $(PREFIX)/share
|
||||
-PYTHON ?= /usr/bin/env python
|
||||
+PYTHON ?= /usr/bin/python
|
||||
+SYSCONFDIR=/etc
|
||||
|
||||
# set SYSCONFDIR to /etc if PREFIX=/usr or PREFIX=/usr/local
|
||||
-ifeq ($(PREFIX),/usr)
|
||||
|
@ -24,7 +23,7 @@
|
|||
- endif
|
||||
-endif
|
||||
+#ifeq ($(PREFIX),/usr)
|
||||
+# SYSCONFDIR=/etc
|
||||
+#SYSCONFDIR=/etc
|
||||
+#else
|
||||
+# ifeq ($(PREFIX),/usr/local)
|
||||
+# SYSCONFDIR=/etc
|
||||
|
@ -35,7 +34,7 @@
|
|||
|
||||
install: youtube-dl youtube-dl.1 youtube-dl.bash-completion youtube-dl.zsh youtube-dl.fish
|
||||
install -d $(DESTDIR)$(BINDIR)
|
||||
@@ -50,7 +51,7 @@
|
||||
@@ -50,7 +50,7 @@
|
||||
|
||||
.PHONY: all clean install test tar bash-completion pypi-files zsh-completion fish-completion ot offlinetest codetest supportedsites
|
||||
|
||||
|
@ -44,21 +43,21 @@
|
|||
|
||||
youtube-dl: youtube_dl/*.py youtube_dl/*/*.py
|
||||
zip --quiet youtube-dl youtube_dl/*.py youtube_dl/*/*.py
|
||||
@@ -70,11 +71,11 @@
|
||||
@@ -70,11 +70,11 @@
|
||||
python devscripts/make_supportedsites.py docs/supportedsites.md
|
||||
|
||||
README.txt: README.md
|
||||
- pandoc -f markdown -t plain README.md -o README.txt
|
||||
+ # pandoc -f markdown -t plain README.md -o
|
||||
+ #pandoc -f markdown -t plain README.md -o README.txt
|
||||
|
||||
youtube-dl.1: README.md
|
||||
python devscripts/prepare_manpage.py >youtube-dl.1.temp.md
|
||||
- pandoc -s -f markdown -t man youtube-dl.1.temp.md -o youtube-dl.1
|
||||
+ # pandoc -s -f markdown -t man youtube-dl.1.temp.md -o youtube-dl.1
|
||||
+ #pandoc -s -f markdown -t man youtube-dl.1.temp.md -o youtube-dl.1
|
||||
rm -f youtube-dl.1.temp.md
|
||||
|
||||
youtube-dl.bash-completion: youtube_dl/*.py youtube_dl/*/*.py devscripts/bash-completion.in
|
||||
@@ -92,7 +93,7 @@
|
||||
@@ -92,7 +92,7 @@
|
||||
|
||||
fish-completion: youtube-dl.fish
|
||||
|
||||
|
@ -67,7 +66,7 @@
|
|||
@tar -czf youtube-dl.tar.gz --transform "s|^|youtube-dl/|" --owner 0 --group 0 \
|
||||
--exclude '*.DS_Store' \
|
||||
--exclude '*.kate-swp' \
|
||||
@@ -105,7 +106,7 @@
|
||||
@@ -105,7 +105,7 @@
|
||||
--exclude 'docs/_build' \
|
||||
-- \
|
||||
bin devscripts test youtube_dl docs \
|
||||
|
@ -76,18 +75,9 @@
|
|||
Makefile MANIFEST.in youtube-dl.1 youtube-dl.bash-completion \
|
||||
youtube-dl.zsh youtube-dl.fish setup.py \
|
||||
youtube-dl
|
||||
--- youtube-dl-2015.03.09/setup.orig.py 2015-03-11 01:21:28.928076346 +0200
|
||||
+++ youtube-dl-2015.03.09/setup.py 2015-03-11 01:37:37.112972370 +0200
|
||||
@@ -6,6 +6,8 @@
|
||||
import os.path
|
||||
import warnings
|
||||
import sys
|
||||
+from youtube_dl.version import __version__
|
||||
+
|
||||
|
||||
try:
|
||||
from setuptools import setup
|
||||
@@ -46,10 +48,8 @@
|
||||
--- youtube-dl-2015.05.20/setup.orig.py 2015-05-25 04:08:00.477179771 +0300
|
||||
+++ youtube-dl-2015.05.20/setup.py 2015-05-25 04:18:55.835986658 +0300
|
||||
@@ -46,10 +46,8 @@
|
||||
params = py2exe_params
|
||||
else:
|
||||
files_spec = [
|
||||
|
@ -96,7 +86,7 @@
|
|||
- ('share/doc/youtube_dl', ['README.txt']),
|
||||
- ('share/man/man1', ['youtube-dl.1'])
|
||||
+ ('/etc/bash_completion.d', ['youtube-dl.bash-completion']),
|
||||
+ ('/etc/fish/completions', ['youtube-dl.fish'])
|
||||
+ ('/etc/fish/completions', ['youtube-dl.fish']),
|
||||
]
|
||||
root = os.path.dirname(os.path.abspath(__file__))
|
||||
data_files = []
|
||||
|
|
|
@ -24,7 +24,7 @@
|
|||
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
|
||||
PRGNAM=youtube-dl
|
||||
VERSION=${VERSION:-2015.05.10}
|
||||
VERSION=${VERSION:-2015.05.20}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
PRGNAM="youtube-dl"
|
||||
VERSION="2015.05.10"
|
||||
VERSION="2015.05.20"
|
||||
HOMEPAGE="https://rg3.github.io/youtube-dl"
|
||||
DOWNLOAD="https://github.com/rg3/youtube-dl/archive/2015.05.10.tar.gz"
|
||||
MD5SUM="ce289c1dc08a48ab7eadd4d4fbee5b3b"
|
||||
DOWNLOAD="https://github.com/rg3/youtube-dl/archive/2015.05.20.tar.gz"
|
||||
MD5SUM="6423947f267b17ed47ee0e0cb7aa7afb"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES=""
|
||||
|
|
Loading…
Reference in New Issue