libraries/stfl: Fixed install directory for python.

Signed-off-by: Heinz Wiesinger <pprkut@slackbuilds.org>
This commit is contained in:
Benjamin Trigona-Harany 2012-11-17 18:20:43 +01:00 committed by Heinz Wiesinger
parent fc8e896dcc
commit 4e03132f84
2 changed files with 16 additions and 1 deletions

View File

@ -0,0 +1,13 @@
diff -Nur stfl-0.22.a/python/Makefile.snippet stfl-0.22.b/python/Makefile.snippet
--- stfl-0.22.a/python/Makefile.snippet 2009-06-18 01:27:16.000000000 -0700
+++ stfl-0.22.b/python/Makefile.snippet 2012-10-05 18:24:00.912721777 -0700
@@ -33,8 +33,7 @@
install_python: python/_stfl.so python/stfl.py python/stfl.pyc
mkdir -p $(DESTDIR)$(PYTHON_SITEARCH)/
- mkdir -p $(DESTDIR)$(PYTHON_SITEARCH)/lib-dynload/
- cp python/_stfl.so $(DESTDIR)$(PYTHON_SITEARCH)/lib-dynload/
+ cp python/_stfl.so $(DESTDIR)$(PYTHON_SITEARCH)/
cp python/stfl.pyc $(DESTDIR)$(PYTHON_SITEARCH)/
cp python/stfl.py $(DESTDIR)$(PYTHON_SITEARCH)/

View File

@ -7,7 +7,7 @@
PRGNAM=stfl
VERSION=${VERSION:-0.22}
BUILD=${BUILD:-2}
BUILD=${BUILD:-3}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@ -54,6 +54,8 @@ find . \
# Allow custom options in Makefile
patch -p1 < $CWD/allow-custom-opts-in-Makefile.patch
# Fix the install directory for Python
patch -p1 < $CWD/fix-python-install-in-Makefile.patch
make install \
OPTS="$SLKCFLAGS" \