graphics/paraview: Updated for version 5.9.1
Signed-off-by: Christoph Willing <chris.willing@linux.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
f9cf7e2fdb
commit
4b76a07ff4
|
@ -1,12 +0,0 @@
|
|||
--- ParaViewCore/ClientServerCore/Default/vtkPVFileInformation.cxx.orig 2018-11-07 05:03:24.000000000 +1000
|
||||
+++ ParaViewCore/ClientServerCore/Default/vtkPVFileInformation.cxx 2018-11-23 18:17:38.214000000 +1000
|
||||
@@ -1227,7 +1227,8 @@
|
||||
//-----------------------------------------------------------------------------
|
||||
std::string vtkPVFileInformation::GetParaViewDocDirectory()
|
||||
{
|
||||
- return vtkPVFileInformation::GetParaViewSharedResourcesDirectory() + "/doc";
|
||||
+ /* return vtkPVFileInformation::GetParaViewSharedResourcesDirectory() + "/doc"; */
|
||||
+ return "/usr/doc/paraview-" PARAVIEW_VERSION_FULL ;
|
||||
}
|
||||
|
||||
//-----------------------------------------------------------------------------
|
|
@ -0,0 +1,20 @@
|
|||
--- Remoting/Core/vtkPVFileInformation.cxx.orig 2021-05-14 02:47:34.000000000 +1000
|
||||
+++ Remoting/Core/vtkPVFileInformation.cxx 2021-05-23 20:53:31.322000000 +1000
|
||||
@@ -1227,13 +1227,15 @@
|
||||
//-----------------------------------------------------------------------------
|
||||
std::string vtkPVFileInformation::GetParaViewExampleFilesDirectory()
|
||||
{
|
||||
- return vtkPVFileInformation::GetParaViewSharedResourcesDirectory() + "/examples";
|
||||
+ /* return vtkPVFileInformation::GetParaViewSharedResourcesDirectory() + "/examples"; */
|
||||
+ return "/usr/doc/paraview-"PARAVIEW_VERSION_FULL ;
|
||||
}
|
||||
|
||||
//-----------------------------------------------------------------------------
|
||||
std::string vtkPVFileInformation::GetParaViewDocDirectory()
|
||||
{
|
||||
- return vtkPVFileInformation::GetParaViewSharedResourcesDirectory() + "/doc";
|
||||
+ /* return vtkPVFileInformation::GetParaViewSharedResourcesDirectory() + "/doc"; */
|
||||
+ return "/usr/doc/paraview-"PARAVIEW_VERSION_FULL ;
|
||||
}
|
||||
|
||||
//-----------------------------------------------------------------------------
|
|
@ -1,10 +0,0 @@
|
|||
--- VTK/Utilities/Doxygen/CMakeLists.txt.orig 2017-03-11 05:22:48.000000000 +1000
|
||||
+++ VTK/Utilities/Doxygen/CMakeLists.txt 2017-03-15 21:49:40.289474063 +1000
|
||||
@@ -80,7 +80,4 @@
|
||||
install(FILES doc_readme.txt
|
||||
DESTINATION ${VTK_INSTALL_DOXYGEN_DIR}
|
||||
COMPONENT Development)
|
||||
- install(DIRECTORY ${VTK_BINARY_DIR}/Utilities/Doxygen/doc/html
|
||||
- DESTINATION ${VTK_INSTALL_DOXYGEN_DIR}
|
||||
- COMPONENT Development)
|
||||
endif()
|
|
@ -7,12 +7,6 @@ processing capabilities.
|
|||
This SlackBuild, in line with official Paraview releases,
|
||||
is intended only for 64bit systems.
|
||||
|
||||
Although not recommended, building without MPI (mpich) and/or Matplotlib support
|
||||
is possible by setting the relevant variables in the build environment:
|
||||
MPICH=no
|
||||
MATPLOTLIB=no
|
||||
|
||||
Optional embedding with PythonQt may be enabled by setting
|
||||
PYTHONQT=yes
|
||||
in the build environment. This requires the SBo PythonQt package to be
|
||||
installed at build time.
|
||||
Although not recommended, building without MPI (mpich) support
|
||||
is possible by setting the relevant variables in the build environment e.g.
|
||||
MPICH=no sh paraview.SlackBuild
|
||||
|
|
|
@ -2,7 +2,7 @@
|
|||
|
||||
# Slackware build script for paraview
|
||||
|
||||
# Copyright 2016-2018 Christoph Willing Brisbane, Australia
|
||||
# Copyright 2016-2021 Christoph Willing Brisbane, Australia
|
||||
# All rights reserved.
|
||||
#
|
||||
# Redistribution and use of this script, with or without modification, is
|
||||
|
@ -24,9 +24,9 @@
|
|||
|
||||
PRGNAM=paraview
|
||||
SRCNAM=ParaView
|
||||
VERSION=${VERSION:-5.6.0}
|
||||
SHORT_VERSION=${SHORT_VERSION:-5.6}
|
||||
DOC_VERSION=${DOC_VERSION:-5.6.0}
|
||||
VERSION=${VERSION:-5.9.1}
|
||||
SHORT_VERSION=${SHORT_VERSION:-5.9}
|
||||
DOC_VERSION=${DOC_VERSION:-5.9.1}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
|
@ -57,14 +57,7 @@ else
|
|||
LIBDIRSUFFIX=""
|
||||
fi
|
||||
|
||||
mpich="-DPARAVIEW_USE_MPI=ON \
|
||||
-DVTK_VPIC_USE_MPI=ON -DVTK_XDMF_USE_MPI=ON" ; [ "${MPICH:-yes}" != "yes" ] && mpich=""
|
||||
matplotlib="-DPARAVIEW_ENABLE_MATPLOTLIB=ON" ; [ "${MATPLOTLIB:-yes}" != "yes" ] && matplotlib=""
|
||||
pythonqt="-DPARAVIEW_BUILD_PLUGIN_PythonQtPlugin=ON \
|
||||
-DPythonQt_Wrap_Qtcore=ON \
|
||||
-DPythonQt_Wrap_Qtgui=ON \
|
||||
-DPythonQt_Wrap_Qtuitools=ON \
|
||||
-DPYTHONQT_INCLUDE_DIR=/usr/include/PythonQt" ; [ "${PYTHONQT:-no}" != "yes" ] && pythonqt=""
|
||||
mpich="-DPARAVIEW_USE_MPI=ON" ; [ "${MPICH:-yes}" != "yes" ] && mpich=""
|
||||
|
||||
set -e
|
||||
|
||||
|
@ -74,11 +67,8 @@ cd $TMP
|
|||
rm -rf $SRCNAM-v$VERSION
|
||||
tar xvf $CWD/$SRCNAM-v$VERSION.tar.xz
|
||||
cd $SRCNAM-v$VERSION
|
||||
patch -p0 < $CWD/011_doc_path.diff
|
||||
patch -p0 < $CWD/020_vtkdocs.diff
|
||||
sed -i -e 's/@PARAVIEW_VERSION_FULL@/1.0/' Applications/ParaView/paraview.desktop.in
|
||||
echo "Exec=paraview" >> Applications/ParaView/paraview.desktop.in
|
||||
echo "Categories=Development;Graphics" >> Applications/ParaView/paraview.desktop.in
|
||||
patch -p0 < $CWD/012_doc_path.diff
|
||||
sed -i -e 's/^Categories.*/&Development;Graphics;/' Clients/ParaView/org.paraview.ParaView.desktop.in
|
||||
chown -R root:root .
|
||||
find -L . \
|
||||
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
|
||||
|
@ -92,60 +82,35 @@ cd build
|
|||
-DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
|
||||
-DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
|
||||
-DCMAKE_INSTALL_PREFIX=/usr \
|
||||
-DLIB_SUFFIX=${LIBDIRSUFFIX} \
|
||||
-DFFMPEG_LIBAVCODEC_INCLUDE_DIRS=/usr/include/libavcodec \
|
||||
-DFFMPEG_LIBAVDEVICE_INCLUDE_DIRS=/usr/include/libavdevice \
|
||||
-DFFMPEG_LIBAVFORMAT_INCLUDE_DIRS=/usr/include/libavformat \
|
||||
-DFFMPEG_LIBAVUTIL_INCLUDE_DIRS=/usr/include/libavutil \
|
||||
-DFFMPEG_LIBSWSCALE_INCLUDE_DIRS=/usr/include/libswscale \
|
||||
-DPARAVIEW_BUILD_QT_GUI=ON \
|
||||
-DPARAVIEW_ENABLE_XDMF3=ON \
|
||||
-DPARAVIEW_ENABLE_CATALYST=ON \
|
||||
-DCMAKE_INSTALL_MANDIR=man \
|
||||
-DPARAVIEW_ENABLE_FFMPEG=ON \
|
||||
-DPARAVIEW_ENABLE_PYTHON=ON \
|
||||
-DPARAVIEW_ENABLE_GDAL=ON \
|
||||
-DPARAVIEW_ENABLE_XDMF3=ON \
|
||||
-DPARAVIEW_ENABLE_FFMPEG=ON \
|
||||
-DPARAVIEW_USE_PYTHON=ON \
|
||||
-DPARAVIEW_USE_QT=ON \
|
||||
-DPARAVIEW_INSTALL_DEVELOPMENT_FILES=ON \
|
||||
-DVTK_RENDERING_BACKEND="OpenGL2" \
|
||||
-DBUILD_DOCUMENTATION=ON \
|
||||
-DBUILD_EXAMPLES=ON \
|
||||
-DBUILD_TESTING=OFF \
|
||||
-DINSTALL_MAN_DIR=/usr/man \
|
||||
-DINSTALL_LIB_DIR=/usr/lib${LIBDIRSUFFIX} \
|
||||
-DINSTALL_DOCS=ON \
|
||||
-DICET_INSTALL_MAN_DIR=man \
|
||||
-DVTK_INSTALL_ARCHIVE_DIR=lib${LIBDIRSUFFIX}/${PRGNAM}-${VERSION} \
|
||||
-DVTK_INSTALL_LIBRARY_DIR=lib${LIBDIRSUFFIX}/${PRGNAM}-${VERSION} \
|
||||
-DVTK_INSTALL_PACKAGE_DIR=lib${LIBDIRSUFFIX}/cmake/${PRGNAM}-${VERSION} \
|
||||
-DVTK_INSTALL_DOC_DIR=doc/${PRGNAM}-${VERSION} \
|
||||
-DQtTesting_INSTALL_LIB_DIR=lib${LIBDIRSUFFIX} \
|
||||
-DQtTesting_INSTALL_CMAKE_DIR=lib${LIBDIRSUFFIX}/cmake/qttesting \
|
||||
$matplotlib \
|
||||
-DVTK_USE_TK=ON \
|
||||
$mpich \
|
||||
$pythonqt \
|
||||
-DCMAKE_BUILD_TYPE=Release ..
|
||||
make
|
||||
make install DESTDIR=$PKG
|
||||
cd ..
|
||||
|
||||
# Remove duplicate files in usr/lib
|
||||
[ -r $PKG/usr/lib${LIBDIRSUFFIX}/${PRGNAM}-${VERSION}/libXdmfCore.so ] && \
|
||||
rm -f $PKG/usr/lib/libXdmfCore.so
|
||||
[ -r $PKG/usr/lib${LIBDIRSUFFIX}/${PRGNAM}-${VERSION}/libvtkxdmf3.so ] && \
|
||||
rm -f $PKG/usr/lib/libvtkxdmf3.so
|
||||
if [ "$ARCH" = "x86_64" ]; then
|
||||
rm -rf $PKG/usr/lib
|
||||
fi
|
||||
|
||||
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
|
||||
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
|
||||
|
||||
find $PKG/usr/man -type f -exec gzip -9 {} \;
|
||||
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
|
||||
|
||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp -a \
|
||||
CONTRIBUTING.* Copyright.* License_v1.2.txt README.* version.txt \
|
||||
CONTRIBUTING* Copyright* License_v1.2.txt README* version.txt \
|
||||
$PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp $CWD/ParaViewGettingStarted-${DOC_VERSION}.pdf $PKG/usr/doc/$PRGNAM-$VERSION/GettingStarted.pdf
|
||||
cp $CWD/ParaViewGuide-${DOC_VERSION}.pdf $PKG/usr/doc/$PRGNAM-$VERSION/Guide.pdf
|
||||
cp $CWD/ParaViewTutorial-${DOC_VERSION}.pdf $PKG/usr/doc/$PRGNAM-$VERSION/Tutorial.pdf
|
||||
mv $PKG/usr/share/vtkm* $PKG/usr/doc/$PRGNAM-$VERSION/
|
||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||
|
||||
mkdir -p $PKG/install
|
||||
|
|
|
@ -1,14 +1,14 @@
|
|||
PRGNAM="paraview"
|
||||
VERSION="5.6.0"
|
||||
VERSION="5.9.1"
|
||||
HOMEPAGE="https://www.paraview.org"
|
||||
DOWNLOAD="https://www.paraview.org/files/v5.6/ParaView-v5.6.0.tar.xz \
|
||||
https://www.paraview.org/files/v5.6/ParaViewGuide-5.6.0.pdf \
|
||||
https://www.paraview.org/files/v5.6/ParaViewGettingStarted-5.6.0.pdf"
|
||||
MD5SUM="eefb05c36ba2c3a6b25991b73f699981 \
|
||||
4013363d00c1f51e192bdf2778bea00b \
|
||||
1bdadd4b5a62ba9f2de8eb0219ca858c"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES="hdf5 Sphinx matplotlib mpich"
|
||||
DOWNLOAD="UNSUPPORTED"
|
||||
MD5SUM=""
|
||||
DOWNLOAD_x86_64="https://www.paraview.org/files/v5.9/ParaView-v5.9.1.tar.xz \
|
||||
https://www.paraview.org/files/v5.9/ParaViewTutorial-5.9.1.pdf \
|
||||
https://www.paraview.org/files/v5.9/ParaViewGettingStarted-5.9.1.pdf"
|
||||
MD5SUM_x86_64="8bb6e0eca272b570ea28e3f7db8574a4 \
|
||||
ec86d6432aa8b26bf4fc818e6db162d4 \
|
||||
392a29c111c5867b51e78bcb83e64198"
|
||||
REQUIRES="gdal hdf5 mpich python3-matplotlib Sphinx"
|
||||
MAINTAINER="Christoph Willing"
|
||||
EMAIL="chris.willing@linux.com"
|
||||
|
|
Loading…
Reference in New Issue