desktop/polybar: Added (a fast and easy-to-use status bar).

Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
Azure Zanculmarktum 2018-03-17 08:42:58 +07:00 committed by Willy Sudiarto Raharjo
parent a6dccbfdc3
commit 49b8773b23
4 changed files with 24 additions and 55 deletions

View File

@ -5,3 +5,4 @@ black belt in shell scripting.
Optional dependencies for extended module support:
* jsoncpp required by internal/i3
* libmpdclient required by internal/mpd
* siji-font for additional font support

View File

@ -1,27 +0,0 @@
From d35abc7620c8f06618b4708d9a969dfa2f309e96 Mon Sep 17 00:00:00 2001
From: patrick96 <p.ziegler96@gmail.com>
Date: Wed, 12 Jul 2017 11:22:45 +0200
Subject: [PATCH] Remove curlbuild include
Curl removed that header in 73a2fcea0b4adea6ba342cd7ed1149782c214ae3
([1])
http.cpp doesn't use anything from that header and compilation works for
fine with curl 7.54.1
Fixes #647
Ref:
[1]: https://github.com/curl/curl/commit/73a2fcea0b4adea6ba342cd7ed1149782c214ae3
---
src/utils/http.cpp | 1 -
1 file changed, 1 deletion(-)
diff --git a/src/utils/http.cpp b/src/utils/http.cpp
index 365dd3be..f6fe6779 100644
--- a/src/utils/http.cpp
+++ b/src/utils/http.cpp
@@ -1,5 +1,4 @@
#include <curl/curl.h>
-#include <curl/curlbuild.h>
#include <curl/easy.h>
#include <sstream>

View File

@ -2,7 +2,7 @@
# Slackware build script for polybar
# Copyright 2017 Azure Zanculmarktum <zanculmarktum@gmail.com>
# Copyright 2017-2018 Azure Zanculmarktum <zanculmarktum@gmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@ -23,14 +23,10 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=polybar
VERSION=${VERSION:-3.0.5}
VERSION=${VERSION:-3.1.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
# Git modules
MODULENAMS=(i3ipcpp xpp)
MODULEVERSIONS=(0.6.2 1.3.6)
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i586 ;;
@ -67,19 +63,21 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
# Extract the Git modules to lib
for i in $(seq 0 ${#MODULENAMS[@]}); do
[ $i -eq ${#MODULENAMS[@]} ] && break
rm -rf lib/${MODULENAMS[$i]}
tar xvf $CWD/${MODULENAMS[$i]}-${MODULEVERSIONS[$i]}.tar.gz
mv ${MODULENAMS[$i]}-${MODULEVERSIONS[$i]} lib/${MODULENAMS[$i]}
for mod in i3ipcpp-0.7.0 xpp-1.4.0; do
rm -rf lib/${mod%-*}
tar xvf $CWD/$mod.tar.gz
mv $mod lib/${mod%-*}
done
patch -p1 < $CWD/d35abc7620c8f06618b4708d9a969dfa2f309e96.patch
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Fixes install location
sed -i -e '/share\/doc\/polybar/s/share\///' doc/CMakeLists.txt
sed -i -e '/share\/man\/man1/s/share\///' man/CMakeLists.txt
mkdir -p build
cd build
@ -87,19 +85,16 @@ cd build
-DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_INSTALL_PREFIX=/usr \
-DLIB_SUFFIX=${LIBDIRSUFFIX} \
-DMAN_INSTALL_DIR=/usr/man \
-DCMAKE_BUILD_TYPE=Release ..
make
make -j1
make install/strip DESTDIR=$PKG
cd ..
mv $PKG/usr/share/man $PKG/usr/man
find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a LICENSE README.md $PKG/usr/doc/$PRGNAM-$VERSION
cp -a LICENSE README.md SUPPORT.md $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install

View File

@ -1,12 +1,12 @@
PRGNAM="polybar"
VERSION="3.0.5"
VERSION="3.1.0"
HOMEPAGE="https://github.com/jaagr/polybar"
DOWNLOAD="https://github.com/jaagr/polybar/archive/3.0.5/polybar-3.0.5.tar.gz \
https://github.com/jaagr/i3ipcpp/archive/v0.6.2/i3ipcpp-0.6.2.tar.gz \
https://github.com/jaagr/xpp/archive/1.3.6/xpp-1.3.6.tar.gz"
MD5SUM="bda4d0d34e394001dc502c8b38d89f48 \
b6300a0d4ca4b93d0b82f9402aab4fca \
fac190ed8862453164399137c0cdaa24"
DOWNLOAD="https://github.com/jaagr/polybar/archive/3.1.0/polybar-3.1.0.tar.gz \
https://github.com/jaagr/i3ipcpp/archive/v0.7.0/i3ipcpp-0.7.0.tar.gz \
https://github.com/jaagr/xpp/archive/1.4.0/xpp-1.4.0.tar.gz"
MD5SUM="2c45bc25c0e7e9eee8af451fbd1e334f \
572b9f058bab2d19fcc3f44f4601b739 \
d1a7db82fb5737cc91f386d2bcbb1286"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="xcb-util-xrm"