system/fxload: Updated for version 2008_10_13

This commit is contained in:
Andre Barboza 2010-05-13 00:40:23 +02:00 committed by David Somero
parent 662832272c
commit 456abf8065
3 changed files with 10 additions and 20 deletions

View File

@ -1,11 +0,0 @@
--- Makefile 2008-10-13 18:44:04.000000000 -0300
+++ Makefile.diff 2009-04-06 14:41:17.000000000 -0300
@@ -13,7 +13,7 @@
PROG = fxload
-CFLAGS = -O -Wall $(RPM_OPT_FLAGS)
+CFLAGS += -Wall $(RPM_OPT_FLAGS)
FILES_SRC_C = ezusb.c main.c
FILES_SRC_H = ezusb.h

View File

@ -2,9 +2,8 @@
# Slackware build script for fxload
# Copyright 2009 Andre Barboza
# All rights reserved.
#
# Written by Andre Barboza <bmg.andre at gmail.com>
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
@ -22,7 +21,6 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
# Written by Andre Barboza <bmg.andre at gmail.com>
PRGNAM=fxload
VERSION=${VERSION:-2008_10_13}
@ -37,10 +35,13 @@ OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
fi
set -e
@ -58,9 +59,7 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
patch Makefile $CWD/Makefile.patch
CFLAGS="$SLKCFLAGS" make
RPM_OPT_FLAGS="$SLKCFLAGS" make
make install prefix=$PKG
( cd $PKG
@ -84,4 +83,4 @@ mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}

View File

@ -3,6 +3,8 @@ VERSION="2008_10_13"
HOMEPAGE="http://linux-hotplug.sourceforge.net"
DOWNLOAD="http://downloads.sourceforge.net/linux-hotplug/fxload-2008_10_13.tar.gz"
MD5SUM="4477a2457f064228bef4a93ba2f21692"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MAINTAINER="Andre Barboza"
EMAIL="bmg.andre@gmail.com"
APPROVED="rworkman"
APPROVED="dsomero"