network/bmon: Updated for version 3.4.
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
This commit is contained in:
parent
0afef319ef
commit
45424c4039
|
@ -6,8 +6,13 @@
|
|||
|
||||
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
|
||||
|
||||
# 20140825 bkw:
|
||||
# - updated for 3.4
|
||||
# - remove unused diffs from tarball
|
||||
# - install bmon.conf as .new config, add doinst.sh
|
||||
|
||||
PRGNAM=bmon
|
||||
VERSION=${VERSION:-3.1}
|
||||
VERSION=${VERSION:-3.4}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
|
@ -38,7 +43,7 @@ rm -rf $PKG
|
|||
mkdir -p $TMP $PKG $OUTPUT $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cd $TMP
|
||||
rm -rf $PRGNAM-$VERSION
|
||||
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
|
||||
tar xvf $CWD/v$VERSION.tar.gz || tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
|
||||
cd $PRGNAM-$VERSION
|
||||
chown -R root:root .
|
||||
find -L . \
|
||||
|
@ -47,6 +52,8 @@ find -L . \
|
|||
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
||||
-exec chmod 644 {} \;
|
||||
|
||||
autoreconf -if
|
||||
|
||||
CFLAGS="$SLKCFLAGS" \
|
||||
CXXFLAGS="$SLKCFLAGS" \
|
||||
./configure \
|
||||
|
@ -54,20 +61,26 @@ CXXFLAGS="$SLKCFLAGS" \
|
|||
--sysconfdir=/etc \
|
||||
--localstatedir=/var \
|
||||
--mandir=/usr/man \
|
||||
--docdir=/usr/doc/$PRGNAM-$VERSION \
|
||||
--build=$ARCH-slackware-linux
|
||||
|
||||
make
|
||||
make install DESTDIR=$PKG
|
||||
make install-strip DESTDIR=$PKG
|
||||
gzip $PKG/usr/man/man?/*.?
|
||||
|
||||
strip $PKG/usr/bin/$PRGNAM
|
||||
mkdir -p $PKG/etc
|
||||
cat examples/$PRGNAM.conf > $PKG/etc/$PRGNAM.conf.new
|
||||
|
||||
find $PKG/usr/man -type f -exec gzip -9 {} \;
|
||||
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
|
||||
# nothing here but the example config, don't need
|
||||
rm -rf $PKG/usr/share
|
||||
|
||||
# ChangeLog is 0 bytes, don't bother.
|
||||
cp -a LICENSE* NEWS README* $PKG/usr/doc/$PRGNAM-$VERSION/
|
||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||
|
||||
mkdir -p $PKG/install
|
||||
cat $CWD/slack-desc > $PKG/install/slack-desc
|
||||
cat $CWD/doinst.sh > $PKG/install/doinst.sh
|
||||
|
||||
cd $PKG
|
||||
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
PRGNAM="bmon"
|
||||
VERSION="3.1"
|
||||
HOMEPAGE="http://people.suug.ch/~tgr/bmon/"
|
||||
DOWNLOAD="http://www.carisma.slowglass.com/~tgr/bmon/files/bmon-3.1.tar.gz"
|
||||
MD5SUM="7341089378fd5558de42e2424693943b"
|
||||
VERSION="3.4"
|
||||
HOMEPAGE="https://github.com/tgraf/bmon/"
|
||||
DOWNLOAD="https://github.com/tgraf/bmon/archive/v3.4.tar.gz"
|
||||
MD5SUM="34c1dc9c03b38cdf9fe6d20ed813cf0c"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES="confuse"
|
||||
|
|
|
@ -1,30 +0,0 @@
|
|||
diff -Naur bmon-2.1.0/configure.ac bmon-2.1.0.patched/configure.ac
|
||||
--- bmon-2.1.0/configure.ac 2005-04-05 11:01:33.000000000 -0400
|
||||
+++ bmon-2.1.0.patched/configure.ac 2009-09-30 23:43:25.000000000 -0400
|
||||
@@ -188,26 +188,6 @@
|
||||
|
||||
#####################################################################
|
||||
##
|
||||
-## libnl check
|
||||
-##
|
||||
-#####################################################################
|
||||
-NL="No "
|
||||
-AC_CHECK_LIB(nl, nl_connect, [
|
||||
- AC_DEFINE_UNQUOTED(HAVE_NL, "1", [have libnl])
|
||||
- LIBNL="-lnl"
|
||||
- NL="Yes"
|
||||
-],[
|
||||
- case ${target_os} in
|
||||
- *linux*)
|
||||
- echo
|
||||
- echo "*** Warning: Building bmon on Linuxx w/o libnl ***"
|
||||
- echo
|
||||
- ;;
|
||||
- esac
|
||||
-])
|
||||
-
|
||||
-#####################################################################
|
||||
-##
|
||||
## libm check
|
||||
##
|
||||
#####################################################################
|
|
@ -0,0 +1,14 @@
|
|||
config() {
|
||||
NEW="$1"
|
||||
OLD="$(dirname $NEW)/$(basename $NEW .new)"
|
||||
# If there's no config file by that name, mv it over:
|
||||
if [ ! -r $OLD ]; then
|
||||
mv $NEW $OLD
|
||||
elif [ "$(cat $OLD | md5sum)" = "$(cat $NEW | md5sum)" ]; then
|
||||
# toss the redundant copy
|
||||
rm $NEW
|
||||
fi
|
||||
# Otherwise, we leave the .new copy for the admin to consider...
|
||||
}
|
||||
|
||||
config etc/bmon.conf.new
|
|
@ -1,24 +0,0 @@
|
|||
diff -Naur bmon-2.1.0.old/src/out_audio.c bmon-2.1.0.patched/src/out_audio.c
|
||||
--- bmon-2.1.0.old/src/out_audio.c 2005-04-05 11:01:33.000000000 -0400
|
||||
+++ bmon-2.1.0.patched/src/out_audio.c 2009-09-30 23:48:28.000000000 -0400
|
||||
@@ -141,7 +141,7 @@
|
||||
.om_draw = audio_draw,
|
||||
.om_set_opts = audio_set_opts,
|
||||
.om_probe = audio_probe,
|
||||
- .om_shutdown audio_shutdown,
|
||||
+ .om_shutdown = audio_shutdown,
|
||||
};
|
||||
|
||||
static void __init audio_init(void)
|
||||
diff -Naur bmon-2.1.0.old/src/out_xml_event.c bmon-2.1.0.patched/src/out_xml_event.c
|
||||
--- bmon-2.1.0.old/src/out_xml_event.c 2005-04-05 11:01:33.000000000 -0400
|
||||
+++ bmon-2.1.0.patched/src/out_xml_event.c 2009-09-30 23:46:22.000000000 -0400
|
||||
@@ -127,7 +127,7 @@
|
||||
.om_draw = xml_event_draw,
|
||||
.om_set_opts = xml_event_set_opts,
|
||||
.om_probe = xml_event_probe,
|
||||
- .om_shutdown xml_event_shutdown,
|
||||
+ .om_shutdown = xml_event_shutdown,
|
||||
};
|
||||
|
||||
static void __init xml_event_init(void)
|
|
@ -15,5 +15,5 @@ bmon: HTML output but also formatable ASCII output. Statistics may be
|
|||
bmon: distributed over a network using multicast or unicast and collected
|
||||
bmon: at some point to generate a summary of statistics for a set of nodes.
|
||||
bmon:
|
||||
bmon: Homepage: http://people.suug.ch/~tgr/bmon/
|
||||
bmon:
|
||||
bmon:
|
||||
|
|
Loading…
Reference in New Issue