office/calibre: Removed (Use calibre-bin).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
0594bc5eb9
commit
42e431f80d
|
@ -1,11 +0,0 @@
|
|||
Calibre is meant to be a complete e-library solution. It includes
|
||||
library management, format conversion, news feeds to ebook conversion
|
||||
as well as e-book reader sync features.
|
||||
|
||||
Calibre is primarily an ebook cataloging program. It manages your
|
||||
ebook collection for you. It is designed around the concept of the
|
||||
logical book, i.e. a single entry in the database that may correspond
|
||||
to ebooks in several formats. It also supports conversion from a dozen
|
||||
different ebook formats to LRF and EPUB. A graphical interface to
|
||||
the conversion software can be accessed easily by just clicking the
|
||||
"Convert E-books" button.
|
|
@ -1,176 +0,0 @@
|
|||
#!/bin/bash
|
||||
|
||||
# Slackware build script for calibre
|
||||
|
||||
# Copyright 2009-2018 Larry Hajali <larryhaja[at]gmail[dot]com>
|
||||
# All rights reserved.
|
||||
#
|
||||
# Redistribution and use of this script, with or without modification, is
|
||||
# permitted provided that the following conditions are met:
|
||||
#
|
||||
# 1. Redistributions of this script must retain the above copyright
|
||||
# notice, this list of conditions and the following disclaimer.
|
||||
#
|
||||
# THIS SOFTWARE IS PROVIDED ''AS IS'' AND ANY EXPRESS OR IMPLIED
|
||||
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
|
||||
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
|
||||
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
||||
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
|
||||
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
|
||||
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
|
||||
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
|
||||
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
||||
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
|
||||
cd $(dirname $0) ; CWD=$(pwd)
|
||||
|
||||
PRGNAM=calibre
|
||||
VERSION=${VERSION:-3.48.0}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
PKGTYPE=${PKGTYPE:-tgz}
|
||||
|
||||
if [ -z "$ARCH" ]; then
|
||||
case "$( uname -m )" in
|
||||
i?86) ARCH=i586 ;;
|
||||
arm*) ARCH=arm ;;
|
||||
*) ARCH=$( uname -m ) ;;
|
||||
esac
|
||||
fi
|
||||
|
||||
|
||||
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
|
||||
# the name of the created package would be, and then exit. This information
|
||||
# could be useful to other scripts.
|
||||
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
|
||||
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
|
||||
exit 0
|
||||
fi
|
||||
|
||||
TMP=${TMP:-/tmp/SBo}
|
||||
PKG=$TMP/package-$PRGNAM
|
||||
OUTPUT=${OUTPUT:-/tmp}
|
||||
|
||||
if [ "$ARCH" = "i586" ]; then
|
||||
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
|
||||
LIBDIRSUFFIX=""
|
||||
elif [ "$ARCH" = "i686" ]; then
|
||||
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
|
||||
LIBDIRSUFFIX=""
|
||||
elif [ "$ARCH" = "x86_64" ]; then
|
||||
SLKCFLAGS="-O2 -fPIC"
|
||||
LIBDIRSUFFIX="64"
|
||||
else
|
||||
SLKCFLAGS="-O2"
|
||||
LIBDIRSUFFIX=""
|
||||
fi
|
||||
|
||||
set -e
|
||||
|
||||
rm -rf $PKG
|
||||
mkdir -p $TMP $PKG $OUTPUT
|
||||
cd $TMP
|
||||
rm -rf $PRGNAM-$VERSION
|
||||
tar xvf $CWD/$PRGNAM-$VERSION.tar.xz
|
||||
cd $PRGNAM-$VERSION
|
||||
chown -R root:root .
|
||||
find -L . \
|
||||
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
|
||||
-o -perm 511 \) -exec chmod 755 {} \; -o \
|
||||
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
|
||||
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
|
||||
|
||||
# Patch for the newer icu4c
|
||||
patch -p1 < $CWD/patches/icu.patch
|
||||
# Patch for qt-5.15.x
|
||||
patch -p1 < $CWD/patches/qt-5.15.patch
|
||||
# Remove desktop integration. We'll do that later.
|
||||
patch -p1 < $CWD/patches/remove-desktop-integration.patch
|
||||
# Fix calibre module location.
|
||||
patch -p1 < $CWD/patches/calibre-module-fix.patch
|
||||
# Remove calibre update check
|
||||
patch -p1 < $CWD/patches/calibre-no-update.patch
|
||||
# Remove calibre portable scripts.
|
||||
rm -f resources/calibre-portable.*
|
||||
|
||||
OVERRIDE_CFLAGS="$SLKCFLAGS" \
|
||||
OVERRIDE_LDFLAGS="-L/usr/lib${LIBDIRSUFFIX}" \
|
||||
python setup.py build
|
||||
|
||||
# We have to fake out CALIBRE_CONFIG_DIRECTORY if there is a current
|
||||
# calibre installation while the build process takes place. :/
|
||||
mkdir -p "$PWD/tmp/config"
|
||||
|
||||
# Hack for installing zsh completion.
|
||||
mkdir -p $PKG/usr/share/zsh/site-functions
|
||||
|
||||
CALIBRE_CONFIG_DIRECTORY="$PWD/tmp/config" \
|
||||
python setup.py install \
|
||||
--root=$PKG \
|
||||
--prefix=/usr \
|
||||
--libdir=/usr/lib${LIBDIRSUFFIX} \
|
||||
--sharedir=/usr/share \
|
||||
--bindir=/usr/bin \
|
||||
--staging-libdir=$PKG/usr/lib${LIBDIRSUFFIX} \
|
||||
--staging-bindir=$PKG/usr/bin \
|
||||
--staging-sharedir=$PKG/usr/share
|
||||
|
||||
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
|
||||
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
|
||||
|
||||
# Fix permissions.
|
||||
find $PKG/usr/lib${LIBDIRSUFFIX} -iname "*\.py" -exec chmod 0644 '{}' \;
|
||||
|
||||
# Install the necessary desktop items.
|
||||
mkdir -p $PKG/usr/share/{applications,mime/packages}
|
||||
cat src/calibre/linux.py | sed -n "/^VIEWER/,/^'''/p" | \
|
||||
sed -e "/'''/d" > $PKG/usr/share/applications/$PRGNAM-lrfviewer.desktop
|
||||
cat src/calibre/linux.py | sed -n "/^EVIEWER/,/^'''/p" | \
|
||||
sed -e "/'''/d" > $PKG/usr/share/applications/$PRGNAM-ebook-viewer.desktop
|
||||
cat src/calibre/linux.py | sed -n "/^ETWEAK/,/^'''/p" | \
|
||||
sed -e "/'''/d" > $PKG/usr/share/applications/$PRGNAM-ebook-edit.desktop
|
||||
cat src/calibre/linux.py | sed -n "/^GUI/,/^'''/p" | \
|
||||
sed -e "/'''/d" -e '/^Name/s|calibre|Calibre|' \
|
||||
> $PKG/usr/share/applications/$PRGNAM-gui.desktop
|
||||
install -D -m 0644 resources/$PRGNAM-mimetypes.xml $PKG/usr/share/mime/packages
|
||||
rm -f $PKG/usr/share/$PRGNAM/$PRGNAM-mimetypes.xml
|
||||
|
||||
for i in 16 24 32 64 96 128; do
|
||||
convert resources/images/lt.png -resize ${i}x${i}! $PRGNAM-gui-${i}.png
|
||||
convert -background none imgsrc/viewer.svg \
|
||||
-resize ${i}x${i}! $PRGNAM-viewer-${i}.png
|
||||
convert imgsrc/mimetypes/lrf.svg \
|
||||
-resize ${i}x${i}! application-x-sony-bbeb-${i}.png
|
||||
convert resources/images/tweak.png -resize ${i}x${i}! $PRGNAM-ebook-edit-${i}.png
|
||||
install -D -m 0644 $PRGNAM-gui-${i}.png \
|
||||
$PKG/usr/share/icons/hicolor/${i}x${i}/apps/$PRGNAM-gui.png
|
||||
install -D -m 0644 $PRGNAM-viewer-${i}.png \
|
||||
$PKG/usr/share/icons/hicolor/${i}x${i}/apps/$PRGNAM-viewer.png
|
||||
install -D -m 0644 application-x-sony-bbeb-${i}.png \
|
||||
$PKG/usr/share/icons/hicolor/${i}x${i}/mimetypes/application-x-sony-bbeb.png
|
||||
install -D -m 0644 $PRGNAM-ebook-edit-${i}.png \
|
||||
$PKG/usr/share/icons/hicolor/${i}x${i}/apps/$PRGNAM-ebook-edit.png
|
||||
done
|
||||
|
||||
# Don't ship fonts that are already in Slackware.
|
||||
for FONT in $PKG/usr/share/$PRGNAM/fonts/liberation/*; do
|
||||
# Make sure that the fonts exist first before deleting them.
|
||||
if find /usr/share/fonts/ -name "$(basename $FONT)" 2>/dev/null 1>/dev/null
|
||||
then
|
||||
rm -f $FONT
|
||||
ln -s $(find /usr/share/fonts/ -name "$(basename $FONT)") $FONT
|
||||
fi
|
||||
done
|
||||
|
||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp -a \
|
||||
LICENSE* Changelog.yaml COPYRIGHT README.md \
|
||||
$PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||
|
||||
mkdir -p $PKG/install
|
||||
cat $CWD/slack-desc > $PKG/install/slack-desc
|
||||
cat $CWD/doinst.sh > $PKG/install/doinst.sh
|
||||
|
||||
cd $PKG
|
||||
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
|
|
@ -1,10 +0,0 @@
|
|||
PRGNAM="calibre"
|
||||
VERSION="3.48.0"
|
||||
HOMEPAGE="https://calibre-ebook.com"
|
||||
DOWNLOAD="https://download.calibre-ebook.com/3.48.0/calibre-3.48.0.tar.xz"
|
||||
MD5SUM="ec7431dcdeea8a9d8eca3edc83bdec42"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES="css-parser mechanize podofo python2-dateutil netifaces python2-psutil cssselect apsw optipng msgpack-python python2-regex html5-parser dukpy unrardll python2-pillow"
|
||||
MAINTAINER="Larry Hajali"
|
||||
EMAIL="larryhaja[at]gmail[dot]com"
|
|
@ -1,13 +0,0 @@
|
|||
if [ -x /usr/bin/update-desktop-database ]; then
|
||||
/usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
|
||||
fi
|
||||
|
||||
if [ -x /usr/bin/update-mime-database ]; then
|
||||
/usr/bin/update-mime-database usr/share/mime >/dev/null 2>&1
|
||||
fi
|
||||
|
||||
if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
|
||||
if [ -x /usr/bin/gtk-update-icon-cache ]; then
|
||||
/usr/bin/gtk-update-icon-cache -f usr/share/icons/hicolor >/dev/null 2>&1
|
||||
fi
|
||||
fi
|
|
@ -1,14 +0,0 @@
|
|||
diff -Naur calibre.orig/setup/install.py calibre/setup/install.py
|
||||
--- calibre.orig/setup/install.py 2010-03-05 21:13:33.000000000 +0000
|
||||
+++ calibre/setup/install.py 2010-03-07 00:07:41.000000000 +0000
|
||||
@@ -142,7 +142,9 @@
|
||||
|
||||
def install_env_module(self):
|
||||
import distutils.sysconfig as s
|
||||
- libdir = s.get_python_lib(prefix=self.opts.staging_root)
|
||||
+ libdir = s.get_python_lib(prefix=(self.opts.staging_root + sys.prefix))
|
||||
+ if not os.path.exists(libdir):
|
||||
+ os.makedirs(libdir)
|
||||
try:
|
||||
if not os.path.exists(libdir):
|
||||
os.makedirs(libdir)
|
|
@ -1,24 +0,0 @@
|
|||
diff -Nur calibre-2.9.0.orig/src/calibre/gui2/update.py calibre-2.9.0/src/calibre/gui2/update.py
|
||||
--- calibre-2.9.0.orig/src/calibre/gui2/update.py 2014-11-08 21:43:22.888681538 -0700
|
||||
+++ calibre-2.9.0/src/calibre/gui2/update.py 2014-11-08 21:45:27.363383815 -0700
|
||||
@@ -63,20 +63,6 @@
|
||||
while not self.shutdown_event.is_set():
|
||||
calibre_update_version = NO_CALIBRE_UPDATE
|
||||
plugins_update_found = 0
|
||||
- try:
|
||||
- version = get_newest_version()
|
||||
- if version[:2] > numeric_version[:2]:
|
||||
- calibre_update_version = version
|
||||
- except Exception as e:
|
||||
- prints('Failed to check for calibre update:', as_unicode(e))
|
||||
- try:
|
||||
- update_plugins = get_plugin_updates_available(raise_error=True)
|
||||
- if update_plugins is not None:
|
||||
- plugins_update_found = len(update_plugins)
|
||||
- except Exception as e:
|
||||
- prints('Failed to check for plugin update:', as_unicode(e))
|
||||
- if calibre_update_version != NO_CALIBRE_UPDATE or plugins_update_found > 0:
|
||||
- self.signal.update_found.emit(calibre_update_version, plugins_update_found)
|
||||
self.shutdown_event.wait(self.INTERVAL)
|
||||
|
||||
def shutdown(self):
|
|
@ -1,31 +0,0 @@
|
|||
diff -Naur calibre-3.48.0.orig/src/calibre/utils/icu.c calibre-3.48.0/src/calibre/utils/icu.c
|
||||
--- calibre-3.48.0.orig/src/calibre/utils/icu.c 2019-09-13 04:46:46.000000000 +0200
|
||||
+++ calibre-3.48.0/src/calibre/utils/icu.c 2020-12-05 09:20:59.063932000 +0100
|
||||
@@ -243,14 +243,14 @@
|
||||
|
||||
a = python_to_icu(a_, &asz);
|
||||
if (a == NULL) goto end;
|
||||
- if (asz == 0) { found = TRUE; goto end; }
|
||||
+ if (asz == 0) { found = true; goto end; }
|
||||
b = python_to_icu(b_, &bsz);
|
||||
if (b == NULL) goto end;
|
||||
|
||||
search = usearch_openFromCollator(a, asz, b, bsz, self->collator, NULL, &status);
|
||||
if (U_SUCCESS(status)) {
|
||||
pos = usearch_first(search, &status);
|
||||
- if (pos != USEARCH_DONE) found = TRUE;
|
||||
+ if (pos != USEARCH_DONE) found = true;
|
||||
}
|
||||
end:
|
||||
if (search != NULL) usearch_close(search);
|
||||
diff -Naur calibre-3.48.0.orig/src/calibre/utils/matcher.c calibre-3.48.0/src/calibre/utils/matcher.c
|
||||
--- calibre-3.48.0.orig/src/calibre/utils/matcher.c 2019-09-13 04:46:46.000000000 +0200
|
||||
+++ calibre-3.48.0/src/calibre/utils/matcher.c 2020-12-05 09:26:57.800932000 +0100
|
||||
@@ -15,7 +15,6 @@
|
||||
#define inline
|
||||
#endif
|
||||
|
||||
-typedef unsigned char bool;
|
||||
#define TRUE 1
|
||||
#define FALSE 0
|
||||
#define MAX(x, y) ((x > y) ? x : y)
|
|
@ -1,40 +0,0 @@
|
|||
From db7007a25faefb0cc90e64dda1c0793393b9512d Mon Sep 17 00:00:00 2001
|
||||
From: Antonio Rojas <arojas@archlinux.org>
|
||||
Date: Tue, 26 May 2020 20:10:48 +0200
|
||||
Subject: [PATCH] Update fontconfig database for Qt 5.15
|
||||
|
||||
---
|
||||
src/calibre/headless/fontconfig_database.cpp | 19 +++++++++++++++++++
|
||||
1 file changed, 19 insertions(+)
|
||||
|
||||
diff --git a/src/calibre/headless/fontconfig_database.cpp b/src/calibre/headless/fontconfig_database.cpp
|
||||
index d867f02948..96a6365ba2 100644
|
||||
--- a/src/calibre/headless/fontconfig_database.cpp
|
||||
+++ b/src/calibre/headless/fontconfig_database.cpp
|
||||
@@ -295,7 +295,26 @@ static const char specialLanguages[][6] = {
|
||||
"", // MasaramGondi
|
||||
"", // Nushu
|
||||
"", // Soyombo
|
||||
+#if (QT_VERSION >= QT_VERSION_CHECK(5, 15, 0))
|
||||
+ "", // ZanabazarSquare
|
||||
+ "", // Dogra
|
||||
+ "", // GunjalaGondi
|
||||
+ "", // HanifiRohingya
|
||||
+ "", // Makasar
|
||||
+ "", // Medefaidrin
|
||||
+ "", // OldSogdian
|
||||
+ "", // Sogdian
|
||||
+ "", // Elymaic
|
||||
+ "", // Nandinagari
|
||||
+ "", // NyiakengPuachueHmong
|
||||
+ "", // Wancho
|
||||
+ "", // Chorasmian
|
||||
+ "", // DivesAkuru
|
||||
+ "", // KhitanSmallScript
|
||||
+ "" // Yezidi
|
||||
+#else
|
||||
"" // ZanabazarSquare
|
||||
+#endif // Qt >= 5.15
|
||||
#else
|
||||
"" // SignWriting
|
||||
#endif // Qt >= 5.11
|
|
@ -1,14 +0,0 @@
|
|||
diff -Naur calibre-3.48.0.orig/src/calibre/linux.py calibre-3.48.0/src/calibre/linux.py
|
||||
--- calibre-3.48.0.orig/src/calibre/linux.py 2019-09-13 04:46:46.000000000 +0200
|
||||
+++ calibre-3.48.0/src/calibre/linux.py 2020-03-04 15:02:49.789055000 +0100
|
||||
@@ -725,10 +725,6 @@
|
||||
self.appdata_resources = []
|
||||
if islinux or isbsd:
|
||||
self.setup_completion()
|
||||
- if islinux or isbsd:
|
||||
- self.setup_desktop_integration()
|
||||
- if not getattr(self.opts, 'staged_install', False):
|
||||
- self.create_uninstaller()
|
||||
|
||||
from calibre.utils.config import config_dir
|
||||
if os.path.exists(config_dir):
|
|
@ -1,19 +0,0 @@
|
|||
# HOW TO EDIT THIS FILE:
|
||||
# The "handy ruler" below makes it easier to edit a package description.
|
||||
# Line up the first '|' above the ':' following the base package name, and
|
||||
# the '|' on the right side marks the last column you can put a character in.
|
||||
# You must make exactly 11 lines for the formatting to be correct. It's also
|
||||
# customary to leave one space after the ':' except on otherwise blank lines.
|
||||
|
||||
|-----handy-ruler------------------------------------------------------|
|
||||
calibre: calibre (Ebook library manager)
|
||||
calibre:
|
||||
calibre: Calibre is a one stop solution to all your e-book needs. It is free,
|
||||
calibre: open source and cross-platform in design and works well on Linux,
|
||||
calibre: OS X and Windows. calibre is meant to be a complete e-library
|
||||
calibre: solution and thus includes library management, format conversion,
|
||||
calibre: news feeds to ebook conversion, as well as e-book reader sync
|
||||
calibre: features and an integrated e-book viewer.
|
||||
calibre:
|
||||
calibre: Homepage: https://calibre-ebook.com
|
||||
calibre:
|
Loading…
Reference in New Issue