libraries/SimGear: Updated for version 2020.1.2.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
e683923459
commit
41394fb628
|
@ -3,5 +3,4 @@ blocks for quickly assembling 3d simulations, games, and visualization
|
|||
applications.
|
||||
|
||||
For those wanting to build this in current (15.0 EXPERIMENTAL), pass
|
||||
CURRENT=yes to the script (currently broken ATM because of the new boost
|
||||
version but I'm working on it).
|
||||
CURRENT=yes to the script.
|
||||
|
|
|
@ -0,0 +1,29 @@
|
|||
diff -Naur simgear-2020.1.2/CMakeLists.txt simgear-2020.1.2.new/CMakeLists.txt
|
||||
--- simgear-2020.1.2/CMakeLists.txt 2020-05-24 11:13:35.000000000 -0400
|
||||
+++ simgear-2020.1.2.new/CMakeLists.txt 2020-06-01 09:36:21.608814301 -0400
|
||||
@@ -43,13 +43,13 @@
|
||||
set(CMAKE_CXX_STANDARD_REQUIRED YES)
|
||||
|
||||
# read 'version' file into a variable (stripping any newlines or spaces)
|
||||
-file(READ version versionFile)
|
||||
+file(READ simgear-version versionFile)
|
||||
string(STRIP ${versionFile} SIMGEAR_VERSION)
|
||||
|
||||
project(SimGear VERSION ${SIMGEAR_VERSION} LANGUAGES C CXX)
|
||||
|
||||
# add a dependency on the version file
|
||||
-set_property(DIRECTORY APPEND PROPERTY CMAKE_CONFIGURE_DEPENDS version)
|
||||
+set_property(DIRECTORY APPEND PROPERTY CMAKE_CONFIGURE_DEPENDS simgear-version)
|
||||
|
||||
set_property(GLOBAL PROPERTY FIND_LIBRARY_USE_LIB64_PATHS TRUE)
|
||||
|
||||
diff -Naur simgear-2020.1.2/simgear-version simgear-2020.1.2.new/simgear-version
|
||||
--- simgear-2020.1.2/simgear-version 1969-12-31 19:00:00.000000000 -0500
|
||||
+++ simgear-2020.1.2.new/simgear-version 2020-05-24 11:13:36.000000000 -0400
|
||||
@@ -0,0 +1 @@
|
||||
+2020.1.2
|
||||
diff -Naur simgear-2020.1.2/version simgear-2020.1.2.new/version
|
||||
--- simgear-2020.1.2/version 2020-05-24 11:13:36.000000000 -0400
|
||||
+++ simgear-2020.1.2.new/version 1969-12-31 19:00:00.000000000 -0500
|
||||
@@ -1 +0,0 @@
|
||||
-2020.1.2
|
|
@ -24,7 +24,7 @@
|
|||
|
||||
PRGNAM=SimGear
|
||||
SRCNAM=simgear
|
||||
VERSION=${VERSION:-2020.1.1}
|
||||
VERSION=${VERSION:-2020.1.2}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
|
@ -75,6 +75,8 @@ if [ "${CURRENT:-no}" = "yes" ]; then
|
|||
BOOSTOPT="-DBoost_NO_BOOST_CMAKE=ON"
|
||||
# patch for the new boost:
|
||||
patch -p1 < $CWD/simgear-enable-if.patch
|
||||
# Thanks Gentoo for this one
|
||||
patch -p1 < $CWD/SimGear-version.patch
|
||||
else
|
||||
BOOSTOPT=""
|
||||
fi
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
PRGNAM="SimGear"
|
||||
VERSION="2020.1.1"
|
||||
VERSION="2020.1.2"
|
||||
HOMEPAGE="http://wiki.flightgear.org/SimGear"
|
||||
DOWNLOAD="https://downloads.sourceforge.net/flightgear/simgear-2020.1.1.tar.bz2"
|
||||
MD5SUM="d50075fc2683fb2b8b21b018b09b28f3"
|
||||
DOWNLOAD="https://downloads.sourceforge.net/flightgear/simgear-2020.1.2.tar.bz2"
|
||||
MD5SUM="72b30525f3c9f538535574403ea3d4ab"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES="OpenSceneGraph freealut plib"
|
||||
|
|
Loading…
Reference in New Issue