python/python-pcapy: Updated for version 0.11.3.
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
This commit is contained in:
parent
088932d279
commit
3eb8b3c4dd
|
@ -1,15 +1,10 @@
|
||||||
--- pcapy-0.11.1.orig/setup.py 2017-01-16 09:38:07.000000000 -0700
|
--- pcapy-0.11.3/setup.py.orig 2018-04-09 14:01:47.209882717 -0600
|
||||||
+++ pcapy-0.11.1/setup.py 2017-04-06 17:01:20.736516673 -0600
|
+++ pcapy-0.11.3/setup.py 2018-04-09 14:06:58.308869383 -0600
|
||||||
@@ -79,8 +79,8 @@
|
@@ -88,7 +88,4 @@
|
||||||
library_dirs=library_dirs,
|
library_dirs=library_dirs,
|
||||||
libraries=libraries)],
|
libraries=libraries)],
|
||||||
# scripts=['tests/pcapytests.py', 'tests/96pings.pcap'],
|
#scripts=['tests/pcapytests.py', 'tests/96pings.pcap'],
|
||||||
- data_files=[
|
- data_files=[
|
||||||
- (os.path.join('share', 'doc', PACKAGE_NAME),
|
- (os.path.join('share', 'doc', PACKAGE_NAME), ['README', 'LICENSE', 'pcapy.html']),
|
||||||
- ['README', 'LICENSE', 'pcapy.html']),
|
- (os.path.join('share', 'doc', PACKAGE_NAME, 'tests'), glob.glob('tests/*'))]
|
||||||
- ('tests', ['tests/pcapytests.py', 'tests/96pings.pcap'])]
|
|
||||||
+ #data_files=[
|
|
||||||
+ # (os.path.join('share', 'doc', PACKAGE_NAME),
|
|
||||||
+ # ['README', 'LICENSE', 'pcapy.html']),
|
|
||||||
+ # ('tests', ['tests/pcapytests.py', 'tests/96pings.pcap'])]
|
|
||||||
)
|
)
|
||||||
|
|
|
@ -24,7 +24,7 @@
|
||||||
|
|
||||||
PRGNAM=python-pcapy
|
PRGNAM=python-pcapy
|
||||||
SRCNAM=pcapy
|
SRCNAM=pcapy
|
||||||
VERSION=${VERSION:-0.11.1}
|
VERSION=${VERSION:-0.11.3}
|
||||||
BUILD=${BUILD:-1}
|
BUILD=${BUILD:-1}
|
||||||
TAG=${TAG:-_SBo}
|
TAG=${TAG:-_SBo}
|
||||||
|
|
||||||
|
@ -76,6 +76,11 @@ patch -p1 --verbose < $CWD/no-auto-docs-setup.py.diff
|
||||||
|
|
||||||
python setup.py install --root=$PKG
|
python setup.py install --root=$PKG
|
||||||
|
|
||||||
|
# Python 3 support.
|
||||||
|
if $(python3 -c 'import sys' 2>/dev/null); then
|
||||||
|
python3 setup.py install --root=$PKG
|
||||||
|
fi
|
||||||
|
|
||||||
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
|
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
|
||||||
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
|
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
|
||||||
|
|
||||||
|
|
|
@ -1,8 +1,8 @@
|
||||||
PRGNAM="python-pcapy"
|
PRGNAM="python-pcapy"
|
||||||
VERSION="0.11.1"
|
VERSION="0.11.3"
|
||||||
HOMEPAGE="https://www.coresecurity.com/corelabs-research/open-source-tools/pcapy"
|
HOMEPAGE="https://www.coresecurity.com/corelabs-research/open-source-tools/pcapy"
|
||||||
DOWNLOAD="https://github.com/CoreSecurity/pcapy/archive/0.11.1/pcapy-0.11.1.tar.gz"
|
DOWNLOAD="https://github.com/CoreSecurity/pcapy/archive/0.11.3/pcapy-0.11.3.tar.gz"
|
||||||
MD5SUM="eb82db6abbffae1786c5bae51c951685"
|
MD5SUM="a52f104c3dcadfb40275a48794634557"
|
||||||
DOWNLOAD_x86_64=""
|
DOWNLOAD_x86_64=""
|
||||||
MD5SUM_x86_64=""
|
MD5SUM_x86_64=""
|
||||||
REQUIRES=""
|
REQUIRES=""
|
||||||
|
|
Loading…
Reference in New Issue