network/open-iscsi: Updated for version 2.1.5.

Signed-off-by: Mario Preksavec <mario@slackware.hr>

Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
Mario Preksavec 2021-12-06 01:30:12 +01:00 committed by Willy Sudiarto Raharjo
parent 1c49148319
commit 3d25e1af34
No known key found for this signature in database
GPG Key ID: 3F617144D7238786
4 changed files with 33 additions and 17 deletions

View File

@ -20,14 +20,3 @@ diff -Naur open-iscsi-2.0.875.orig/iscsiuio/src/unix/libs/bnx2x.c open-iscsi-2.0
#include "config.h"
diff -Naur open-iscsi-2.0.875.orig/iscsiuio/src/unix/libs/qedi.c open-iscsi-2.0.875/iscsiuio/src/unix/libs/qedi.c
--- open-iscsi-2.0.875.orig/iscsiuio/src/unix/libs/qedi.c 2017-09-01 20:05:23.000000000 +0200
+++ open-iscsi-2.0.875/iscsiuio/src/unix/libs/qedi.c 2019-09-06 14:29:00.780039000 +0200
@@ -58,6 +58,7 @@
#include <sys/user.h>
#include <fcntl.h>
#include <unistd.h>
+#include <sys/sysmacros.h>
#include "config.h"

View File

@ -3,6 +3,7 @@
# Slackware build script for open-iscsi
# Copyright 2019 Wayne Cuddy USA
# Copyright 2021 Mario Preksavec, Zagreb, Croatia
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@ -29,8 +30,8 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=open-iscsi
VERSION=${VERSION:-2.0.875}
BUILD=${BUILD:-3}
VERSION=${VERSION:-2.1.5}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@ -80,6 +81,8 @@ cd $PRGNAM-$VERSION
# Allow this SB to work on "current", benign on 14.2.
patch -p1 <$CWD/include_sysmacros.patch
patch -p1 <$CWD/remove_werror.patch
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@ -87,7 +90,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
make
make OPTFLAGS="-DNO_SYSTEMD" NO_SYSTEMD=1
make install DESTDIR=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \

View File

@ -1,8 +1,8 @@
PRGNAM="open-iscsi"
VERSION="2.0.875"
VERSION="2.1.5"
HOMEPAGE="https://github.com/open-iscsi/open-iscsi"
DOWNLOAD="https://github.com/open-iscsi/open-iscsi/archive/2.0.875/open-iscsi-2.0.875.tar.gz"
MD5SUM="982e48181411365fa11b3364cf91a977"
DOWNLOAD="https://github.com/open-iscsi/open-iscsi/archive/2.1.5/open-iscsi-2.1.5.tar.gz"
MD5SUM="fcde2e39f3bec7b668751035987fdc35"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="open-isns"

View File

@ -0,0 +1,24 @@
--- open-iscsi-2.1.1/libopeniscsiusr/Makefile.orig 2020-02-26 20:07:13.000000000 +0100
+++ open-iscsi-2.1.1/libopeniscsiusr/Makefile 2020-07-14 18:13:07.144477155 +0200
@@ -44,7 +44,7 @@
OBJS = context.o misc.o session.o sysfs.o iface.o idbm.o node.o default.o
CFLAGS ?= -O2 -g
-CFLAGS += -Wall -Werror -Wextra -fvisibility=hidden -fPIC
+CFLAGS += -Wall -Wextra -fvisibility=hidden -fPIC
CFLAGS += $(shell $(PKG_CONFIG) --cflags libkmod)
LDFLAGS += $(shell $(PKG_CONFIG) --libs libkmod)
--- open-iscsi-2.1.1/usr/Makefile 2020-02-26 20:07:13.000000000 +0100
+++ open-iscsi-2.1.1/usr/Makefile 2020-07-14 17:56:48.298477155 +0200
@@ -35,7 +35,7 @@
PKG_CONFIG = /usr/bin/pkg-config
CFLAGS ?= -O2 -g
-WARNFLAGS ?= -Wall -Wextra -Werror -Wstrict-prototypes -fno-common
+WARNFLAGS ?= -Wall -Wextra -Wstrict-prototypes -fno-common
CFLAGS += $(WARNFLAGS) -I../include -I. -D_GNU_SOURCE \
-I$(TOPDIR)/libopeniscsiusr
CFLAGS += $(shell $(PKG_CONFIG) --cflags libkmod)