multimedia/vobcopy: Updated for version 1.2.0

This commit is contained in:
Nishant Limbachia 2010-05-13 00:35:17 +02:00 committed by David Somero
parent 91dc3878c8
commit 3cacf179da
5 changed files with 65 additions and 35 deletions

View File

@ -0,0 +1,20 @@
--- Makefile.orig 2009-07-01 13:06:33.857658500 -0500
+++ Makefile 2009-07-01 16:09:55.195727429 -0500
@@ -7,13 +7,13 @@
#PREFIX += /usr/local
#BINDIR = ${PREFIX}/bin
#MANDIR = ${PREFIX}/man
-PREFIX += /usr/local
+PREFIX += /usr
BINDIR = ${PREFIX}/bin
MANDIR = ${PREFIX}/man
-DOCDIR = ${PREFIX}/share/doc/vobcopy
+DOCDIR = ${PREFIX}/doc/vobcopy-@VERSION@
LFS = -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE
-CFLAGS += -I/usr/local//include
-LDFLAGS += -ldvdread -L/usr/local//lib
+CFLAGS += -I/usr/include
+LDFLAGS += -ldvdread -L/usr/lib@LIBDIRSUFFIX@
#This specifies the conversion from .c to .o
.c.o:

View File

@ -1,5 +1,5 @@
vobcopy copies .vob files from DVD to hard drives.
vobcopy copies .vob files from DVD to hard drives. vobcopy also uses
libdvdcss (if available) for encrypted dvds.
Please refer README or manpages in the package for usage info.
vobcopy requires libdvdread and (optionally) libdvdcss for encrypted
dvd's; both are available at SlackBuilds.org.
Optional dependency: libdvdcss for encrypted dvds available at SBo.

View File

@ -5,12 +5,13 @@
# make exactly 11 lines for the formatting to be correct. It's also
# customary to leave one space after the ':'.
|-----handy-ruler-----------------------------------------------------|
|-----handy-ruler---------------------------------------------------|
vobcopy: vobcopy (decrypts and copies the dvd vob files)
vobcopy:
vobcopy: vobcopy decrypts and copies the dvd vob files to your local
vobcopy: hard drive. It uses libdvdread and libdvdcss (for decryption)
vobcopy:
vobcopy:
vobcopy: Home page http://www.vobcopy.org
vobcopy:
vobcopy:

View File

@ -1,17 +1,17 @@
#!/bin/sh
# Slackware Package Build Script for vobcopy
# Home Page http://vobcopy.org
# Home Page http://vobcopy.org/
# Copyright (c) 2007, Nishant Limbachia (nishant@mnspace.net)
# Copyright (c) 2007-2009, Nishant Limbachia, Hoffman Est, IL, USA (nishant@mnspace.net)
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of script must retain the above copyright notice,
# this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
@ -25,7 +25,7 @@
# SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=vobcopy
VERSION=1.1.2
VERSION=1.2.0
ARCH=${ARCH:-i486}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@ -35,52 +35,59 @@ PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
CWD=$(pwd)
set -e
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
fi
set -e
rm -fr $TMP/$PRGNAM-$VERSION $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
tar xvf $CWD/$PRGNAM-$VERSION.tar.?z*
cd $TMP/$PRGNAM-$VERSION
chown -R root.root .
find . \
\( -perm 664 -o -perm 666 -o -perm 600 -o -perm 440 -o -perm 444 -o -perm 400 \) \
-exec chmod 644 {} \;
find . \
\( -perm 777 -o -perm 755 -o -perm 711 -o -perm 700 -o -perm 555 -o -perm 511 -o -perm 500 \) \
-exec chmod 755 {} \;
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
CFLAGS="$SLKCFLAGS" make
mkdir -p $PKG/usr/{bin,include,man/man1}
### patch makefile
patch -p0 < $CWD/Makefile.patch
install --strip -m 0755 vobcopy $PKG/usr/bin
install -m 0644 vobcopy.1 $PKG/usr/man/man1
install -m 0644 vobcopy.h dvd.h $PKG/usr/include
### update Makefile
sed -i "s|@VERSION@|$VERSION|" Makefile
sed -i "s|@LIBDIRSUFFIX@|$LIBDIRSUFFIX|" Makefile
### make and install
CFLAGS=${SLKCFLAGS} make
make install DESTDIR=$PKG
### strip binary
( cd $PKG
find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
xargs strip --strip-unneeded 2> /dev/null || true
find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
xargs strip --strip-unneeded 2> /dev/null
)
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a COPYING Changelog README Release-Notes TODO alternative_programs.txt \
$PKG/usr/doc/$PRGNAM-$VERSION
( cd $PKG/usr/man || exit 1
( cd $PKG/usr/man
find . -type f -exec gzip -9 {} \;
for i in $(find . -type l) ; do ln -s $(readlink $i).gz $i.gz ; rm $i ; done
)
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}

View File

@ -1,8 +1,10 @@
PRGNAM="vobcopy"
VERSION="1.1.2"
VERSION="1.2.0"
HOMEPAGE="http://vobcopy.org/"
DOWNLOAD="http://vobcopy.org/download/vobcopy-1.1.2.tar.bz2"
MD5SUM="7f4bc2ba19d567339e4d854636aafa24"
DOWNLOAD="http://vobcopy.org/download/vobcopy-1.2.0.tar.bz2"
MD5SUM="88f735ccd051093ff40dab4597bc586e"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MAINTAINER="Nishant Limbachia"
EMAIL="nishant@mnspace.net"
APPROVED="rworkman"
APPROVED="dsomero"