development/pcc-libs: Removed (included in pcc).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
0643223074
commit
39c33d45e6
|
@ -1,26 +0,0 @@
|
|||
Description: Fix buildsystem
|
||||
- Enable us to build pcc-libs with pcc
|
||||
Author: Thorsten Glaser <tg@mirbsd.de>
|
||||
Forwarded: http://article.gmane.org/gmane.comp.compilers.pcc/2094
|
||||
Last-Update: $MirOS: contrib/hosted/tg/deb/pcc/debian/patches/002-build-libpcc-with-pcc,v 1.1 2011/04/22 19:15:01 tg Exp $
|
||||
|
||||
--- pcc-libs-1.0.0/libsoftfloat/Makefile.in
|
||||
+++ pcc-libs-1.0.0/libsoftfloat/Makefile.in
|
||||
@@ -18,6 +18,7 @@ VERSION = @version@
|
||||
PCCLIBDIR = $(libdir)/pcc/$(TARGET)/$(VERSION)/lib
|
||||
|
||||
CPPFLAGS += @CPPFLAGS@ -DSOFTFLOAT_FOR_GCC -I$(srcdir) -I$(srcdir)/arch/$(TARGMACH)
|
||||
+CPPFLAGS += -isystem $(top_srcdir)/libpcc/include
|
||||
|
||||
LIBS = @LIBS@
|
||||
AR = @AR@
|
||||
--- pcc-libs-1.0.0/libpcc/Makefile.in
|
||||
+++ pcc-libs-1.0.0/libpcc/Makefile.in
|
||||
@@ -20,6 +20,7 @@ PCCLIBDIR = $(libdir)/pcc/$(TARGET)/$(VE
|
||||
PCCINCDIR = $(libdir)/pcc/$(TARGET)/$(VERSION)/include
|
||||
|
||||
CPPFLAGS += @CPPFLAGS@ -I$(srcdir) @ENDIAN_FLAG@ -Dos_$(TARGOS)
|
||||
+CPPFLAGS += -isystem $(top_srcdir)/libpcc/include
|
||||
|
||||
LIBS = @LIBS@
|
||||
AR = @AR@
|
|
@ -1,7 +0,0 @@
|
|||
pcc-libs (Standard C library for pcc)
|
||||
|
||||
The compiler is based on the original Portable C Compiler by S. C.
|
||||
Johnson, written in the late 70's. About 50% of the frontend code
|
||||
and 80% of the backend code has been rewritten.
|
||||
|
||||
This package contains the standard C library for pcc.
|
|
@ -1,77 +0,0 @@
|
|||
#!/bin/sh
|
||||
|
||||
# Slackware build script for pcc (Portable C Compiler)
|
||||
# Written by Armin Besirovic <armin[at]linux[dot]org[dot]ba>
|
||||
|
||||
PRGNAM=pcc-libs
|
||||
VERSION=${VERSION:-1.0.0}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
if [ -z "$ARCH" ]; then
|
||||
case "$( uname -m )" in
|
||||
i?86) ARCH=i486 ;;
|
||||
arm*) ARCH=arm ;;
|
||||
*) ARCH=$( uname -m ) ;;
|
||||
esac
|
||||
fi
|
||||
|
||||
CWD=$(pwd)
|
||||
TMP=${TMP:-/tmp/SBo}
|
||||
PKG=$TMP/package-$PRGNAM
|
||||
OUTPUT=${OUTPUT:-/tmp}
|
||||
|
||||
if [ "$ARCH" = "i486" ]; then
|
||||
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
|
||||
LIBDIRSUFFIX=""
|
||||
elif [ "$ARCH" = "i686" ]; then
|
||||
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
|
||||
LIBDIRSUFFIX=""
|
||||
elif [ "$ARCH" = "x86_64" ]; then
|
||||
SLKCFLAGS="-O2 -fPIC"
|
||||
LIBDIRSUFFIX="64"
|
||||
else
|
||||
SLKCFLAGS="-O2"
|
||||
LIBDIRSUFFIX=""
|
||||
fi
|
||||
|
||||
set -e
|
||||
|
||||
rm -rf $PKG
|
||||
mkdir -p $TMP $PKG $OUTPUT
|
||||
cd $TMP
|
||||
rm -rf $PRGNAM-$VERSION
|
||||
tar xvf $CWD/$PRGNAM-$VERSION.tgz
|
||||
cd $PRGNAM-$VERSION
|
||||
chown -R root:root .
|
||||
find -L . \
|
||||
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
|
||||
-exec chmod 755 {} \; -o \
|
||||
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
||||
-exec chmod 644 {} \;
|
||||
|
||||
# Fixup to compile pcc-libs with pcc
|
||||
# Thanks to Thorsten Glaser <tg@mirbsd.de>
|
||||
patch -p1 < $CWD/002-build-libpcc-with-pcc.patch
|
||||
|
||||
CFLAGS="$SLKCFLAGS" \
|
||||
CXXFLAGS="$SLKCFLAGS" \
|
||||
./configure \
|
||||
--prefix=/usr \
|
||||
--libdir=/usr/lib${LIBDIRSUFFIX} \
|
||||
--build=$ARCH-slackware-linux
|
||||
|
||||
make
|
||||
make install DESTDIR=$PKG
|
||||
|
||||
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
|
||||
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
|
||||
|
||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||
|
||||
mkdir -p $PKG/install
|
||||
cat $CWD/slack-desc > $PKG/install/slack-desc
|
||||
|
||||
cd $PKG
|
||||
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
|
|
@ -1,10 +0,0 @@
|
|||
PRGNAM="pcc-libs"
|
||||
VERSION="1.0.0"
|
||||
HOMEPAGE="http://pcc.ludd.ltu.se/"
|
||||
DOWNLOAD="ftp://pcc.ludd.ltu.se/pub/pcc-releases/pcc-libs-1.0.0.tgz"
|
||||
MD5SUM="a8dfcd6d3be512bc3f16f96c9abf132e"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES=""
|
||||
MAINTAINER="Armin Besirovic"
|
||||
EMAIL="armin[at]linux[dot]org[dot]ba"
|
|
@ -1,19 +0,0 @@
|
|||
# HOW TO EDIT THIS FILE:
|
||||
# The "handy ruler" below makes it easier to edit a package description.
|
||||
# Line up the first '|' above the ':' following the base package name, and
|
||||
# the '|' on the right side marks the last column you can put a character in.
|
||||
# You must make exactly 11 lines for the formatting to be correct. It's also
|
||||
# customary to leave one space after the ':' except on otherwise blank lines.
|
||||
|
||||
|-----handy-ruler------------------------------------------------------|
|
||||
pcc-libs: pcc-libs (C Library for the Portable C Compiler)
|
||||
pcc-libs:
|
||||
pcc-libs: The compiler is based on the original Portable C Compiler by S. C.
|
||||
pcc-libs: Johnson, written in the late 70's. About 50% of the frontend code
|
||||
pcc-libs: and 80% of the backend code has been rewritten. See the PCC History
|
||||
pcc-libs: wiki page for details.
|
||||
pcc-libs:
|
||||
pcc-libs: This package contains the standard C library.
|
||||
pcc-libs:
|
||||
pcc-libs: Project website: http://pcc.ludd.ltu.se/
|
||||
pcc-libs:
|
Loading…
Reference in New Issue