graphics/MaterialX: Added (Open standard for computer graphics).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
63ea6006e6
commit
38159e03b4
|
@ -0,0 +1,215 @@
|
|||
#!/bin/bash
|
||||
|
||||
# Slackware build script for MaterialX
|
||||
|
||||
# Copyright 2023 Giancarlo Dessi, Cagliari, IT
|
||||
# All rights reserved.
|
||||
#
|
||||
# Redistribution and use of this script, with or without modification, is
|
||||
# permitted provided that the following conditions are met:
|
||||
#
|
||||
# 1. Redistributions of this script must retain the above copyright
|
||||
# notice, this list of conditions and the following disclaimer.
|
||||
#
|
||||
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
|
||||
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
|
||||
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
|
||||
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
||||
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
|
||||
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
|
||||
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
|
||||
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
|
||||
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
||||
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
|
||||
cd $(dirname $0) ; CWD=$(pwd)
|
||||
|
||||
PRGNAM=MaterialX
|
||||
VERSION=${VERSION:-1.38.8}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
PKGTYPE=${PKGTYPE:-tgz}
|
||||
EXTVERSION=20240101
|
||||
|
||||
if [ -z "$ARCH" ]; then
|
||||
case "$( uname -m )" in
|
||||
i?86) ARCH=i586 ;;
|
||||
arm*) ARCH=arm ;;
|
||||
*) ARCH=$( uname -m ) ;;
|
||||
esac
|
||||
fi
|
||||
|
||||
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
|
||||
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
|
||||
exit 0
|
||||
fi
|
||||
|
||||
TMP=${TMP:-/tmp/SBo}
|
||||
PKG=$TMP/package-$PRGNAM
|
||||
OUTPUT=${OUTPUT:-/tmp}
|
||||
|
||||
if [ "$ARCH" = "i586" ]; then
|
||||
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
|
||||
LIBDIRSUFFIX=""
|
||||
elif [ "$ARCH" = "i686" ]; then
|
||||
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
|
||||
LIBDIRSUFFIX=""
|
||||
elif [ "$ARCH" = "x86_64" ]; then
|
||||
SLKCFLAGS="-O2 -fPIC"
|
||||
LIBDIRSUFFIX="64"
|
||||
else
|
||||
SLKCFLAGS="-O2"
|
||||
LIBDIRSUFFIX=""
|
||||
fi
|
||||
|
||||
set -e
|
||||
|
||||
if [ -d /usr/share/cmake-3.28 ]; then
|
||||
# This prevents some cmake warnings in current
|
||||
CMAKE_POLICY="-DCMAKE_POLICY_DEFAULT_CMP0148=OLD "
|
||||
else
|
||||
CMAKE_POLICY=""
|
||||
fi
|
||||
|
||||
if pkg-config --exists OpenImageIO; then
|
||||
WITHOIIO=""; \
|
||||
[ "${OIIO:-yes}" = "yes" ] && WITHOIIO="-DMATERIALX_BUILD_OIIO=ON "
|
||||
else
|
||||
WITHOIIO=""
|
||||
fi
|
||||
|
||||
rm -rf $PKG
|
||||
mkdir -p $TMP $PKG $OUTPUT
|
||||
cd $TMP
|
||||
rm -rf $PRGNAM-$VERSION
|
||||
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
|
||||
cd $PRGNAM-$VERSION
|
||||
|
||||
BUILDOPTIONS=""
|
||||
GUI=no
|
||||
SET_GRAPH_EDITOR=no
|
||||
SET_VIEWER=no
|
||||
|
||||
# Some third-part modules are build as internal but are not included in the
|
||||
# source tarball because should be added in a git repository of
|
||||
# MaterialX cloned with git -recursive, so we have to do the following steps
|
||||
|
||||
if [ ${VIEWER:-yes} = "yes" ]; then
|
||||
tar xvf $CWD/nanogui-$EXTVERSION.tar.gz
|
||||
tar xvf $CWD/glfw-$EXTVERSION.tar.gz
|
||||
tar xvf $CWD/nanobind-$EXTVERSION.tar.gz
|
||||
tar xvf $CWD/nanovg-$EXTVERSION.tar.gz
|
||||
tar xvf $CWD/robin-map-$EXTVERSION.tar.gz
|
||||
rm -rf nanogui-$EXTVERSION/ext/glfw
|
||||
rm -rf nanogui-$EXTVERSION/ext/nanovg
|
||||
rm -rf nanogui-$EXTVERSION/ext/nanobind
|
||||
mv glfw-$EXTVERSION nanogui-$EXTVERSION/ext/glfw
|
||||
mv nanovg-$EXTVERSION nanogui-$EXTVERSION/ext/nanovg
|
||||
mv nanobind-$EXTVERSION nanogui-$EXTVERSION/ext/nanobind
|
||||
rm -rf nanogui-$EXTVERSION/ext/robin_map
|
||||
mv robin-map-$EXTVERSION nanogui-$EXTVERSION/ext/nanobind/ext/robin_map
|
||||
rm -rf source/MaterialXView/NanoGUI
|
||||
mv nanogui-$EXTVERSION source/MaterialXView/NanoGUI
|
||||
|
||||
BUILDOPTIONS="-DMATERIALX_BUILD_VIEWER=ON -DNANOGUI_PREFERRED_BACKEND=OpenGL "
|
||||
GUI=yes
|
||||
SET_VIEWER=yes
|
||||
|
||||
sed -i ./source/MaterialXView/NanoGUI/resources/bin2c.cmake -e \
|
||||
"s/cmake_minimum_required (VERSION 2.8.12)/cmake_minimum_required (VERSION 3.5)/g"
|
||||
fi
|
||||
|
||||
if [ ${EDITOR:-yes} = "yes" ]; then
|
||||
tar xvf $CWD/imgui-$EXTVERSION.tar.gz
|
||||
tar xvf $CWD/imgui-node-editor-$EXTVERSION.tar.gz
|
||||
rm -rf source/MaterialXGraphEditor/External/ImGui*
|
||||
mv imgui-$EXTVERSION source/MaterialXGraphEditor/External/ImGui
|
||||
mv imgui-node-editor-$EXTVERSION source/MaterialXGraphEditor/External/ImGuiNodeEditor
|
||||
|
||||
BUILDOPTIONS="$BUILDOPTIONS -DMATERIALX_BUILD_GRAPH_EDITOR=ON "
|
||||
GUI=yes
|
||||
SET_GRAPH_EDITOR=yes
|
||||
|
||||
sed -i ./source/MaterialXGraphEditor/External/Glfw/CMakeLists.txt -e \
|
||||
"s/cmake_minimum_required(VERSION 3.1)/cmake_minimum_required (VERSION 3.5)/g"
|
||||
fi
|
||||
|
||||
if [ $GUI = "yes" ]; then
|
||||
cp -a $CWD/materialx.png $CWD/*.desktop ./
|
||||
fi
|
||||
|
||||
if [ ${PYTHON:-yes} = "yes" ]; then
|
||||
BUILDOPTIONS="$BUILDOPTIONS -DMATERIALX_BUILD_PYTHON=ON -DMATERIALX_INSTALL_PYTHON=ON "
|
||||
patch -p1 < $CWD/fix-setup_py_in.patch
|
||||
else
|
||||
BUILDOPTIONS="$BUILDOPTIONS -DMATERIALX_BUILD_PYTHON=OFF "
|
||||
fi
|
||||
|
||||
chown -R root:root .
|
||||
find -L . \
|
||||
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
|
||||
-o -perm 511 \) -exec chmod 755 {} \; -o \
|
||||
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
|
||||
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
|
||||
|
||||
mkdir -p build
|
||||
cd build
|
||||
cmake \
|
||||
-DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
|
||||
-DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
|
||||
-DCMAKE_INSTALL_PREFIX=/usr/share/MaterialX \
|
||||
-DMATERIALX_BUILD_SHARED_LIBS=ON \
|
||||
-DMATERIALX_INSTALL_LIB_PATH=../../lib${LIBDIRSUFFIX} \
|
||||
$WITHOIIO \
|
||||
$BUILDOPTIONS \
|
||||
$CMAKE_POLICY \
|
||||
-DCMAKE_BUILD_TYPE=Release ..
|
||||
make
|
||||
make install/strip DESTDIR=$PKG
|
||||
cd ..
|
||||
|
||||
rm -f $PKG/{,usr/}lib${LIBDIRSUFFIX}/*.la
|
||||
|
||||
# fix wrong, redundant, and/or non standard installation path
|
||||
rm -rf $PKG/tmp
|
||||
rm -f $PKG/usr/share/MaterialX/*.md $PKG/usr/share/MaterialX/LICENSE
|
||||
|
||||
# add symbolic links to executable and include files
|
||||
mkdir -p $PKG/usr/include
|
||||
cd $PKG/usr/include
|
||||
ln -s ../share/MaterialX/include MaterialX
|
||||
|
||||
if [ $GUI = "yes" ]; then
|
||||
mkdir -p $PKG/usr/bin
|
||||
mkdir -p $PKG/usr/share/applications
|
||||
mkdir -p $PKG/usr/share/icons/hicolor/256x256/apps
|
||||
cp -a $TMP/$PRGNAM-$VERSION/materialx.png $PKG/usr/share/icons/hicolor/256x256/apps
|
||||
cd $PKG/usr/bin
|
||||
fi
|
||||
|
||||
if [ "$SET_GRAPH_EDITOR" = "yes" ]; then
|
||||
echo "Creating symbolic links and desktop entry for MaterialX Graph Editor ..."
|
||||
ln -s ../share/MaterialX/bin/MaterialXGraphEditor MaterialXGraphEditor
|
||||
cp -a $TMP/$PRGNAM-$VERSION/MaterialXGraphEditor.desktop \
|
||||
$PKG/usr/share/applications/MaterialXGraphEditor.desktop
|
||||
fi
|
||||
|
||||
if [ "$SET_VIEWER" = "yes" ]; then
|
||||
echo "Creating symbolic links and desktop entry for MaterialX View ..."
|
||||
ln -s ../share/MaterialX/bin/MaterialXView MaterialXView
|
||||
cp -a $TMP/$PRGNAM-$VERSION/MaterialXView.desktop \
|
||||
$PKG/usr/share/applications/MaterialXView.desktop
|
||||
fi
|
||||
|
||||
cd $TMP/$PRGNAM-$VERSION
|
||||
|
||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp -a *.md LICENSE $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||
|
||||
mkdir -p $PKG/install
|
||||
cat $CWD/slack-desc > $PKG/install/slack-desc
|
||||
cat $CWD/doinst.sh > $PKG/install/doinst.sh
|
||||
|
||||
cd $PKG
|
||||
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
|
|
@ -0,0 +1,24 @@
|
|||
PRGNAM="MaterialX"
|
||||
VERSION="1.38.8"
|
||||
HOMEPAGE="https://materialx.org/"
|
||||
DOWNLOAD="https://github.com/AcademySoftwareFoundation/MaterialX/archive/v1.38.8.tar.gz \
|
||||
https://github.com/giandex/nanogui/archive/20240101.tar.gz \
|
||||
https://github.com/giandex/nanobind/archive/20240101.tar.gz \
|
||||
https://github.com/giandex/nanovg/archive/20240101.tar.gz \
|
||||
https://github.com/giandex/glfw/archive/20240101.tar.gz \
|
||||
https://github.com/giandex/robin-map/archive/20240101.tar.gz \
|
||||
https://github.com/giandex/imgui/archive/20240101.tar.gz \
|
||||
https://github.com/giandex/imgui-node-editor/archive/20240101.tar.gz"
|
||||
MD5SUM="fad8f4e19305fb2ee920cbff638f3560 \
|
||||
405cc59e1bd28e7571b9587c9c9c21a5 \
|
||||
ec7d95e77a32fc06a1670fd938981b82 \
|
||||
84ef5e0623bcfc65c3cf767ba71ce5dd \
|
||||
e22ebcdf0e0105caab481ef602f45a03 \
|
||||
edbf5a3f54414b524b59fafda78a0e29 \
|
||||
597bc2b0664ba3fad4c6b8c7b4871c2b \
|
||||
3295c5ccd31706814bcca8e5f92c8744"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES="pybind11 zenity"
|
||||
MAINTAINER="Giancarlo Dessi"
|
||||
EMAIL="slack@giand.it"
|
|
@ -0,0 +1,21 @@
|
|||
[Desktop Entry]
|
||||
Type=Application
|
||||
Name=MaterialXGraphEditor
|
||||
GenericName=MaterialX Graph Editor
|
||||
GenericName[de]=MaterialX Grafikeditor
|
||||
GenericName[es]=Editor de Gráficos MaterialX
|
||||
GenericName[fr]=Éditeur de Graphique MaterialX
|
||||
GenericName[it]=Editor di Grafica MaterialX
|
||||
GenericName[pt]=Editor Gráfico MaterialX
|
||||
Comment=MaterialX graphics processing interface
|
||||
Comment[de]=MaterialX Grafikverarbeitungsschnittstelle
|
||||
Comment[es]=Interfaz de procesamiento de gráficos MaterialX
|
||||
Comment[fr]=Interface de traitement de graphique MaterialX
|
||||
Comment[it]=Interfaccia per l'elaborazione di grafica MaterialX
|
||||
Comment[pt]=Interface de processamento gráfico MaterialX
|
||||
Exec=MaterialXGraphEditor %f
|
||||
Icon=/usr/share/icons/hicolor/256x256/apps/materialx.png
|
||||
Terminal=false
|
||||
Categories=Graphics;
|
||||
StartupNotify=true
|
||||
MimeType=application/x-mtlx;model/materialx;application/x-materialx;application/xml;text/mtlx+xml;image/mtlx;
|
|
@ -0,0 +1,21 @@
|
|||
[Desktop Entry]
|
||||
Type=Application
|
||||
Name=MaterialXView
|
||||
GenericName=MaterialX Viewer
|
||||
GenericName[de]=MaterialX Viewer
|
||||
GenericName[es]=Visor de MaterialX
|
||||
GenericName[fr]=Visionneuse de MaterialX
|
||||
GenericName[it]=Visualizzatore di MaterialX
|
||||
GenericName[pt]=Visualizador de MaterialX
|
||||
Comment=Interface for viewing GLSL shaders for MaterialX
|
||||
Comment[de]=Schnittstelle zum Anzeigen von GLSL-Shadern für MaterialX
|
||||
Comment[es]=Interfaz para ver sombreadores GLSL para MaterialX
|
||||
Comment[fr]=Interface de visualisation des shaders GLSL pour MaterialX
|
||||
Comment[it]=Interfaccia per la visualizzazione di ombreggiatori GLSL per MaterialX
|
||||
Comment[pt]=Interface para visualização de shaders GLSL para MaterialX
|
||||
Exec=MaterialXView %f
|
||||
Icon=/usr/share/icons/hicolor/256x256/apps/materialx.png
|
||||
Terminal=false
|
||||
Categories=Graphics;
|
||||
StartupNotify=true
|
||||
MimeType=application/x-mtlx;model/materialx;application/x-materialx;application/xml;image/mtlx+xml;
|
|
@ -0,0 +1,51 @@
|
|||
MaterialX is an open standard for representing rich material and
|
||||
look-development content in computer graphics, enabling its
|
||||
platform-independent description and exchange across applications
|
||||
and renderers.
|
||||
Launched at Industrial Light & Magic in 2012, MaterialX has been a key
|
||||
technology in their feature films and real-time experiences. The
|
||||
project was released as open source in 2017 and MaterialX is a hosted
|
||||
project of the Academy Software Foundation since 2021. This standard
|
||||
is supported as optional extension by standards and platforms for
|
||||
computer graphics, like OpenShadingLanguage and Blender.
|
||||
|
||||
MaterialX includes also two graphical interfaces, MaterialX Viewer and
|
||||
MaterialX Graph Editor.
|
||||
|
||||
MaterialX Viewer creates the GLSL shaders from MaterialX graphs and
|
||||
renders the results using the NanoGUI framework. This framework is not
|
||||
available in SBo but is built as third part component of MaterialX.
|
||||
The build of internal NanoGUI requires also the buildof robin-map as
|
||||
external component. Although this dependency is available in SBo you
|
||||
cannot use the one installed in your system. The built does not affect
|
||||
other installations of robin-map.
|
||||
|
||||
MaterialX Graph Editor can be used to visualize, create, and edit
|
||||
MaterialX graphs. It uses the ImGui framework also built as third
|
||||
part component with the headers of an internal GLFW. Although these
|
||||
dependencies are available in SBo, the build does not allow the use of
|
||||
imgui and glfw3 installed in the system, but the internal components
|
||||
built with MaterialX do not conflict with other installations.
|
||||
|
||||
By default this slackbuild installs both the graphical interfaces and
|
||||
the Python bindings. If not required, you can disable their built by
|
||||
setting the following variables:
|
||||
|
||||
VIEWER=no disables the build of MaterialX Viewer. The dependency zenity
|
||||
is not required. You have no even the download of these extrasources:
|
||||
nanogui, nanobind, nanovg, glfw, and robin-map.
|
||||
|
||||
EDITOR=no disables the build of MaterialX Graph Editor. The download of
|
||||
following extrasources is not required: imgui and imgui-node-editor.
|
||||
|
||||
PYTHON=no disables the build of Python bindings. The dependency
|
||||
python3-pybind11 is not required.
|
||||
|
||||
For example, if you want disable both the graphical interfaces you have
|
||||
to launch the script with the following command:
|
||||
VIEWER=no EDITOR=no ./MaterialXViewer.SlackBuild
|
||||
|
||||
openimageio is an optional dependency autodetected and its support
|
||||
will be enable by default if found in the system. If you do not
|
||||
require this extension you can disable it by passing
|
||||
OIIO=no ./MaterialX.SlackBuild
|
|
@ -0,0 +1,19 @@
|
|||
if [ -x /usr/bin/update-desktop-database ]; then
|
||||
/usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
|
||||
fi
|
||||
|
||||
if [ -x /usr/bin/update-mime-database ]; then
|
||||
/usr/bin/update-mime-database usr/share/mime >/dev/null 2>&1
|
||||
fi
|
||||
|
||||
if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
|
||||
if [ -x /usr/bin/gtk-update-icon-cache ]; then
|
||||
/usr/bin/gtk-update-icon-cache -f usr/share/icons/hicolor >/dev/null 2>&1
|
||||
fi
|
||||
fi
|
||||
|
||||
if [ -e usr/share/glib-2.0/schemas ]; then
|
||||
if [ -x /usr/bin/glib-compile-schemas ]; then
|
||||
/usr/bin/glib-compile-schemas usr/share/glib-2.0/schemas >/dev/null 2>&1
|
||||
fi
|
||||
fi
|
|
@ -0,0 +1,16 @@
|
|||
--- ./python/setup.py.in 2023-09-08 21:34:30.000000000 +0200
|
||||
+++ ./python/setup.py.in 2023-12-29 20:55:34.110939801 +0100
|
||||
@@ -1,4 +1,4 @@
|
||||
-from setuptools import setup
|
||||
+from setuptools import setup, find_packages
|
||||
import os
|
||||
|
||||
os.chdir(os.path.dirname(os.path.abspath(__file__)))
|
||||
@@ -13,6 +13,6 @@
|
||||
setup(name='MaterialX',
|
||||
url='www.materialx.org',
|
||||
version='${MATERIALX_MAJOR_VERSION}.${MATERIALX_MINOR_VERSION}.${MATERIALX_BUILD_VERSION}',
|
||||
- packages=['MaterialX'],
|
||||
+ packages=find_packages(['MaterialX']),
|
||||
package_data={'MaterialX' : getRecursivePackageData('MaterialX')},
|
||||
zip_safe = False)
|
Binary file not shown.
After Width: | Height: | Size: 36 KiB |
|
@ -0,0 +1,19 @@
|
|||
# HOW TO EDIT THIS FILE:
|
||||
# The "handy ruler" below makes it easier to edit a package description.
|
||||
# Line up the first '|' above the ':' following the base package name, and
|
||||
# the '|' on the right side marks the last column you can put a character in.
|
||||
# You must make exactly 11 lines for the formatting to be correct. It's also
|
||||
# customary to leave one space after the ':' except on otherwise blank lines.
|
||||
|
||||
|-----handy-ruler------------------------------------------------------|
|
||||
MaterialX: MaterialX (open standard for computer graphics)
|
||||
MaterialX:
|
||||
MaterialX: MaterialX is an open standard for representing rich material and
|
||||
MaterialX: look-development content in computer graphics, enabling its
|
||||
MaterialX: platform-independent description and exchange across applications
|
||||
MaterialX: and renderers.
|
||||
MaterialX:
|
||||
MaterialX: Home page: https://materialx.org/
|
||||
MaterialX:
|
||||
MaterialX:
|
||||
MaterialX:
|
Loading…
Reference in New Issue