desktop/hsetroot: Work around imlib2 breakage.

Signed-off-by: B. Watson <urchlay@slackware.uk>

Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
B. Watson 2023-01-26 12:51:02 -05:00 committed by Willy Sudiarto Raharjo
parent 3cb6b4db26
commit 37168998cb
No known key found for this signature in database
GPG Key ID: 3F617144D7238786
2 changed files with 32 additions and 7 deletions

View File

@ -22,11 +22,15 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
# 20230126 bkw: Modified by SlackBuilds.org, BUILD=2:
# - fix build with imlib2-1.10.0.
# - get rid of useless INSTALL from doc dir.
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=hsetroot
VERSION=${VERSION:-1.0.2}
BUILD=${BUILD:-1}
BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@ -38,9 +42,6 @@ if [ -z "$ARCH" ]; then
esac
fi
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
# the name of the created package would be, and then exit. This information
# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@ -75,9 +76,13 @@ cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
-o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
# 20230126 bkw: fix build for later imlib2, which lacks imlib2-config.
patch -p1 < $CWD/imlib2_pkgconfig.diff
autoreconf -if
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
@ -94,7 +99,7 @@ make
make install-strip DESTDIR=$PKG
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a AUTHORS COPYING ChangeLog INSTALL NEWS README $PKG/usr/doc/$PRGNAM-$VERSION
cp -a AUTHORS COPYING ChangeLog NEWS README $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install

View File

@ -0,0 +1,20 @@
diff -Naur hsetroot-1.0.2/configure.ac hsetroot-1.0.2.patched/configure.ac
--- hsetroot-1.0.2/configure.ac 2003-09-05 17:41:38.000000000 -0400
+++ hsetroot-1.0.2.patched/configure.ac 2023-01-26 12:45:06.365351344 -0500
@@ -39,15 +39,8 @@
AC_C_CONST
# Check for imlib2
-AC_CHECK_PROGS(imlib2config_cmd, imlib2-config)
-if test x$imlib2config_cmd = "x"; then
- AC_MSG_ERROR([error. Imlib2 is required to compile.])
-fi
-
-IMLIB2_CFLAGS=`$imlib2config_cmd --cflags`
+PKG_CHECK_MODULES([IMLIB2], [imlib2])
AC_SUBST(IMLIB2_CFLAGS)
-
-IMLIB2_LIBS=`$imlib2config_cmd --libs`
AC_SUBST(IMLIB2_LIBS)
# Some extra definitions for config.h