network/offlineimap: Added to 13.0 repository
This commit is contained in:
parent
9ddb94b963
commit
34ff4e11c6
|
@ -0,0 +1,2 @@
|
||||||
|
OfflineIMAP is a tool to sync remote imap mailboxes and
|
||||||
|
specifically useful in syncing imap servers.
|
|
@ -0,0 +1,11 @@
|
||||||
|
--- Makefile.orig 2009-05-06 21:10:37.578993290 -0500
|
||||||
|
+++ Makefile 2009-05-06 21:11:37.266485486 -0500
|
||||||
|
@@ -38,7 +38,7 @@
|
||||||
|
docbook2man offlineimap.sgml
|
||||||
|
docbook2html -u offlineimap.sgml
|
||||||
|
mv offlineimap.html manual.html
|
||||||
|
- man -t -l offlineimap.1 > manual.ps
|
||||||
|
+ man -t ./offlineimap.1 > manual.ps
|
||||||
|
ps2pdf manual.ps
|
||||||
|
groff -Tascii -man offlineimap.1 | sed $$'s/.\b//g' > manual.txt
|
||||||
|
-rm manpage.links manpage.refs manual.ps
|
|
@ -0,0 +1,14 @@
|
||||||
|
config() {
|
||||||
|
NEW="$1"
|
||||||
|
OLD="$(dirname $NEW)/$(basename $NEW .new)"
|
||||||
|
# If there's no config file by that name, mv it over:
|
||||||
|
if [ ! -r $OLD ]; then
|
||||||
|
mv $NEW $OLD
|
||||||
|
elif [ "$(cat $OLD | md5sum)" = "$(cat $NEW | md5sum)" ]; then
|
||||||
|
# toss the redundant copy
|
||||||
|
rm $NEW
|
||||||
|
fi
|
||||||
|
# Otherwise, we leave the .new copy for the admin to consider...
|
||||||
|
}
|
||||||
|
config etc/offlineimap.conf.new
|
||||||
|
|
|
@ -0,0 +1,80 @@
|
||||||
|
#!/bin/sh
|
||||||
|
|
||||||
|
# Slackware build script for OfflineIMAP
|
||||||
|
# Home Page http://software.complete.org/software/projects/show/offlineimap
|
||||||
|
|
||||||
|
# Copyright (c) 2008-2009, Nishant Limbachia, Hoffman Est, IL, USA (nishant@mnspace.net)
|
||||||
|
# All rights reserved.
|
||||||
|
#
|
||||||
|
# Redistribution and use of this script, with or without modification, is
|
||||||
|
# permitted provided that the following conditions are met:
|
||||||
|
#
|
||||||
|
# 1. Redistributions of script must retain the above copyright notice,
|
||||||
|
# this list of conditions and the following disclaimer.
|
||||||
|
#
|
||||||
|
# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
|
||||||
|
# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
|
||||||
|
# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
|
||||||
|
# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
|
||||||
|
# CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
|
||||||
|
# EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
|
||||||
|
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
|
||||||
|
# PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF
|
||||||
|
# LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
|
||||||
|
# NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
|
||||||
|
# SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||||
|
|
||||||
|
PRGNAM=offlineimap
|
||||||
|
VERSION=6.2.0
|
||||||
|
ARCH=${ARCH:-i486}
|
||||||
|
BUILD=${BUILD:-1}
|
||||||
|
TAG=${TAG=_SBo}
|
||||||
|
|
||||||
|
SRCNAM="${PRGNAM}_${VERSION}.orig"
|
||||||
|
|
||||||
|
CWD=$(pwd)
|
||||||
|
TMP=${TMP:-/tmp/SBo}
|
||||||
|
PKG=$TMP/package-$PRGNAM
|
||||||
|
OUTPUT=${OUTPUT:-/tmp}
|
||||||
|
|
||||||
|
set -e # Exit on most errors
|
||||||
|
|
||||||
|
rm -fr $TMP/$PRGNAM $PKG
|
||||||
|
mkdir -p $TMP $PKG $OUTPUT
|
||||||
|
cd $TMP
|
||||||
|
tar xvf $CWD/$SRCNAM.tar.gz
|
||||||
|
cd $PRGNAM
|
||||||
|
chown -R root.root .
|
||||||
|
find . \
|
||||||
|
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
|
||||||
|
-exec chmod 755 {} \; -o \
|
||||||
|
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
||||||
|
-exec chmod 644 {} \;
|
||||||
|
|
||||||
|
### build and install
|
||||||
|
python setup.py install --root=$PKG
|
||||||
|
|
||||||
|
### patch makefile to fix document generation
|
||||||
|
patch -p0 < $CWD/doc_generation_fix.patch
|
||||||
|
|
||||||
|
### make and install docs
|
||||||
|
make doc
|
||||||
|
mkdir -p $PKG/usr/{man/man1,doc/$PRGNAM-$VERSION} $PKG/etc
|
||||||
|
|
||||||
|
### install config file
|
||||||
|
install -m 0644 -D $PRGNAM.conf $PKG/etc/$PRGNAM.conf.new
|
||||||
|
|
||||||
|
install -m 0644 $PRGNAM.1 $PKG/usr/man/man1
|
||||||
|
gzip -9 $PKG/usr/man/man1/$PRGNAM.1
|
||||||
|
|
||||||
|
cp -a \
|
||||||
|
COPYING COPYRIGHT UPGRADING FAQ.html manual.* $PRGNAM.conf* \
|
||||||
|
$PKG/usr/doc/$PRGNAM-$VERSION
|
||||||
|
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||||
|
|
||||||
|
mkdir -p $PKG/install
|
||||||
|
cat $CWD/slack-desc > $PKG/install/slack-desc
|
||||||
|
cat $CWD/doinst.sh > $PKG/install/doinst.sh
|
||||||
|
|
||||||
|
cd $PKG
|
||||||
|
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
|
|
@ -0,0 +1,10 @@
|
||||||
|
PRGNAM="offlineimap"
|
||||||
|
VERSION="6.2.0"
|
||||||
|
HOMEPAGE="http://software.complete.org/software/projects/show/offlineimap"
|
||||||
|
DOWNLOAD="http://software.complete.org/software/attachments/download/413/offlineimap_6.2.0.orig.tar.gz"
|
||||||
|
MD5SUM="a23dab23ac08de063e330fe26d08e9b9"
|
||||||
|
DOWNLOAD_x86_64=""
|
||||||
|
MD5SUM_x86_64=""
|
||||||
|
MAINTAINER="Nishant Limbachia"
|
||||||
|
EMAIL="nishant@mnspace.net"
|
||||||
|
APPROVED="rworkman"
|
|
@ -0,0 +1,18 @@
|
||||||
|
# HOW TO EDIT THIS FILE:
|
||||||
|
# The "handy ruler" below makes it easier to edit a package description. Line
|
||||||
|
# up the first '|' above the ':' following the base package name, and the '|'
|
||||||
|
# on the right side marks the last column you can put a character in. You must
|
||||||
|
# make exactly 11 lines for the formatting to be correct. It's also
|
||||||
|
# customary to leave one space after the ':'.
|
||||||
|
|-----handy-ruler-----------------------------------------------|
|
||||||
|
offlineimap: offlineimap (IMAP sync tool)
|
||||||
|
offlineimap:
|
||||||
|
offlineimap: OfflineIMAP allows you to sync imap mailboxes between remote
|
||||||
|
offlineimap: and local machines. It is most useful in syncing user
|
||||||
|
offlineimap: mailboxes between imap servers.
|
||||||
|
offlineimap:
|
||||||
|
offlineimap: http://software.complete.org/software/projects/show/offlineimap
|
||||||
|
offlineimap:
|
||||||
|
offlineimap:
|
||||||
|
offlineimap:
|
||||||
|
offlineimap:
|
Loading…
Reference in New Issue