audio/Pd-extended: Updated for version 0.43.4.
Lot of stuff changed Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
This commit is contained in:
parent
ea7d73bcdd
commit
349d7ace77
|
@ -1,12 +0,0 @@
|
|||
diff -Naur Pd-0.42.5-extended-orig/packages/Makefile Pd-0.42.5-extended/packages/Makefile
|
||||
--- Pd-0.42.5-extended-orig/packages/Makefile 2010-09-10 01:03:57.000000000 +0100
|
||||
+++ Pd-0.42.5-extended/packages/Makefile 2010-11-03 19:06:37.095286845 +0000
|
||||
@@ -404,7 +404,7 @@
|
||||
echo '<p>Please consider trying to get rid of software patents in your country: <a href="http://www.nosoftwarepatents.com" target="nsp">http://www.nosoftwarepatents.com</a></p>' >> $(README_FILE)
|
||||
echo "<h3>Pure Data CVS Developers</h3>" >> $(README_FILE)
|
||||
# this may seem whack, but it generates the list of developers from the SourceForge site:
|
||||
- curl 'http://sourceforge.net/project/memberlist.php?group_id=55736' | grep -A2 -e '<td>' | sed 's|\(href="\)|target="w" \1http://sourceforge.net|' >> $(README_FILE)
|
||||
+ cat $(DEVELOPERSLIST) >> $(README_FILE)
|
||||
echo "</p>" >> $(README_FILE)
|
||||
echo "<p>" >> $(README_FILE)
|
||||
echo "Many others not listed have contributed their time and effort, this is just a list of the current developers in the SourceForge project. But really, every Pd user is a developer and is encouraged to contribute to the CVS repository." >> $(README_FILE)
|
|
@ -6,12 +6,11 @@
|
|||
# Modified by the SlackBuilds.org project.
|
||||
|
||||
PRGNAM=Pd-extended
|
||||
VERSION=0.42.5
|
||||
BUILD=${BUILD:-3}
|
||||
VERSION=0.43.4
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
SRCNAM=Pd
|
||||
SRCVER=$VERSION-extended
|
||||
SRCNAM=pd-extended
|
||||
|
||||
if [ -z "$ARCH" ]; then
|
||||
case "$( uname -m )" in
|
||||
|
@ -47,37 +46,36 @@ set -e
|
|||
rm -rf $PKG
|
||||
mkdir -p $TMP $PKG $OUTPUT
|
||||
cd $TMP
|
||||
rm -rf $SRCNAM-$SRCVER
|
||||
tar xvf $CWD/$SRCNAM-$SRCVER.tar.gz
|
||||
cd $SRCNAM-$SRCVER
|
||||
rm -rf $SRCNAM
|
||||
tar xvf $CWD/${PRGNAM}_${VERSION}-source.tar.?z*
|
||||
cd $SRCNAM
|
||||
chown -R root:root .
|
||||
find . \
|
||||
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
|
||||
-exec chmod 755 {} \; -o \
|
||||
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
||||
-exec chmod 644 {} \;
|
||||
|
||||
# Disable the usage of curl to get the list of developpers.
|
||||
patch -p1 < $CWD/Makefile.diff
|
||||
|
||||
# Patch for newer libquicktime (w/o lqt-config)
|
||||
patch -p1 < $CWD/Pd-extended_libquicktime122.patch
|
||||
find -L . \
|
||||
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
|
||||
-o -perm 511 \) -exec chmod 755 {} \; -o \
|
||||
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
|
||||
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
|
||||
|
||||
# videodev.h has moved
|
||||
sed -i "s|linux/videodev\.h|libv4l1-videodev.h|" \
|
||||
Gem/src/configure \
|
||||
Gem/src/configure.ac \
|
||||
Gem/src/Pixes/videoV4L.h \
|
||||
externals/pidip/include/pdp_mp4config.h \
|
||||
externals/pidip/include/pdp_mp4videosource.h \
|
||||
externals/pidip/modules/pdp_v4l2.c \
|
||||
externals/pidip/modules/pdp_vloopback.c \
|
||||
externals/pdp/configure.ac \
|
||||
externals/pdp/modules/image_io/pdp_v4l.c
|
||||
externals/pdp/modules/image_io/pdp_v4l.c || exit 1
|
||||
|
||||
# Fix a wrong call
|
||||
sed -i "s|---export-dynamic|-export-dynamic|" externals/pdp/Makefile
|
||||
sed -i "s|--export-dynamic|-export-dynamic|" externals/pdp/opengl/Makefile
|
||||
sed -i "s|---export-dynamic|-export-dynamic|" externals/pdp/Makefile || exit 1
|
||||
sed -i "s|--export-dynamic|-export-dynamic|" externals/pdp/opengl/Makefile || exit 1
|
||||
|
||||
# Fix lua calling
|
||||
sed -i \
|
||||
-e "s|include/lua5\.1|include|" \
|
||||
-e "s|llua5\.1|llua|" \
|
||||
externals/loaders/pdlua/src/Makefile || exit 1
|
||||
|
||||
# Fix tcl calling
|
||||
sed -i \
|
||||
-e "s|include/tcl8\.5|include|" \
|
||||
-e "s|ltcl8\.5|ltcl|" \
|
||||
externals/loaders/tclpd/Makefile || exit 1
|
||||
|
||||
cd packages/linux_make
|
||||
make -j1 install \
|
||||
|
@ -88,9 +86,15 @@ cd packages/linux_make
|
|||
DESTDIR=$PKG
|
||||
cd ../..
|
||||
|
||||
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
|
||||
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
|
||||
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
|
||||
|
||||
find $PKG/usr/man -type f -exec gzip -9 {} \;
|
||||
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
|
||||
|
||||
[ "$LIBDIRSUFFIX" = "64" ] && mv $PKG/usr/lib/pkgconfig/Gem.pc \
|
||||
$PKG/usr/lib64/pkgconfig/Gem.pc ; rmdir $PKG/usr/lib/pkgconfig ; rmdir $PKG/usr/lib
|
||||
|
||||
if [ "$ARCH" = "x86_64" ]; then
|
||||
echo '#!/bin/sh' > $PKG/usr/bin/pdextended64
|
||||
echo 'cd /usr/lib64/pd-extended/bin' >> $PKG/usr/bin/pdextended64
|
||||
|
@ -98,11 +102,13 @@ if [ "$ARCH" = "x86_64" ]; then
|
|||
chmod 755 $PKG/usr/bin/pdextended64
|
||||
fi
|
||||
|
||||
# Seems Pd can't make their mind up how they want to be called,
|
||||
# Seems Pd developers can't make their mind up how they want to be called,
|
||||
# (Pd/pd or Pd/pd-extended), so we're hardcoding the files here.
|
||||
mkdir -p $PKG/usr/share/{applications,pixmaps,mime/packages}
|
||||
cat packages/linux_make/pd-extended.desktop > $PKG/usr/share/applications/pd-extended.desktop
|
||||
cat packages/linux_make/pd.png > $PKG/usr/share/pixmaps/pd.png
|
||||
mkdir -p $PKG/usr/share/applications $PKG/usr/share/pixmaps $PKG/usr/share/mime/packages
|
||||
sed "s|^Exec.*|Exec=/usr/lib$LIBDIRSUFFIX/pd-extended/tcl/pd-gui.tcl %F|" \
|
||||
packages/linux_make/pd-extended.desktop > $PKG/usr/share/applications/pd-extended.desktop
|
||||
cat packages/linux_make/pd-extended.png > $PKG/usr/share/pixmaps/pd-extended.png
|
||||
cat packages/linux_make/pd-extended.xpm > $PKG/usr/share/pixmaps/pd-extended.xpm
|
||||
cat packages/linux_make/pd-extended.xml > $PKG/usr/share/mime/packages/pd-extended.xml
|
||||
|
||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
|
@ -110,6 +116,7 @@ cp -a doc/* packages/gpl-3.0.txt $PKG/usr/doc/$PRGNAM-$VERSION
|
|||
sed "s,/usr/lib/,/usr/lib${LIBDIRSUFFIX}/,g" $CWD/example.pdextended \
|
||||
> $PKG/usr/doc/$PRGNAM-$VERSION/example.pdextended
|
||||
cat $CWD/Pd-extended.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM-extended.SlackBuild
|
||||
|
||||
mkdir -p $PKG/install
|
||||
cat $CWD/slack-desc > $PKG/install/slack-desc
|
||||
cat $CWD/doinst.sh > $PKG/install/doinst.sh
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
PRGNAM="Pd-extended"
|
||||
VERSION="0.42.5"
|
||||
VERSION="0.43.4"
|
||||
HOMEPAGE="http://puredata.info"
|
||||
DOWNLOAD="http://downloads.sourceforge.net/pure-data/Pd-0.42.5-extended.tar.gz"
|
||||
MD5SUM="54c20a51d4d07396f6a806ab46b31b18"
|
||||
DOWNLOAD="http://downloads.sourceforge.net/pure-data/Pd-extended_0.43.4-source.tar.bz2"
|
||||
MD5SUM="c19606f1eee2ee83802317ee1eaeaec3"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES="dssi gsl imlib2 lame libquicktime pd speex"
|
||||
|
|
|
@ -1,13 +0,0 @@
|
|||
--- Pd-0.42.5-extended/externals/pidip/configure.ac 2010-08-14 21:02:57.000000000 -0300
|
||||
+++ Pd-0.42.5-extended_patched/externals/pidip/configure.ac 2011-04-04 01:59:43.000000000 -0300
|
||||
@@ -148,8 +148,8 @@
|
||||
AC_CHECK_LIB(theora, theora_encode_init, , AC_MSG_ERROR(theora library needed! sorry...), -lm)
|
||||
AC_CHECK_LIB(quicktime, lqt_decode_video, , AC_MSG_ERROR(libquicktime not found) )
|
||||
|
||||
-qt_minor_version="`lqt-config --version | cut -f3 -d'.'`"
|
||||
-qt_major_version="`lqt-config --version | cut -f1 -d'.'`"
|
||||
+qt_minor_version="`pkg-config --modversion libquicktime | cut -f3 -d'.'`"
|
||||
+qt_major_version="`pkg-config --modversion libquicktime | cut -f1 -d'.'`"
|
||||
echo "qt version minor : ${qt_minor_version} major : ${qt_major_version}"
|
||||
if test ${qt_minor_version} == "8";
|
||||
then
|
Loading…
Reference in New Issue