network/youtube-dl: Updated for version 2015.12.06.
Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com>
This commit is contained in:
parent
aa2128929f
commit
2dee6acb77
|
@ -1,6 +1,6 @@
|
|||
--- youtube-dl-2015.05.20/Makefile.orig 2015-05-25 04:09:16.056234902 +0300
|
||||
+++ youtube-dl-2015.05.20/Makefile 2015-05-25 04:13:42.180907886 +0300
|
||||
@@ -4,22 +4,22 @@
|
||||
--- youtube-dl-2015.12.06/Makefile 2015-12-06 19:51:25.000000000 +0200
|
||||
+++ youtube-dl-2015.12.06/Makefile.orig 2015-12-08 03:44:10.554844147 +0200
|
||||
@@ -4,11 +4,11 @@
|
||||
rm -rf youtube-dl.1.temp.md youtube-dl.1 youtube-dl.bash-completion README.txt MANIFEST build/ dist/ .coverage cover/ youtube-dl.tar.gz youtube-dl.zsh youtube-dl.fish *.dump *.part *.info.json *.mp4 *.flv *.mp3 *.avi CONTRIBUTING.md.tmp youtube-dl youtube-dl.exe
|
||||
find . -name "*.pyc" -delete
|
||||
|
||||
|
@ -13,27 +13,7 @@
|
|||
+PYTHON ?= /usr/bin/python
|
||||
|
||||
# set SYSCONFDIR to /etc if PREFIX=/usr or PREFIX=/usr/local
|
||||
-ifeq ($(PREFIX),/usr)
|
||||
- SYSCONFDIR=/etc
|
||||
-else
|
||||
- ifeq ($(PREFIX),/usr/local)
|
||||
- SYSCONFDIR=/etc
|
||||
- else
|
||||
- SYSCONFDIR=$(PREFIX)/etc
|
||||
- endif
|
||||
-endif
|
||||
+#ifeq ($(PREFIX),/usr)
|
||||
+#SYSCONFDIR=/etc
|
||||
+#else
|
||||
+# ifeq ($(PREFIX),/usr/local)
|
||||
+# SYSCONFDIR=/etc
|
||||
+# else
|
||||
+# SYSCONFDIR=$(PREFIX)/etc
|
||||
+# endif
|
||||
+#endif
|
||||
|
||||
install: youtube-dl youtube-dl.1 youtube-dl.bash-completion youtube-dl.zsh youtube-dl.fish
|
||||
install -d $(DESTDIR)$(BINDIR)
|
||||
ifeq ($(PREFIX),/usr)
|
||||
@@ -50,7 +50,7 @@
|
||||
|
||||
.PHONY: all clean install test tar bash-completion pypi-files zsh-completion fish-completion ot offlinetest codetest supportedsites
|
||||
|
@ -44,39 +24,21 @@
|
|||
youtube-dl: youtube_dl/*.py youtube_dl/*/*.py
|
||||
zip --quiet youtube-dl youtube_dl/*.py youtube_dl/*/*.py
|
||||
@@ -70,11 +70,11 @@
|
||||
python devscripts/make_supportedsites.py docs/supportedsites.md
|
||||
$(PYTHON) devscripts/make_supportedsites.py docs/supportedsites.md
|
||||
|
||||
README.txt: README.md
|
||||
- pandoc -f markdown -t plain README.md -o README.txt
|
||||
+ #pandoc -f markdown -t plain README.md -o README.txt
|
||||
+ # pandoc -f markdown -t plain README.md -o README.txt
|
||||
|
||||
youtube-dl.1: README.md
|
||||
python devscripts/prepare_manpage.py >youtube-dl.1.temp.md
|
||||
$(PYTHON) devscripts/prepare_manpage.py >youtube-dl.1.temp.md
|
||||
- pandoc -s -f markdown -t man youtube-dl.1.temp.md -o youtube-dl.1
|
||||
+ #pandoc -s -f markdown -t man youtube-dl.1.temp.md -o youtube-dl.1
|
||||
+ # pandoc -s -f markdown -t man youtube-dl.1.temp.md -o youtube-dl.1
|
||||
rm -f youtube-dl.1.temp.md
|
||||
|
||||
youtube-dl.bash-completion: youtube_dl/*.py youtube_dl/*/*.py devscripts/bash-completion.in
|
||||
@@ -92,7 +92,7 @@
|
||||
|
||||
fish-completion: youtube-dl.fish
|
||||
|
||||
-youtube-dl.tar.gz: youtube-dl README.md README.txt youtube-dl.1 youtube-dl.bash-completion youtube-dl.zsh youtube-dl.fish
|
||||
+youtube-dl.tar.gz: youtube-dl README.md youtube-dl.1 youtube-dl.bash-completion youtube-dl.zsh youtube-dl.fish
|
||||
@tar -czf youtube-dl.tar.gz --transform "s|^|youtube-dl/|" --owner 0 --group 0 \
|
||||
--exclude '*.DS_Store' \
|
||||
--exclude '*.kate-swp' \
|
||||
@@ -105,7 +105,7 @@
|
||||
--exclude 'docs/_build' \
|
||||
-- \
|
||||
bin devscripts test youtube_dl docs \
|
||||
- LICENSE README.md README.txt \
|
||||
+ LICENSE README.md \
|
||||
Makefile MANIFEST.in youtube-dl.1 youtube-dl.bash-completion \
|
||||
youtube-dl.zsh youtube-dl.fish setup.py \
|
||||
youtube-dl
|
||||
--- youtube-dl-2015.05.20/setup.orig.py 2015-05-25 04:08:00.477179771 +0300
|
||||
+++ youtube-dl-2015.05.20/setup.py 2015-05-25 04:18:55.835986658 +0300
|
||||
--- youtube-dl-2015.12.06/setup.py 2015-12-06 19:51:25.000000000 +0200
|
||||
+++ youtube-dl-2015.12.06/setup.py.orig 2015-12-08 03:47:01.705704467 +0200
|
||||
@@ -46,10 +46,8 @@
|
||||
params = py2exe_params
|
||||
else:
|
||||
|
|
|
@ -636,7 +636,7 @@ Prefer free video formats unless a specific one is requested
|
|||
.RE
|
||||
.TP
|
||||
.B \-F, \-\-list\-formats
|
||||
List all available formats of specified videos
|
||||
List all available formats of requested videos
|
||||
.RS
|
||||
.RE
|
||||
.TP
|
||||
|
|
|
@ -24,7 +24,7 @@
|
|||
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
|
||||
PRGNAM=youtube-dl
|
||||
VERSION=${VERSION:-2015.11.27.1}
|
||||
VERSION=${VERSION:-2015.12.06}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
PRGNAM="youtube-dl"
|
||||
VERSION="2015.11.27.1"
|
||||
VERSION="2015.12.06"
|
||||
HOMEPAGE="https://rg3.github.io/youtube-dl"
|
||||
DOWNLOAD="https://github.com/rg3/youtube-dl/archive/2015.11.27.1.tar.gz"
|
||||
MD5SUM="1f4a153050bd923647fbce11b47fe876"
|
||||
DOWNLOAD="https://github.com/rg3/youtube-dl/archive/2015.12.06.tar.gz"
|
||||
MD5SUM="6c3bd16c8a0705d4b30165a71fd245e4"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES=""
|
||||
|
|
Loading…
Reference in New Issue