academic/bibus: Updated for version 1.5.2 + new maintainer.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
ae59dc0313
commit
2d65a7e61b
|
@ -1,123 +0,0 @@
|
||||||
diff -Nur bibus-1.5.1.orig/Makefile bibus-1.5.1/Makefile
|
|
||||||
--- bibus-1.5.1.orig/Makefile 2009-11-22 09:18:33.000000000 -0600
|
|
||||||
+++ bibus-1.5.1/Makefile 2010-01-01 01:25:31.731964448 -0600
|
|
||||||
@@ -12,64 +12,65 @@
|
|
||||||
sysconfdir = /etc
|
|
||||||
mandir = $(prefix)/share/man
|
|
||||||
man1dir = $(mandir)/man1
|
|
||||||
+docdir = $(prefix)/$(docdir)
|
|
||||||
|
|
||||||
define install-files
|
|
||||||
- install -d $(datadir)/bibus
|
|
||||||
- install -m644 *.py MySQL_Bibus.ini $(datadir)/bibus/
|
|
||||||
+ install -d $(PKGDIR)/$(datadir)/bibus
|
|
||||||
+ install -m644 *.py MySQL_Bibus.ini $(PKGDIR)/$(datadir)/bibus/
|
|
||||||
#
|
|
||||||
for dir in Export Format Import StyleEditor FirstStart bibOOo db_models Pixmaps Data LyX Utilities; do \
|
|
||||||
- find $$dir ! -wholename '*CVS*' -a -type f -exec install -m644 '{}' -D $(datadir)/bibus/'{}' ';' ; \
|
|
||||||
+ find $$dir ! -wholename '*CVS*' -a -type f -exec install -m644 '{}' -D $(PKGDIR)/$(datadir)/bibus/'{}' ';' ; \
|
|
||||||
done
|
|
||||||
- install -m644 Setup/UnoConnectionListener.odg -D $(datadir)/bibus/Setup/UnoConnectionListener.odg
|
|
||||||
+ install -m644 Setup/UnoConnectionListener.odg -D $(PKGDIR)/$(datadir)/bibus/Setup/UnoConnectionListener.odg
|
|
||||||
# locale files. We look for all the directory in locale/
|
|
||||||
for dir in $(wildcard locale/*); do \
|
|
||||||
if [ -d $$dir ] && [ $$dir != "locale/CVS" ]; then \
|
|
||||||
- install -m644 $$dir/LC_MESSAGES/bibus.mo -D $(datadir)/$$dir/LC_MESSAGES/bibus.mo ; \
|
|
||||||
+ install -m644 $$dir/LC_MESSAGES/bibus.mo -D $(PKGDIR)/$(datadir)/$$dir/LC_MESSAGES/bibus.mo ; \
|
|
||||||
fi; \
|
|
||||||
done
|
|
||||||
# bibus.config in /etc
|
|
||||||
- install -m644 bibus.config -D $(sysconfdir)/bibus.config
|
|
||||||
+ install -m644 bibus.config -D $(PKGDIR)/$(sysconfdir)/bibus.config
|
|
||||||
# man page
|
|
||||||
- install -m644 Setup/bibus.1 -D $(man1dir)/bibus.1
|
|
||||||
+ install -m644 Setup/bibus.1 -D $(PKGDIR)/$(man1dir)/bibus.1
|
|
||||||
|
|
||||||
# freedesktop icon and shortcut
|
|
||||||
- install -m644 Pixmaps/bibus.png -D $(datadir)/icons/hicolor/48x48/apps/bibus.png
|
|
||||||
- install -m644 Setup/bibus.desktop -D $(datadir)/applications/bibus.desktop
|
|
||||||
+ install -m644 Pixmaps/bibus.png -D $(PKGDIR)/$(datadir)/icons/hicolor/48x48/apps/bibus.png
|
|
||||||
+ install -m644 Setup/bibus.desktop -D $(PKGDIR)/$(datadir)/applications/bibus.desktop
|
|
||||||
# The following lines are presumably not needed since icons/desktop are in standard locations
|
|
||||||
#echo 'Exec=$(bindir)/bibus' >> $(datadir)/applications/bibus.desktop
|
|
||||||
#echo 'Icon=$(datadir)/icons/hicolor/48x48/apps/bibus.png' >> $(datadir)/applications/bibus.desktop
|
|
||||||
|
|
||||||
# bibus command
|
|
||||||
- install -d $(bindir)
|
|
||||||
- ln -sf $(datadir)/bibus/bibusStart.py $(bindir)/bibus
|
|
||||||
- chmod 755 $(datadir)/bibus/bibusStart.py
|
|
||||||
+ install -d $(PKGDIR)/$(bindir)
|
|
||||||
+ ln -sf $(datadir)/bibus/bibusStart.py $(PKGDIR)/$(bindir)/bibus
|
|
||||||
+ chmod 755 $(PKGDIR)/$(datadir)/bibus/bibusStart.py
|
|
||||||
|
|
||||||
# basic doc files
|
|
||||||
- install -m755 -d $(datadir)/doc/bibus
|
|
||||||
- install -m644 Docs/*.txt Docs/CHANGELOG Docs/copying $(datadir)/doc/bibus
|
|
||||||
+ install -m755 -d $(PKGDIR)/$(docdir)
|
|
||||||
+ install -m644 Docs/*.txt Docs/CHANGELOG Docs/copying $(PKGDIR)/$(docdir)
|
|
||||||
|
|
||||||
# generating bibus.cfg file
|
|
||||||
- echo '[PATH]' > $(datadir)/bibus/bibus.cfg
|
|
||||||
- echo 'python = $(python)' >> $(datadir)/bibus/bibus.cfg
|
|
||||||
- echo 'oopath = $(oopath)' >> $(datadir)/bibus/bibus.cfg
|
|
||||||
- echo 'ooure = $(ooure)' >> $(datadir)/bibus/bibus.cfg
|
|
||||||
- echo 'oobasis = $(oobasis)' >> $(datadir)/bibus/bibus.cfg
|
|
||||||
- echo 'docdir = $(datadir)/doc/bibus/html' >> $(datadir)/bibus/bibus.cfg
|
|
||||||
- echo 'licence = $(datadir)/doc/bibus/copying' >> $(datadir)/bibus/bibus.cfg
|
|
||||||
- echo 'localedir = $(datadir)/locale' >> $(datadir)/bibus/bibus.cfg
|
|
||||||
- echo 'systemconf = $(sysconfdir)/bibus.config' >> $(datadir)/bibus/bibus.cfg
|
|
||||||
+ echo '[PATH]' > $(PKGDIR)/$(datadir)/bibus/bibus.cfg
|
|
||||||
+ echo 'python = $(python)' >> $(PKGDIR)/$(datadir)/bibus/bibus.cfg
|
|
||||||
+ echo 'oopath = $(oopath)' >> $(PKGDIR)/$(datadir)/bibus/bibus.cfg
|
|
||||||
+ echo 'ooure = $(ooure)' >> $(PKGDIR)/$(datadir)/bibus/bibus.cfg
|
|
||||||
+ echo 'oobasis = $(oobasis)' >> $(PKGDIR)/$(datadir)/bibus/bibus.cfg
|
|
||||||
+ echo 'docdir = $(docdir)/html' >> $(PKGDIR)/$(datadir)/bibus/bibus.cfg
|
|
||||||
+ echo 'licence = $(docdir)/copying' >> $(PKGDIR)/$(datadir)/bibus/bibus.cfg
|
|
||||||
+ echo 'localedir = $(datadir)/locale' >> $(PKGDIR)/$(datadir)/bibus/bibus.cfg
|
|
||||||
+ echo 'systemconf = $(sysconfdir)/bibus.config' >> $(PKGDIR)/$(datadir)/bibus/bibus.cfg
|
|
||||||
endef
|
|
||||||
|
|
||||||
define install-doc-en
|
|
||||||
# copying docs in from Docs/html/en/ for bibus-doc-en
|
|
||||||
cd Docs;\
|
|
||||||
- find html/en/* -type f -exec install -m644 '{}' -D $(datadir)/doc/bibus/'{}' ';'
|
|
||||||
+ find html/en/* -type f -exec install -m644 '{}' -D $(PKGDIR)/$(docdir)/'{}' ';'
|
|
||||||
endef
|
|
||||||
|
|
||||||
define compile
|
|
||||||
# compile recursively all the python files located in $(datadir)/bibus
|
|
||||||
- $(python) -c "import compileall ; compileall.compile_dir('$(datadir)/bibus')"
|
|
||||||
- $(python) -O -c "import compileall ; compileall.compile_dir('$(datadir)/bibus')"
|
|
||||||
+ $(python) -c "import compileall ; compileall.compile_dir('$(PKGDIR)/$(datadir)/bibus')"
|
|
||||||
+ $(python) -O -c "import compileall ; compileall.compile_dir('$(PKGDIR)/$(datadir)/bibus')"
|
|
||||||
endef
|
|
||||||
|
|
||||||
install-files:
|
|
||||||
@@ -83,15 +84,15 @@
|
|
||||||
$(install-doc-en)
|
|
||||||
$(compile)
|
|
||||||
|
|
||||||
- # write uninstaller in $(datadir)/bibus/Setup/uninstall.sh
|
|
||||||
- echo "#!/bin/sh" > $(datadir)/bibus/Setup/uninstall.sh
|
|
||||||
- echo "rm -rf $(datadir)/bibus" >> $(datadir)/bibus/Setup/uninstall.sh
|
|
||||||
- echo "rm $(bindir)/bibus" >> $(datadir)/bibus/Setup/uninstall.sh
|
|
||||||
- echo "find $(datadir)/locale -name bibus.mo -exec rm -f {} \;" >> $(datadir)/bibus/Setup/uninstall.sh
|
|
||||||
- echo "rm $(sysconfdir)/bibus.config" >> $(datadir)/bibus/Setup/uninstall.sh
|
|
||||||
- echo "rm $(man1dir)/bibus.1" >> $(datadir)/bibus/Setup/uninstall.sh
|
|
||||||
- echo "rm -rf $(datadir)/doc/bibus" >> $(datadir)/bibus/Setup/uninstall.sh
|
|
||||||
- echo "rm $(datadir)/applications/bibus.desktop" >> $(datadir)/bibus/Setup/uninstall.sh
|
|
||||||
- echo "rm $(datadir)/icons/hicolor/48x48/apps/bibus.png" >> $(datadir)/bibus/Setup/uninstall.sh
|
|
||||||
- chmod 744 $(datadir)/bibus/Setup/uninstall.sh
|
|
||||||
- # end uninstaller
|
|
||||||
+# # write uninstaller in $(datadir)/bibus/Setup/uninstall.sh
|
|
||||||
+# echo "#!/bin/sh" > $(PKGDIR)/$(datadir)/bibus/Setup/uninstall.sh
|
|
||||||
+# echo "rm -rf $(datadir)/bibus" >> $(PKGDIR)/$(datadir)/bibus/Setup/uninstall.sh
|
|
||||||
+# echo "rm $(bindir)/bibus" >> $(PKGDIR)/$(datadir)/bibus/Setup/uninstall.sh
|
|
||||||
+# echo "find $(datadir)/locale -name bibus.mo -exec rm -f {} \;" >> $(PKGDIR)/$(datadir)/bibus/Setup/uninstall.sh
|
|
||||||
+# echo "rm $(sysconfdir)/bibus.config" >> $(datadir)/bibus/Setup/uninstall.sh
|
|
||||||
+# echo "rm $(man1dir)/bibus.1" >> $(PKGDIR)/$(datadir)/bibus/Setup/uninstall.sh
|
|
||||||
+# echo "rm -rf $(docdir)" >> $(PKGDIR)/$(datadir)/bibus/Setup/uninstall.sh
|
|
||||||
+# echo "rm $(datadir)/applications/bibus.desktop" >> $(PKGDIR)/$(datadir)/bibus/Setup/uninstall.sh
|
|
||||||
+# echo "rm $(datadir)/icons/hicolor/48x48/apps/bibus.png" >> $(PKGDIR)/$(datadir)/bibus/Setup/uninstall.sh
|
|
||||||
+# chmod 744 $(datadir)/bibus/Setup/uninstall.sh
|
|
||||||
+# # end uninstaller
|
|
|
@ -3,12 +3,31 @@
|
||||||
# Slackware build script for bibus
|
# Slackware build script for bibus
|
||||||
|
|
||||||
# Written by David Miller dave@frop.net
|
# Written by David Miller dave@frop.net
|
||||||
# This script is released into the public domain
|
|
||||||
|
|
||||||
# Modified by the SlackBuilds.org project
|
# Modified by the SlackBuilds.org project
|
||||||
|
|
||||||
|
# Rewritten by Ryan P.C. McQuen
|
||||||
|
# Copyright 2014 Ryan P.C. McQuen, WA, ryan.q@linux.com
|
||||||
|
# All rights reserved.
|
||||||
|
#
|
||||||
|
# Redistribution and use of this script, with or without modification, is
|
||||||
|
# permitted provided that the following conditions are met:
|
||||||
|
#
|
||||||
|
# 1. Redistributions of this script must retain the above copyright
|
||||||
|
# notice, this list of conditions and the following disclaimer.
|
||||||
|
#
|
||||||
|
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
|
||||||
|
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
|
||||||
|
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
|
||||||
|
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
||||||
|
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
|
||||||
|
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
|
||||||
|
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
|
||||||
|
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
|
||||||
|
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
||||||
|
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||||
|
|
||||||
PRGNAM=bibus
|
PRGNAM=bibus
|
||||||
VERSION=${VERSION:-1.5.1}
|
VERSION=${VERSION:-1.5.2}
|
||||||
ARCH=noarch
|
ARCH=noarch
|
||||||
BUILD=${BUILD:-1}
|
BUILD=${BUILD:-1}
|
||||||
TAG=${TAG:-_SBo}
|
TAG=${TAG:-_SBo}
|
||||||
|
@ -24,36 +43,35 @@ rm -rf $PKG
|
||||||
mkdir -p $TMP $PKG $OUTPUT
|
mkdir -p $TMP $PKG $OUTPUT
|
||||||
cd $TMP
|
cd $TMP
|
||||||
rm -rf $PRGNAM-$VERSION
|
rm -rf $PRGNAM-$VERSION
|
||||||
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
|
tar xvf $CWD/$PRGNAM\_$VERSION.orig.tar.gz
|
||||||
cd $PRGNAM-$VERSION
|
cd $PRGNAM-$VERSION
|
||||||
chown -R root:root .
|
chown -R root:root .
|
||||||
find -L . \
|
find -L . \
|
||||||
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
|
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
|
||||||
-exec chmod 755 {} \; -o \
|
-o -perm 511 \) -exec chmod 755 {} \; -o \
|
||||||
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
|
||||||
-exec chmod 644 {} \;
|
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
|
||||||
|
|
||||||
# Patch the Makefile to install to PKGDIR
|
|
||||||
patch -p1 < $CWD/Makefile.patch
|
|
||||||
|
|
||||||
make \
|
make \
|
||||||
PKGDIR=$PKG \
|
PKGDIR=$PKG \
|
||||||
DESTDIR=/usr \
|
DESTDIR=$PKG/usr \
|
||||||
mandir=/usr/man \
|
mandir=$PKG/usr/man \
|
||||||
sysconfdir=/etc \
|
sysconfdir=$PKG/etc \
|
||||||
docdir=/usr/doc/$PRGNAM-$VERSION \
|
docdir=$PKG/usr/doc/$PRGNAM-$VERSION \
|
||||||
oopath=/opt/openoffice.org3/program \
|
oopath=$PKG/opt/openoffice4/program \
|
||||||
ooure=/opt/openoffice.org3/basis-link/ure-link/lib \
|
ooure=$PKG/opt/openoffice4/basis-link/ure-link/lib \
|
||||||
oobasis=/opt/openoffice.org3/basis-link/program
|
oobasis=$PKG/opt/openoffice4/basis-link/program
|
||||||
|
|
||||||
# Don't clobber the config file
|
# Don't clobber the config file
|
||||||
mv $PKG/etc/bibus.config $PKG/etc/bibus.config.new
|
mv $PKG/etc/bibus.config $PKG/etc/bibus.config.new
|
||||||
|
(
|
||||||
( cd $PKG/usr/man
|
cd $PKG/usr/man/
|
||||||
find . -type f -exec gzip -9 {} \;
|
find . -type f -exec gzip -9 {} \;
|
||||||
for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
|
for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
|
||||||
)
|
)
|
||||||
|
|
||||||
|
rm -f $PKG/usr/share/bibus/*/*.{csv,py}~
|
||||||
|
|
||||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||||
cp -a -r Docs/* $PKG/usr/doc/$PRGNAM-$VERSION
|
cp -a -r Docs/* $PKG/usr/doc/$PRGNAM-$VERSION
|
||||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||||
|
|
|
@ -1,10 +1,10 @@
|
||||||
PRGNAM="bibus"
|
PRGNAM="bibus"
|
||||||
VERSION="1.5.1"
|
VERSION="1.5.2"
|
||||||
HOMEPAGE="http://bibus-biblio.sourceforge.net/"
|
HOMEPAGE="http://bibus-biblio.sourceforge.net/"
|
||||||
DOWNLOAD="http://downloads.sourceforge.net/bibus-biblio/bibus-1.5.1.tar.gz"
|
DOWNLOAD="http://sourceforge.net/projects/bibus-biblio/files/bibus-biblio/bibus-1.5.2/bibus_1.5.2.orig.tar.gz"
|
||||||
MD5SUM="9d1808f98556b58b3f709bebfba11a80"
|
MD5SUM="5bb8b26d0980ebb72a2882b618fbe62c"
|
||||||
DOWNLOAD_x86_64=""
|
DOWNLOAD_x86_64=""
|
||||||
MD5SUM_x86_64=""
|
MD5SUM_x86_64=""
|
||||||
REQUIRES="wxPython"
|
REQUIRES="wxPython"
|
||||||
MAINTAINER="David Miller"
|
MAINTAINER="Ryan P.C. McQuen"
|
||||||
EMAIL="dave@frop.net"
|
EMAIL="ryan.q@linux.com"
|
||||||
|
|
Loading…
Reference in New Issue