libraries/irrlicht: Updated for version 1.8.

Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
This commit is contained in:
Niels Horn 2013-04-07 21:41:46 -05:00 committed by Robby Workman
parent 854aa455d7
commit 2cb4bc2dbb
4 changed files with 8 additions and 39 deletions

View File

@ -1,12 +0,0 @@
--- irrlicht-svn_3843/source/Irrlicht/Makefile 2011-05-18 18:32:00.000000000 -0300
+++ irrlicht-svn_3843_patched/source/Irrlicht/Makefile 2011-10-24 21:25:05.000000000 -0200
@@ -142,7 +142,8 @@
mkdir -p $(INSTALL_DIR)/../include/irrlicht
cp ../../include/*.h $(INSTALL_DIR)/../include/irrlicht/
cp $(LIB_PATH)/$(SHARED_LIB).$(VERSION) $(INSTALL_DIR)
- cd $(INSTALL_DIR) && ln -s -f $(SHARED_LIB).$(VERSION) $(COMPATIBILITY_VERSION)
+ cp $(LIB_PATH)/$(STATIC_LIB) $(INSTALL_DIR)
+ cd $(INSTALL_DIR) && ln -s -f libIrrlicht.so.$(VERSION) $(SHARED_LIB)
# ldconfig -n $(INSTALL_DIR)

View File

@ -3,7 +3,7 @@
# Slackware build script for irrlicht
# Copyright 2010 Larry Hajali <larryhaja[at]gmail[dot]com>
# Copyright 2011-2012 Niels Horn, Rio de Janeiro, RJ, Brazil
# Copyright 2011-2013 Niels Horn, Rio de Janeiro, RJ, Brazil
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@ -23,11 +23,11 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
# Revision date 2012/08/09
# Revision date 2013/03/28
PRGNAM=irrlicht
VERSION=${VERSION:-svn_3843}
BUILD=${BUILD:-2}
VERSION=${VERSION:-1.8}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@ -63,7 +63,7 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
unzip $CWD/$PRGNAM-$VERSION.zip
cd $PRGNAM-$VERSION
chown -R root:root .
find . \
@ -72,14 +72,6 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
# Correct the install sequence to get a working link to the shared lib
# Based on a patch from Debian, adapted for the newer irrlicht versions
patch -p1 < $CWD/correct-install.diff
# Patch for gcc-4.7 - included upstream on 2012/06/18.
# Thanks to Larry Hajali for the info!
patch -p1 < $CWD/irrlicht_gcc47.patch
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
NDEBUG=1 \

View File

@ -1,8 +1,8 @@
PRGNAM="irrlicht"
VERSION="svn_3843"
VERSION="1.8"
HOMEPAGE="http://irrlicht.sourceforge.net/"
DOWNLOAD="http://www.nielshorn.net/_download/slackware/source/irrlicht-svn_3843.tar.bz2"
MD5SUM="ba7c12dad405bd86159c1842dc57a33e"
DOWNLOAD="http://downloads.sourceforge.net/irrlicht/irrlicht-1.8.zip"
MD5SUM="d06329d8f466658caaf4838ba349e393"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""

View File

@ -1,11 +0,0 @@
diff -Naur irrlicht-svn_3843.orig/source/Irrlicht/Makefile irrlicht-svn_3843/source/Irrlicht/Makefile
--- irrlicht-svn_3843.orig/source/Irrlicht/Makefile 2011-05-18 21:32:00.000000000 +0000
+++ irrlicht-svn_3843/source/Irrlicht/Makefile 2012-07-14 23:23:53.693933309 +0000
@@ -82,7 +82,6 @@
LIB_PATH = ../../lib/$(SYSTEM)
INSTALL_DIR = /usr/local/lib
sharedlib install: SHARED_LIB = libIrrlicht.so
-staticlib sharedlib: LDFLAGS += --no-export-all-symbols --add-stdcall-alias
sharedlib: LDFLAGS += -L/usr/X11R6/lib$(LIBSELECT) -lGL -lXxf86vm
staticlib sharedlib: CXXINCS += -I/usr/X11R6/include