libraries/fltk: Removed fltk-1.1.10.

Everything in the repo builds with fltk-1.3.3, the package name
clashes with extra/fltk, and fltk-1.1.10 fails to build if
fltk-1.3.3 is installed.  So we really don't need this any more.

Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
This commit is contained in:
David Spencer 2016-01-15 23:19:49 +00:00 committed by Robby Workman
parent 71bbf30064
commit 2ae32ffea5
7 changed files with 0 additions and 261 deletions

View File

@ -1,6 +0,0 @@
The Fast Light Tool Kit ("FLTK", pronounced "fulltick") is a a cross-platform
C++ GUI toolkit for UNIX(r)/Linux(r) (X11), Microsoft(r) Windows(r), and
MacOS(r) X. FLTK provides modern GUI functionality without the bloat and
supports 3D graphics via OpenGL(r) and its built-in GLUT emulation. It was
originally developed by Mr. Bill Spitzak and is currently maintained by a
small group of developers across the world with a central repository in the US.

View File

@ -1,21 +0,0 @@
diff -up fltk-1.1.10/configure.pkgconfig_xft fltk-1.1.10/configure
--- fltk-1.1.10/configure.pkgconfig_xft 2010-02-14 14:03:17.730616944 -0600
+++ fltk-1.1.10/configure 2010-02-14 14:05:05.369368026 -0600
@@ -12080,7 +12080,7 @@ if test "${ac_cv_lib_Xft_XftDrawCreate+s
echo $ECHO_N "(cached) $ECHO_C" >&6
else
ac_check_lib_save_LIBS=$LIBS
-LIBS="-lXft $LIBS"
+LIBS="`pkg-config --libs fontconfig xft` $LIBS"
cat >conftest.$ac_ext <<_ACEOF
/* confdefs.h. */
_ACEOF
@@ -12140,7 +12140,7 @@ if test $ac_cv_lib_Xft_XftDrawCreate = y
#define USE_XFT 1
_ACEOF
- LIBS="-lXft $LIBS"
+ LIBS="`pkg-config fontconfig xft --libs` $LIBS"
fi
fi

View File

@ -1,61 +0,0 @@
--- fltk1.1-1.1.10.orig/src/Fl_PNG_Image.cxx
+++ fltk1.1-1.1.10/src/Fl_PNG_Image.cxx
@@ -66,6 +66,8 @@ Fl_PNG_Image::Fl_PNG_Image(const char *p
png_structp pp; // PNG read pointer
png_infop info; // PNG info pointers
png_bytep *rows; // PNG row pointers
+ png_uint_32 width, height;
+ int bit_depth, color_type, num_trans = 0;
// Open the PNG file...
@@ -75,7 +77,7 @@ Fl_PNG_Image::Fl_PNG_Image(const char *p
pp = png_create_read_struct(PNG_LIBPNG_VER_STRING, NULL, NULL, NULL);
info = png_create_info_struct(pp);
- if (setjmp(pp->jmpbuf))
+ if (setjmp(png_jmpbuf(pp)))
{
Fl::warning("PNG file \"%s\" contains errors!\n", png);
return;
@@ -87,27 +89,33 @@ Fl_PNG_Image::Fl_PNG_Image(const char *p
// Get the image dimensions and convert to grayscale or RGB...
png_read_info(pp, info);
- if (info->color_type == PNG_COLOR_TYPE_PALETTE)
+ png_get_IHDR(pp, info, &width, &height, &bit_depth, &color_type,
+ NULL /* interlace */, NULL /* compress */, NULL /* filter */);
+#ifdef PNG_tRNS_SUPPORTED
+ png_get_tRNS(pp, info, NULL /* trans */, &num_trans, NULL /* values */);
+#endif
+
+ if (color_type == PNG_COLOR_TYPE_PALETTE)
png_set_expand(pp);
- if (info->color_type & PNG_COLOR_MASK_COLOR)
+ if (color_type & PNG_COLOR_MASK_COLOR)
channels = 3;
else
channels = 1;
- if ((info->color_type & PNG_COLOR_MASK_ALPHA) || info->num_trans)
+ if ((color_type & PNG_COLOR_MASK_ALPHA) || num_trans)
channels ++;
- w((int)(info->width));
- h((int)(info->height));
+ w((int)(width));
+ h((int)(height));
d(channels);
- if (info->bit_depth < 8)
+ if (bit_depth < 8)
{
png_set_packing(pp);
png_set_expand(pp);
}
- else if (info->bit_depth == 16)
+ else if (bit_depth == 16)
png_set_strip_16(pp);
# if defined(HAVE_PNG_GET_VALID) && defined(HAVE_PNG_SET_TRNS_TO_ALPHA)

View File

@ -1,11 +0,0 @@
--- fltk-1.1.x-r5750/src/Makefile.undefined 2007-02-10 08:31:12.000000000 -0600
+++ fltk-1.1.x-r5750/src/Makefile 2007-04-05 07:51:31.000000000 -0500
@@ -282,7 +282,7 @@
libfltk_gl.so.1.1: $(GLOBJECTS) libfltk.so.1.1
echo $(DSOCOMMAND) $@ ...
- $(DSOCOMMAND) $@ $(GLOBJECTS) -L. -lfltk
+ $(DSOCOMMAND) $@ $(GLOBJECTS) -L. $(GLDLIBS) -lfltk
$(RM) libfltk_gl.so
$(LN) libfltk_gl.so.1.1 libfltk_gl.so

View File

@ -1,133 +0,0 @@
#!/bin/sh
# Slackware build script for fltk
# Copyright 2006-2010 LukenShiro <lukenshiro@ngi.it>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
# notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=fltk
VERSION=1.1.10
BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
fi
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
DOCFILES="ANNOUNCEMENT CHANGES COPYING CREDITS README"
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
fi
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xjf $CWD/$PRGNAM-$VERSION-source.tar.bz2
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Fix underlinking.
patch -p1 -i $CWD/fltk-1.1.10-pkgconfig_xft.patch
patch -p1 -i $CWD/fltk-1.1.x-r5750-undefined.patch
# Fix linking when --libdir=/usr/lib64
sed -i \
-e '/RANLIB/s:$(libdir)/\(.*LIBNAME)\):$(libdir)/`basename \1`:g' \
src/Makefile || exit
# Fix for libpng16 (-current) snarfed from Debian ;-)
patch -p1 < $CWD/fltk-1.1.10_libpng.patch
# --docdir seems to be ignored
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
--prefix=/usr \
--sysconfdir=/etc \
--libdir=/usr/lib${LIBDIRSUFFIX} \
--localstatedir=/var \
--mandir=/usr/man \
--enable-gl \
--enable-largefile \
--enable-shared \
--enable-threads \
--enable-xinerama \
--enable-xft \
--enable-xdbe
make
make install DESTDIR=$PKG
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
( cd $PKG/usr/man
find . -type f -exec gzip -9 {} \;
for i in $(find . -type l) ; do ln -s $(readlink $i).gz $i.gz ; rm $i ; done
)
# Remove catman directories :)
rm -rf $PKG/usr/man/cat{1,3}
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/{examples,html}
cp -a $DOCFILES $PKG/usr/doc/$PRGNAM-$VERSION
# move html and image files
mv $PKG/usr/share/doc/$PRGNAM/*.{html,gif,jpg} \
$PKG/usr/doc/$PRGNAM-$VERSION/html/
# move remaing files
mv $PKG/usr/share/doc/$PRGNAM/examples \
$PKG/usr/doc/$PRGNAM-$VERSION/
rm -rf $PKG/usr/share
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}

View File

@ -1,10 +0,0 @@
PRGNAM="fltk"
VERSION="1.1.10"
HOMEPAGE="http://www.fltk.org"
DOWNLOAD="http://ftp.funet.fi/pub/mirrors/ftp.easysw.com/pub/fltk/1.1.10/fltk-1.1.10-source.tar.bz2"
MD5SUM="a1765594bc427ff892e36089fe1fa672"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
MAINTAINER="LukenShiro"
EMAIL="lukenshiro@ngi.it"

View File

@ -1,19 +0,0 @@
# HOW TO EDIT THIS FILE:
# The "handy ruler" below makes it easier to edit a package description.
# Line up the first '|' above the ':' following the base package name, and
# the '|' on the right side marks the last column you can put a character in.
# You must make exactly 11 lines for the formatting to be correct. It's also
# customary to leave one space after the ':' except on otherwise blank lines.
|-----handy-ruler------------------------------------------------------|
fltk: FLTK (Fast Light Tool Kit)
fltk:
fltk: The Fast Light Tool Kit ("FLTK", pronounced "fulltick") is a
fltk: a cross-platform C++ GUI toolkit for UNIX(r)/Linux(r) (X11),
fltk: Microsoft(r) Windows(r), and MacOS(r) X. FLTK provides
fltk: modern GUI functionality without the bloat and supports 3D
fltk: graphics via OpenGL(r) and its built-in GLUT emulation. It
fltk: was originally developed by Mr. Bill Spitzak and is
fltk: currently maintained by a small group of developers across
fltk: the world with a central repository in the US.
fltk: