network/dnscrypt-wrapper: Updated for version 0.1.11.

Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
T3slider 2014-08-07 12:54:29 +07:00 committed by Willy Sudiarto Raharjo
parent 5e6c7f584a
commit 28c9436faa
3 changed files with 47 additions and 12 deletions

View File

@ -0,0 +1,10 @@
--- Makefile.orig 2014-08-06 19:21:52.477696790 -0400
+++ Makefile 2014-08-06 19:22:44.670100677 -0400
@@ -154,7 +154,6 @@
@$(MAKE) -C argparse libargparse.a
argparse/argparse.h:
- git submodule update --init argparse
$(LIB_OBJS): $(LIB_H)

View File

@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=dnscrypt-wrapper
VERSION=${VERSION:-0.1.10}
VERSION=${VERSION:-0.1.11}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@ -54,31 +54,54 @@ else
LIBDIRSUFFIX=""
fi
# argparse is a git submodule required for building...
ARGPARSEVERSION=${ARGPARSEVERSION:-2f310edc35e5adacaf738ccb9d73d9c23f4e38b1}
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
rm -rf $PRGNAM-$VERSION argparse-$ARGPARSEVERSION
if [ -e $CWD/v$VERSION.tar.gz ]; then
tar xvf $CWD/v$VERSION.tar.gz
else
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
fi
if [ -e $CWD/$ARGPARSEVERSION.tar.gz ]; then
tar xvf $CWD/$ARGPARSEVERSION.tar.gz
else
tar xvf $CWD/argparse-$ARGPARSEVERSION.tar.gz
fi
# argparse source is expected in dnscrypt source...
mv argparse-$ARGPARSEVERSION/* $PRGNAM-$VERSION/argparse/
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Patch out git submodule init. Already have argparse anyway, and this is not
# a git repo (so it would fail)...
patch -p0 < $CWD/Makefile.patch
make configure
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
--prefix=/usr \
--libdir=/usr/lib${LIBDIRSUFFIX} \
--sysconfdir=/etc \
--localstatedir=/var \
--mandir=/usr/man \
--docdir=/usr/doc/$PRGNAM-$VERSION \
--build=$ARCH-slackware-linux
make
# A Makefile patch would be larger than this, so...
mkdir -p $PKG/usr/bin
install -m 755 -t $PKG/usr/bin dnscrypt-wrapper
make install BINDIR=$PKG/usr/bin
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true

View File

@ -1,10 +1,12 @@
PRGNAM="dnscrypt-wrapper"
VERSION="0.1.10"
VERSION="0.1.11"
HOMEPAGE="https://github.com/Cofyc/dnscrypt-wrapper"
DOWNLOAD="https://github.com/Cofyc/dnscrypt-wrapper/archive/v0.1.10.tar.gz"
MD5SUM="464d5beadb637caab5c4c791f06599e9"
DOWNLOAD="https://github.com/Cofyc/dnscrypt-wrapper/archive/v0.1.11.tar.gz \
https://github.com/Cofyc/argparse/archive/2f310edc35e5adacaf738ccb9d73d9c23f4e38b1.tar.gz"
MD5SUM="5eba477360a413276d45468a7bcd16a9 \
8165f08226ca5ee68c08d5fa9b706202"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
REQUIRES="libsodium"
MAINTAINER="T3slider"
EMAIL="t3slider@gmail.com"