system/pbzip2: Updated for version 1.0.3
This commit is contained in:
parent
d73dfdc7fe
commit
2649a91533
|
@ -1,22 +0,0 @@
|
|||
--- Makefile 2007-03-14 15:59:20.000000000 -0500
|
||||
+++ Makefile.new 2007-03-14 16:00:29.000000000 -0500
|
||||
@@ -11,16 +11,16 @@
|
||||
|
||||
# Standard pbzip2 compile
|
||||
pbzip2: pbzip2.cpp
|
||||
- $(CC) -O3 -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -o pbzip2 pbzip2.cpp -pthread -lpthread -lbz2
|
||||
+ $(CC) -O3 -march=i486 -mtune=i686 -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -o pbzip2 pbzip2.cpp -pthread -lpthread -lbz2
|
||||
|
||||
# Choose this if you want to compile in a static version of the libbz2 library
|
||||
pbzip2-static: libbz2.a pbzip2.cpp
|
||||
- $(CC) -O3 -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -o pbzip2 pbzip2.cpp -pthread -lpthread -I. -L. -lbz2
|
||||
+ $(CC) -O3 -march=i486 -mtune=i686 -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -o pbzip2 pbzip2.cpp -pthread -lpthread -I. -L. -lbz2
|
||||
|
||||
# Compatability mode for 32bit file sizes (less than 2GB) and systems
|
||||
# that have compilers that treat int as 64bit natively (ie: modern AIX)
|
||||
pbzip2-compat: pbzip2.cpp
|
||||
- $(CC) -O3 -o pbzip2 pbzip2.cpp -pthread -lpthread -lbz2
|
||||
+ $(CC) -O3 -march=i486 -mtune=i686 -o pbzip2 pbzip2.cpp -pthread -lpthread -lbz2
|
||||
|
||||
# Install the binary pbzip2 program and man page
|
||||
install: pbzip2
|
|
@ -1,10 +1,10 @@
|
|||
Parallel BZIP2 (PBZIP2) - Data Compression Software
|
||||
|
||||
PBZIP2 is a parallel implementation of the bzip2 block-sorting file compressor
|
||||
that uses pthreads and achieves near-linear speedup on SMP machines. The
|
||||
output of this version is fully compatible with bzip2 v1.0.2 or newer (ie:
|
||||
anything compressed with pbzip2 can be decompressed with bzip2).
|
||||
PBZIP2 is a parallel implementation of the bzip2 block-sorting file
|
||||
compressor that uses pthreads and achieves near-linear speedup on SMP
|
||||
machines. The output of this version is fully compatible with bzip2 v1.0.2 or
|
||||
newer (ie: anything compressed with pbzip2 can be decompressed with bzip2).
|
||||
|
||||
PBZIP2 should work on any system that has a pthreads compatible C++ compiler
|
||||
(such as gcc). It has been tested on: Linux, Windows (cygwin & MinGW),
|
||||
Solaris, Tru64/OSF1, HP-UX, and Irix.
|
||||
PBZIP2 should work on any system that has a pthreads compatible C++
|
||||
compiler (such as gcc). It has been tested on: Linux, Windows (cygwin &
|
||||
MinGW), Solaris, Tru64/OSF1, HP-UX, and Irix.
|
||||
|
|
|
@ -1,10 +1,10 @@
|
|||
#!/bin/sh
|
||||
#!/bin/sh -eu
|
||||
|
||||
# Slackware build script for PBZIP2
|
||||
# Written by Erik Hanson erik@slackbuilds.org
|
||||
|
||||
PRGNAM=pbzip2
|
||||
VERSION=1.0
|
||||
VERSION=1.0.3
|
||||
ARCH=${ARCH:-i486}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
@ -13,20 +13,28 @@ TMP=${TMP:-/tmp/SBo}
|
|||
PKG=$TMP/package-$PRGNAM
|
||||
OUTPUT=${OUTPUT:-/tmp}
|
||||
|
||||
if [ "$ARCH" = "i486" ]; then
|
||||
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
|
||||
elif [ "$ARCH" = "i686" ]; then
|
||||
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
|
||||
fi
|
||||
|
||||
rm -rf $PKG
|
||||
mkdir -p $TMP $PKG
|
||||
cd $TMP
|
||||
cd $TMP
|
||||
rm -rf $PRGNAM-$VERSION
|
||||
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz || exit 1
|
||||
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
|
||||
cd $PRGNAM-$VERSION
|
||||
chown -R root:root .
|
||||
chmod -R u+w,go+r-w,a-s .
|
||||
|
||||
# Patch to add march/mtune
|
||||
patch -p0 < $CWD/Makefile.patch
|
||||
make || exit 1
|
||||
# Hack to add march/mtune
|
||||
sed -i "s/-O2/${SLKCFLAGS}/" Makefile
|
||||
|
||||
# DESTDIR isn't support, there's only 2 files so install manually
|
||||
# Build
|
||||
make
|
||||
|
||||
# DESTDIR isn't supported, install manually
|
||||
mkdir -p $PKG/usr/{bin,man/man1,doc/$PRGNAM-$VERSION} $PKG/install
|
||||
|
||||
# Binary
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
PRGNAM="pbzip2"
|
||||
VERSION="1.0"
|
||||
VERSION="1.0.3"
|
||||
HOMEPAGE="http://compression.ca/pbzip2/"
|
||||
DOWNLOAD="http://compression.ca/pbzip2/pbzip2-1.0.tar.gz"
|
||||
MD5SUM="a8923165b97e665b9d1e85f1566700e9"
|
||||
DOWNLOAD="http://compression.ca/pbzip2/pbzip2-1.0.3.tar.gz"
|
||||
MD5SUM="38cb9106c45add5e0fb80864477df7e7"
|
||||
MAINTAINER="Erik Hanson"
|
||||
EMAIL="erik@slackbuilds.org"
|
||||
APPROVED="BP{k}"
|
||||
APPROVED="dsomero"
|
||||
|
|
Loading…
Reference in New Issue