development/mysql-workbench: Updated for version 6.3.6.

Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
Willy Sudiarto Raharjo 2015-04-26 17:51:42 +07:00
parent fd1448408d
commit 264004c515
6 changed files with 74 additions and 87 deletions

View File

@ -1,44 +0,0 @@
diff --git a/backend/wbpublic/objimpl/db.query/db_query_Resultset.cpp b/backend/wbpublic/objimpl/db.query/db_query_Resultset.cpp
index 1b69f22..82de11f 100644
--- a/backend/wbpublic/objimpl/db.query/db_query_Resultset.cpp
+++ b/backend/wbpublic/objimpl/db.query/db_query_Resultset.cpp
@@ -241,7 +241,11 @@ public:
const int last_column= meta->getColumnCount();
for (int i = 1; i <= last_column; i++)
{
+#ifdef MYSQLCPPCONN_VERSION_1_1_5
+ column_by_name[meta->getColumnLabel(i)]= i;
+#else
column_by_name[meta->getColumnName(i)]= i;
+#endif
std::string type;
switch (meta->getColumnType(i))
@@ -308,7 +312,11 @@ public:
db_query_ResultsetColumnRef column(aself->get_grt());
column->owner(aself);
+#ifdef MYSQLCPPCONN_VERSION_1_1_5
+ column->name(std::string(meta->getColumnLabel(i)));
+#else
column->name(std::string(meta->getColumnName(i)));
+#endif
column->columnType(type);
self->columns().insert(column);
diff --git a/modules/db.mysql.query/src/dbquery.cpp b/modules/db.mysql.query/src/dbquery.cpp
index 428bad3..74db1dc 100644
--- a/modules/db.mysql.query/src/dbquery.cpp
+++ b/modules/db.mysql.query/src/dbquery.cpp
@@ -521,7 +521,11 @@ std::string DbMySQLQueryImpl::resultFieldName(int result, int field)
throw std::invalid_argument("Invalid resultset");
sql::ResultSet *res = _resultsets[result];
+#ifdef MYSQLCPPCONN_VERSION_1_1_5
+ return res->getMetaData()->getColumnLabel(field);
+#else
return res->getMetaData()->getColumnName(field);
+#endif
}

View File

@ -0,0 +1,58 @@
diff --git a/plugins/migration/copytable/copytable.cpp b/plugins/migration/copytable/copytable.cpp
index de52d91..2df53a4 100644
--- a/plugins/migration/copytable/copytable.cpp
+++ b/plugins/migration/copytable/copytable.cpp
@@ -79,7 +79,7 @@ static const char *mysql_field_type_to_name(enum enum_field_types type)
case MYSQL_TYPE_VAR_STRING: return "MYSQL_TYPE_VAR_STRING";
case MYSQL_TYPE_STRING: return "MYSQL_TYPE_STRING";
case MYSQL_TYPE_GEOMETRY: return "MYSQL_TYPE_GEOMETRY";
- case MYSQL_TYPE_JSON: return "MYSQL_TYPE_JSON";
+// case MYSQL_TYPE_JSON: return "MYSQL_TYPE_JSON";
default:
return "UNKNOWN";
}
@@ -241,7 +241,7 @@ RowBuffer::RowBuffer(boost::shared_ptr<std::vector<ColumnInfo> > columns,
case MYSQL_TYPE_STRING:
case MYSQL_TYPE_VAR_STRING:
case MYSQL_TYPE_BIT:
- case MYSQL_TYPE_JSON:
+// case MYSQL_TYPE_JSON:
if (!col->is_long_data)
bind.buffer_length = (unsigned)col->source_length+1;
@@ -1551,8 +1551,8 @@ bool MySQLCopyDataSource::fetch_row(RowBuffer &rowbuffer)
rowbuffer[index].buffer_type == MYSQL_TYPE_LONG_BLOB ||
rowbuffer[index].buffer_type == MYSQL_TYPE_BLOB ||
rowbuffer[index].buffer_type == MYSQL_TYPE_STRING ||
- rowbuffer[index].buffer_type == MYSQL_TYPE_GEOMETRY ||
- rowbuffer[index].buffer_type == MYSQL_TYPE_JSON)
+ rowbuffer[index].buffer_type == MYSQL_TYPE_GEOMETRY)
+// rowbuffer[index].buffer_type == MYSQL_TYPE_JSON)
{
if (rowbuffer[index].buffer_length)
free(rowbuffer[index].buffer);
@@ -2357,7 +2357,7 @@ bool MySQLCopyDataTarget::append_bulk_column(size_t col_index)
case MYSQL_TYPE_STRING:
case MYSQL_TYPE_ENUM:
case MYSQL_TYPE_SET:
- case MYSQL_TYPE_JSON:
+// case MYSQL_TYPE_JSON:
_bulk_insert_record.append("'", 1);
ret_val = _bulk_insert_record.append_escaped((char*)(*_row_buffer)[col_index].buffer, *(*_row_buffer)[col_index].length);
_bulk_insert_record.append("'", 1);
diff --git a/backend/wbpublic/objimpl/db.query/db_query_Resultset.cpp b/backend/wbpublic/objimpl/db.query/db_query_Resultset.cpp
index f5c2ffb..b42ba6a 100644
--- a/backend/wbpublic/objimpl/db.query/db_query_Resultset.cpp
+++ b/backend/wbpublic/objimpl/db.query/db_query_Resultset.cpp
@@ -300,9 +300,9 @@ public:
case sql::DataType::SET:
type= "string";
break;
- case sql::DataType::JSON:
+ /* case sql::DataType::JSON:
type = "json";
- break;
+ break; */
case sql::DataType::SQLNULL:
type = "null";
break;

View File

@ -3,7 +3,7 @@
# Slackware build script for mysql-workbench
# Originally written by André Geraldo Vieira <andre.geraldo@gmail.com>
# Copyright 2013-2014 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
# Copyright 2013-2016 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@ -24,7 +24,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=mysql-workbench
VERSION=${VERSION:-6.2.5}
VERSION=${VERSION:-6.3.6}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@ -75,12 +75,11 @@ find -L . \
# Patch from Ponce
patch -p1 < $CWD/config_and_ifconfig_paths.patch
# fix schema and table inspector with mysql-connector-c++ >= 1.1.5
# still not really working, so mysql-connector-c++ is kept at 1.1.3
patch -p1 < $CWD/mysql-workbench-column-label.patch
# Patch to fix gdal include path
patch -p1 < $CWD/workbench-gdal.patch
sed -i '/#include/s|gdal/||' \
backend/wbpublic/grtui/geom_draw_box.h \
backend/wbpublic/grt/spatial_handler.h \
backend/wbpublic/objimpl/db.query/db_query_Resultset.cpp
# mysqldump from mariadb does not support --set-gtid-purged
patch -p1 < $CWD/mysql-workbench-no-set-gtid-purged.patch
@ -90,8 +89,13 @@ patch -p1 < $CWD/mysql-workbench-no-set-gtid-purged.patch
# gnome-keyring package in stable release as well
patch -p1 < $CWD/mysql-workbench-gnome-keyring.patch
patch -p1 < $CWD/mysql-workbench-no-json.patch
install -D $CWD/antlr-3.4-complete.jar $TMP/linux-res/bin/antlr-3.4-complete.jar
# make cmake happy with mariadb
sed -i '/^find_package(MySQL /c find_package(MySQL REQUIRED)' CMakeLists.txt
mkdir -p wb-build
cd wb-build
cmake \
@ -102,6 +106,7 @@ cmake \
-DPYTHON_INCLUDE_DIR:PATH=/usr/include/python2.7 \
-DPYTHON_LIBRARY:FILEPATH=/usr/lib$LIBDIRSUFFIX/libpython2.7.so \
-DGDAL_INCLUDE_DIR=/usr/include \
-DCMAKE_CXX_FLAGS="-std=c++11" \
-DCMAKE_BUILD_TYPE=Release ..
make

View File

@ -1,9 +1,9 @@
PRGNAM="mysql-workbench"
VERSION="6.2.5"
VERSION="6.3.6"
HOMEPAGE="https://www.mysql.com/downloads/workbench/"
DOWNLOAD="http://www.mirrorservice.org/sites/ftp.mysql.com/Downloads/MySQLGUITools/mysql-workbench-community-6.2.5-src.tar.gz \
DOWNLOAD="http://www.mirrorservice.org/sites/ftp.mysql.com/Downloads/MySQLGUITools/mysql-workbench-community-6.3.6-src.tar.gz \
http://www.antlr3.org/download/antlr-3.4-complete.jar"
MD5SUM="31f8bd081993854f76d0bc73df08c3ad \
MD5SUM="494fc4fa529cbfec80949ea603d702ff \
1b91dea1c7d480b3223f7c8a9aa0e172"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""

View File

@ -11,6 +11,6 @@
<value type="int" key="sys.usesudo">0</value>
<value type="string" key="sys.system">Linux</value>
<value type="string" key="serverVersion">5.5.40</value>
<value type="string" key="serverVersion">10.0</value>
</value>
</data>

View File

@ -1,32 +0,0 @@
--- mysql-workbench-community-6.2.2-src/backend/wbpublic/grt/spatial_handler.h.orig 2014-09-08 13:59:56.557339109 +0700
+++ mysql-workbench-community-6.2.2-src/backend/wbpublic/grt/spatial_handler.h 2014-09-08 14:00:11.515354241 +0700
@@ -20,12 +20,12 @@
#ifndef SPATIAL_HANDLER_H_
#define SPATIAL_HANDLER_H_
-#include <gdal/ogrsf_frmts.h>
-#include <gdal/ogr_api.h>
-#include <gdal/gdal_pam.h>
-#include <gdal/memdataset.h>
-#include <gdal/gdal_alg.h>
-#include <gdal/gdal.h>
+#include <ogrsf_frmts.h>
+#include <ogr_api.h>
+#include <gdal_pam.h>
+#include <memdataset.h>
+#include <gdal_alg.h>
+#include <gdal.h>
#include <deque>
#include "base/geometry.h"
#include "wbpublic_public_interface.h"
--- mysql-workbench-community-6.2.2-src/backend/wbpublic/grtui/geom_draw_box.h.orig 2014-09-08 14:32:05.677224760 +0700
+++ mysql-workbench-community-6.2.2-src/backend/wbpublic/grtui/geom_draw_box.h 2014-09-08 14:32:13.122224590 +0700
@@ -22,7 +22,7 @@
#define _GEOM_DRAW_BOX_H_
#include <mforms/drawbox.h>
-#include <gdal/ogr_geometry.h>
+#include <ogr_geometry.h>
#include "wbpublic_public_interface.h"
class WBPUBLICBACKEND_PUBLIC_FUNC GeomDrawBox : public mforms::DrawBox