office/LibreOffice: Updated for version 7.2.1.2
Signed-off-by: Christoph Willing <chris.willing@linux.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
07361bd61b
commit
23c7363a55
|
@ -28,13 +28,15 @@ cd $(dirname $0) ; CWD=$(pwd)
|
|||
|
||||
PRGNAM=LibreOffice
|
||||
SRCNAM=libreoffice
|
||||
VERSION=${VERSION:-7.2.0.4}
|
||||
VERSION=${VERSION:-7.2.1.2}
|
||||
SHORT_VERSION=${VERSION%.*.*}
|
||||
BUILD=${BUILD:-2}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
PKGTYPE=${PKGTYPE:-tgz}
|
||||
|
||||
HAVE_SRCS_TARBALL=${HAVE_SRCS_TARBALL:-1}
|
||||
unset UNO_PATH
|
||||
unset URE_BOOTSTRAP
|
||||
|
||||
if [ -z "$ARCH" ]; then
|
||||
case "$( uname -m )" in
|
||||
|
@ -290,6 +292,7 @@ fi
|
|||
|
||||
patch -p0 < $CWD/no-check-if-root.diff
|
||||
patch -p0 < $CWD/skia-freetype-2.11.diff
|
||||
patch -p0 < $CWD/bison_yyn-yyrule_rename.diff
|
||||
|
||||
# GCC10 requirements (Tx alienBOB)
|
||||
sed -i external/libebook/ExternalProject_libebook.mk \
|
||||
|
|
|
@ -1,10 +1,10 @@
|
|||
PRGNAM="LibreOffice"
|
||||
VERSION="7.2.0.4"
|
||||
VERSION="7.2.1.2"
|
||||
HOMEPAGE="https://www.libreoffice.org"
|
||||
DOWNLOAD="https://download.documentfoundation.org/libreoffice/src/7.2.0/libreoffice-7.2.0.4.tar.xz \
|
||||
https://sourceforge.net/projects/slackbuildsdirectlinks/files/LibreOffice/libreoffice-7.2.0.4-srcs.tar.xz"
|
||||
MD5SUM="a4f2e92dc6829d556156ec7a13a965b8 \
|
||||
0ed691eba52080ceed0936ea16c80ff5"
|
||||
DOWNLOAD="https://download.documentfoundation.org/libreoffice/src/7.2.1/libreoffice-7.2.1.2.tar.xz \
|
||||
https://sourceforge.net/projects/slackbuildsdirectlinks/files/LibreOffice/libreoffice-7.2.1.2-srcs.tar.xz"
|
||||
MD5SUM="2631963c2d42eab66f34c1e57e00a995 \
|
||||
ccd38deacdb161aeea36e1678604c880"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES="jdk11 apache-ant perl-Archive-Zip"
|
||||
|
|
|
@ -0,0 +1,18 @@
|
|||
--- connectivity/source/parse/sqlbison.y.orig 2021-09-18 13:35:17.897000000 +1000
|
||||
+++ connectivity/source/parse/sqlbison.y 2021-09-18 13:32:58.864000000 +1000
|
||||
@@ -74,9 +74,15 @@
|
||||
|
||||
// yyi is the internal number of the rule that is currently being reduced
|
||||
// This can be mapped to external rule number via the yyrmap.
|
||||
+#if defined YYBISON && YYBISON >= 30800
|
||||
+#define SQL_NEW_RULE newNode("", SQLNodeType::Rule, yyr1[yyrule])
|
||||
+#define SQL_NEW_LISTRULE newNode("", SQLNodeType::ListRule, yyr1[yyrule])
|
||||
+#define SQL_NEW_COMMALISTRULE newNode("", SQLNodeType::CommaListRule, yyr1[yyrule])
|
||||
+#else
|
||||
#define SQL_NEW_RULE newNode("", SQLNodeType::Rule, yyr1[yyn])
|
||||
#define SQL_NEW_LISTRULE newNode("", SQLNodeType::ListRule, yyr1[yyn])
|
||||
#define SQL_NEW_COMMALISTRULE newNode("", SQLNodeType::CommaListRule, yyr1[yyn])
|
||||
+#endif
|
||||
|
||||
|
||||
extern connectivity::OSQLParser* xxx_pGLOBAL_SQLPARSER;
|
Loading…
Reference in New Issue