system/slim: Patched to use libpng14.

Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
This commit is contained in:
Max Miorim 2010-05-31 23:58:08 -05:00 committed by Robby Workman
parent 1621f3d387
commit 22bc6f3755
2 changed files with 48 additions and 6 deletions

View File

@ -0,0 +1,15 @@
diff --git a/Makefile b/Makefile
--- a/Makefile
+++ b/Makefile
@@ -5,9 +5,9 @@
#######################################################
CXX=/usr/bin/g++
CC=/usr/bin/gcc
-CFLAGS=-Wall -I. -I/usr/include/freetype2 -I/usr/include/freetype2/config -I/usr/include/libpng12 -I/usr/include
+CFLAGS=-Wall -I. -I/usr/include/freetype2 -I/usr/include/freetype2/config -I/usr/include/libpng14 -I/usr/include
CXXFLAGS=$(CFLAGS)
-LDFLAGS=-lXft -lX11 -lfreetype -lXrender -lfontconfig -lpng12 -lz -lm -lcrypt -lXmu -lpng -ljpeg
+LDFLAGS=-lXft -lX11 -lfreetype -lXrender -lfontconfig -lpng14 -lz -lm -lcrypt -lXmu -ljpeg
CUSTOM=-DHAVE_SHADOW
ifdef USE_PAM
LDFLAGS+= -lpam

View File

@ -26,10 +26,19 @@
PRGNAM=slim
VERSION=${VERSION:-1.3.1}
ARCH=${ARCH:-i486}
BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
# Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$( uname -m ) ;;
esac
fi
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
@ -49,10 +58,28 @@ elif [ "$ARCH" = "i686" ]; then
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
fi
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
@ -69,9 +96,12 @@ find . \
# Correct the path used for suspend:
patch -p0 < $CWD/slim.conf.patch
# Include stdio.h for -current (but harmless on 13.0)
# Include stdio.h
patch -p1 < $CWD/slim-1.3.1-include_stdio_h.patch
# Use libpng14
patch -p1 < $CWD/slim-1.3.1-use_libpng14.patch
make \
CFLAGS+="$SLKCFLAGS" \
USE_PAM=${USE_PAM}
@ -86,10 +116,7 @@ tar xvf $CWD/slackware-black.tar.bz2 -C $PKG/usr/share/slim/themes
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
( cd $PKG/usr/man || exit 1
find . -type f -exec gzip -9 {} \;
for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
)
find $PKG/usr/man -type f -exec gzip -9 {} \;
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \