system/backintime: Added (simple backup tool)

Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
This commit is contained in:
Pierre Cazenave 2010-08-28 08:12:05 -04:00 committed by Erik Hanson
parent 5a9d224e41
commit 21581b513c
6 changed files with 158 additions and 0 deletions

13
system/backintime/README Normal file
View File

@ -0,0 +1,13 @@
Back In Time is a simple backup tool for Linux inspired from "flyback
project" and "TimeVault". The backup is done by taking snapshots of a
specified set of directories.
All you have to do is configure:
* Where to save snapshot
* What directories to backup
* When backup should be done (manual, every hour, every day,
every week, every month)
Launch the GUI with backintime-kde4 or from the system menu.

View File

@ -0,0 +1,10 @@
--- backintime-0.9.26/kde4/backintime-kde4-root.desktop 2009-03-20 09:35:01.000000000 +0000
+++ backintime-0.9.26/kde4/backintime-kde4-root.desktop.new 2010-08-24 15:38:40.686785137 +0100
@@ -1,6 +1,6 @@
[Desktop Entry]
Name=Back In Time (root)
-Exec=kdesudo -c backintime-kde4
+Exec=kdesu -c backintime-kde4
Icon=document-save
Terminal=false
X-MultipleArgs=false

View File

@ -0,0 +1,98 @@
#!/bin/sh
# SlackBuild script for Back In Time.
#
# Copyright 2010 Pierre Cazenave <pwcazenave {at} gmail [dot] com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
# notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=backintime
VERSION=0.9.26
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
fi
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
set -eu
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-${VERSION}_src.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
chmod -R u+w,go+r-w,a-s .
# Patch the root .desktop file to use kdesu rather than kdesudo, which isn't
# included in Slackware
patch -p1 < $CWD/backintime-kde4-root-desktop.patch
# Common components
cd $TMP/$PRGNAM-$VERSION/common
./configure
# Fix documentation paths
sed -i 's|/share/doc/backintime-common|/doc/'$PRGNAM'-'$VERSION'|g' \
$TMP/$PRGNAM-$VERSION/common/Makefile
make
make install DESTDIR=$PKG
cd -
# kde4 components
cd $TMP/$PRGNAM-$VERSION/kde4
./configure
# Fix documentation paths
sed -i 's|/share/doc/backintime-kde4|/doc/'$PRGNAM'-'$VERSION'|g' \
$TMP/$PRGNAM-$VERSION/common/Makefile
make
make install DESTDIR=$PKG
cd -
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
# Move the manpages from /usr/share to /usr
mv $PKG/usr/share/man/ $PKG/usr
# Remove duplicate copyright from /usr/share/doc/backintime-0.9.26
rm -r $PKG/usr/share/doc
cp -a \
AUTHORS CHANGES LICENSE README TODO TRANSLATIONS VERSION \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
cat $CWD/README > $PKG/usr/doc/$PRGNAM-$VERSION/README$TAG
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}

View File

@ -0,0 +1,10 @@
PRGNAM="backintime"
VERSION="0.9.26"
HOMEPAGE="http://backintime.le-web.org/"
DOWNLOAD="http://backintime.le-web.org/download/backintime/backintime-0.9.26_src.tar.gz"
MD5SUM="8a53d1f757ccfa439754f4a8b9cb3e49"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MAINTAINER="Pierre Cazenave"
EMAIL="pwcazenave <at> gmail {dot} com"
APPROVED="dsomero"

View File

@ -0,0 +1,8 @@
if [ -x /usr/bin/update-desktop-database ]; then
/usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
fi
if [ -x /usr/bin/update-mime-database ]; then
/usr/bin/update-mime-database usr/share/mime >/dev/null 2>&1
fi

View File

@ -0,0 +1,19 @@
# HOW TO EDIT THIS FILE:
# The "handy ruler" below makes it easier to edit a package description. Line
# up the first '|' above the ':' following the base package name, and the '|' on
# the right side marks the last column you can put a character in. You must make
# exactly 11 lines for the formatting to be correct. It's also customary to
# leave one space after the ':'.
|-----handy-ruler--------------------------------------------------|
backintime: backintime (simple backup tool)
backintime:
backintime: Back In Time is a simple backup tool for Linux inspired from
backintime: "flyback project" and "TimeVault". The backup is done by taking
backintime: snapshots of a specified set of directories.
backintime:
backintime: All you have to do is configure where to save snapshot, what
backintime: directories to backup and when backup should be done (manual,
backintime: every hour, every day, every week, every month)
backintime:
backintime: http://backintime.le-web.org/