libraries/opencv: Updated for version 3.4.4
Signed-off-by: Christoph Willing <chris.willing@linux.com>
This commit is contained in:
parent
7fd261de5f
commit
20e0fe101e
|
@ -26,7 +26,7 @@
|
|||
|
||||
PRGNAM=opencv
|
||||
PRGNAM2=opencv_contrib
|
||||
VERSION=${VERSION:-3.4.3}
|
||||
VERSION=${VERSION:-3.4.4}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
|
@ -81,7 +81,7 @@ tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
|
|||
cd $PRGNAM-$VERSION
|
||||
tar xf $CWD/$PRGNAM2-$VERSION.tar.gz
|
||||
patch -p0 < $CWD/patch_fsh-${VERSION}.diff
|
||||
patch -p1 < $CWD/patch_cvdef_h.diff
|
||||
patch -p0 < $CWD/patch_cvdef_h.diff
|
||||
chown -R root:root .
|
||||
find -L . \
|
||||
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
|
||||
|
|
|
@ -1,10 +1,10 @@
|
|||
PRGNAM="opencv"
|
||||
VERSION="3.4.3"
|
||||
VERSION="3.4.4"
|
||||
HOMEPAGE="https://opencv.org/"
|
||||
DOWNLOAD="https://github.com/opencv/opencv/archive/3.4.3/opencv-3.4.3.tar.gz \
|
||||
https://github.com/opencv/opencv_contrib/archive/3.4.3/opencv_contrib-3.4.3.tar.gz"
|
||||
MD5SUM="712896f5815938c014c199dde142d508 \
|
||||
08340fb742d3c54184653091a1137927"
|
||||
DOWNLOAD="https://github.com/opencv/opencv/archive/3.4.4/opencv-3.4.4.tar.gz \
|
||||
https://github.com/opencv/opencv_contrib/archive/3.4.4/opencv_contrib-3.4.4.tar.gz"
|
||||
MD5SUM="d4b03579405a69ef765e4c79f42c7c82 \
|
||||
171801354ce8c37c3ed9f795c8c03914"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES="numpy3"
|
||||
|
|
|
@ -1,20 +0,0 @@
|
|||
--- opencv-3.4.1/modules/core/include/opencv2/core/cvdef.h.orig 2018-02-28 10:16:45.000320632 +0000
|
||||
+++ opencv-3.4.1/modules/core/include/opencv2/core/cvdef.h 2018-02-28 10:34:30.852346927 +0000
|
||||
@@ -454,6 +454,7 @@ Cv64suf;
|
||||
|
||||
|
||||
// Integer types portatibility
|
||||
+#if defined __cplusplus
|
||||
#ifdef OPENCV_STDINT_HEADER
|
||||
#include OPENCV_STDINT_HEADER
|
||||
#else
|
||||
@@ -494,6 +495,9 @@ typedef ::uint64_t uint64_t;
|
||||
}
|
||||
#endif
|
||||
#endif
|
||||
+#else
|
||||
+#include <stdint.h>
|
||||
+#endif
|
||||
|
||||
|
||||
//! @}
|
|
@ -1,6 +1,6 @@
|
|||
--- CMakeLists.txt.orig 2018-08-28 22:58:21.000000000 +1000
|
||||
+++ CMakeLists.txt 2018-08-31 07:58:34.745000000 +1000
|
||||
@@ -374,7 +374,7 @@
|
||||
--- CMakeLists.txt.orig 2018-11-17 20:22:17.000000000 +1000
|
||||
+++ CMakeLists.txt 2018-11-27 18:04:17.029000000 +1000
|
||||
@@ -383,7 +383,7 @@
|
||||
if(ANDROID OR WIN32)
|
||||
ocv_update(OPENCV_DOC_INSTALL_PATH doc)
|
||||
else()
|
||||
|
@ -9,7 +9,7 @@
|
|||
endif()
|
||||
|
||||
if(WIN32 AND CMAKE_HOST_SYSTEM_NAME MATCHES Windows)
|
||||
@@ -415,7 +415,7 @@
|
||||
@@ -424,7 +424,7 @@
|
||||
elseif(WIN32)
|
||||
ocv_update(OPENCV_TEST_DATA_INSTALL_PATH "testdata")
|
||||
else()
|
||||
|
@ -18,7 +18,7 @@
|
|||
endif()
|
||||
|
||||
if(ANDROID)
|
||||
@@ -446,17 +446,17 @@
|
||||
@@ -455,17 +455,17 @@
|
||||
else()
|
||||
include(GNUInstallDirs)
|
||||
ocv_update(OPENCV_LIB_INSTALL_PATH ${CMAKE_INSTALL_LIBDIR}${LIB_SUFFIX})
|
Loading…
Reference in New Issue