network/vwm: Added to 12.2 repository

This commit is contained in:
Pierre Cazenave 2010-05-12 23:32:52 +02:00 committed by David Somero
parent d397484dca
commit 1a98c0a24f
7 changed files with 183 additions and 0 deletions

18
network/vwm/README Normal file
View File

@ -0,0 +1,18 @@
Viper Window Manager (VWM) is a lightweight, extensible window manager for
the console. Originally, VWM was designed to be the reference implementation
of libviper. In fact, the two projects were initially one before public
release.
From conception, VWM was designed to be both lightweight and ssh
friendly. Character based line-art compresses very well as do the escape
sequences which handle cursor manipulation. This makes VWM quite suitable
for low-bandwidth, remote connectivity over ssh.
It is also very easy to extend the functionality of VWM. By following a
few simple API rules, anyone can create a "native application" which will
appear on the VWM Main Menu. The mechanism for this is very similar to
Mozilla-style plugins.
Requires libpseudo, libviper and libgtop, all available at SlackBuilds.org.
See /usr/doc/vwm-2.0.2/samples/vwmrc for information on customising VWM.

View File

@ -0,0 +1,11 @@
--- modules/sysmon/Makefile.orig 2009-05-22 15:26:39.000000000 +0100
+++ modules/sysmon/Makefile 2009-05-22 15:27:08.000000000 +0100
@@ -4,7 +4,7 @@
libdir = ${prefix}/lib
includedir = ${prefix}/include -I../..
bindir = ${prefix}/bin
-moddir = /usr/lib/vwm/modules
+moddir = ${libdir}/vwm/modules
makefile: all

View File

@ -0,0 +1,11 @@
--- modules/vwmterm2/Makefile.orig 2009-05-22 14:56:53.000000000 +0100
+++ modules/vwmterm2/Makefile 2009-05-22 14:57:32.000000000 +0100
@@ -5,7 +5,7 @@
libdir = ${prefix}/lib
includedir = -I${prefix}/include -I../..
bindir = ${prefix}/bin
-moddir = /usr/lib/vwm/modules
+moddir = ${libdir}/vwm/modules
makefile: all

View File

@ -0,0 +1,20 @@
--- Makefile.orig 2009-05-22 14:47:31.000000000 +0100
+++ Makefile 2009-05-22 15:54:30.000000000 +0100
@@ -8,7 +8,7 @@
includedir = ${prefix}/include -I./
bindir = ${prefix}/bin
headerdir = ${prefix}/include
-moddir = /usr/lib/vwm/modules
+moddir = ${libdir}/vwm/modules
makefile: all
@@ -32,7 +32,7 @@
rm -f vwm
install:
- mkdir -p $(moddir)
+ mkdir -p $(moddir) $(bindir) $(headerdir) $(libdir)
chmod 644 vwm.h
cp -f vwm.h $(headerdir)
chmod 755 vwm

19
network/vwm/slack-desc Normal file
View File

@ -0,0 +1,19 @@
# HOW TO EDIT THIS FILE:
# The "handy ruler" below makes it easier to edit a package description. Line
# up the first '|' above the ':' following the base package name, and the '|'
# on the right side marks the last column you can put a character in. You must
# make exactly 11 lines for the formatting to be correct. It's also
# customary to leave one space after the ':'.
|-----handy-ruler------------------------------------------------------|
vwm: vwm (Viper Window Manager is a console based window manager.)
vwm:
vwm: Viper Window Manager (VWM) is a lightweight, extensible window manager
vwm: for the console. Originally, VWM was designed to be the reference
vwm: implementation of libviper. In fact, the two projects were initially
vwm: one before public release.
vwm: From conception, VWM was designed to be both lightweight and ssh
vwm: friendly. Character based line-art compresses very well as do the
vwm: escape sequences which handle cursor manipulation. This makes VWM
vwm: quite suitable for low-bandwidth, remote connectivity over ssh.
vwm: http://vwm.sourceforge.net/

View File

@ -0,0 +1,96 @@
#!/bin/sh
# SlackBuild script for vwm.
#
# Copyright 2009 Pierre Cazenave <pwcazenave {at} gmail [dot] com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
# notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=vwm
VERSION=2.0.2
ARCH=${ARCH:-i486}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
fi
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM
chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
# patch the relevant Makefiles to not use hardcoded paths
patch -p0 < $CWD/patches/vwm-2.0.2-Makefile.patch
patch -p0 < $CWD/patches/vwm-2.0.2-Makefile-vwmterm2.patch
patch -p0 < $CWD/patches/vwm-2.0.2-Makefile-sysmon.patch
make CFLAGS="$SLKCFLAGS"
make install prefix=$PKG/usr libdir=$PKG/usr/lib${LIBDIRSUFFIX}
# build and install the sysmon module (the vmwterm2 one is done with
# the main installation)
cd modules/sysmon
make CFLAGS="$SLKCFLAGS -I$PKG/usr/include"
make install prefix=$PKG/usr libdir=$PKG/usr/lib${LIBDIRSUFFIX}
cd -
# build and install the keycodes tool to determine codes for remapping
# keystrokes in ~/.vwm/vwmrc
make keycode_tool
cp -a keycodes/keycodes $PKG/usr/bin/
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a CHANGELOG INSTALL LICENSE NOTES samples $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
cat $CWD/README > $PKG/usr/doc/$PRGNAM-$VERSION/README$TAG
find $PKG/usr/doc/$PRGNAM-$VERSION -type f -exec chmod 644 {} \;
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz

8
network/vwm/vwm.info Normal file
View File

@ -0,0 +1,8 @@
PRGNAM="vwm"
VERSION="2.0.2"
HOMEPAGE="http://vwm.sourceforge.net/"
DOWNLOAD="http://kent.dl.sourceforge.net/sourceforge/vwm/vwm-2.0.2.tar.gz"
MD5SUM="d6f2e7c9ec0ad28eb863629b6edf53af"
MAINTAINER="Pierre Cazenave"
EMAIL="pwcazenave <at> gmail {dot} com"
APPROVED="dsomero"