system/pigz: Updated for version 2.4
Fix installation procedure so that pigz binary is not installed twice (as pigz and unpigz). Make a symbolic link instead. Don't overwrite Makefile CFLAGS with SLKCFLAGS, instead append SLKCFLAGS to CFLAGS. Remove patch (not needed anymore). Align SlackBuild with template. Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
e2ab8cfd1b
commit
18db563673
|
@ -1,4 +1,4 @@
|
|||
pigz, which stands for parallel implementation of gzip, is a fully
|
||||
functional replacement for gzip that exploits multiple processors and
|
||||
multiple cores to the hilt when compressing data. pigz was written by
|
||||
Mark Adler, and uses the zlib and pthread libraries.
|
||||
pigz, which stands for Parallel Implementation of GZip, is a fully functional
|
||||
replacement for gzip that utilizes multiple processors and CPU cores when
|
||||
compressing data. pigz was written by Mark Adler, and uses zlib and pthread
|
||||
libraries.
|
||||
|
|
|
@ -1,12 +0,0 @@
|
|||
diff -Naur a/Makefile b/Makefile
|
||||
--- a/Makefile 2013-03-04 00:06:35.000000000 -0600
|
||||
+++ b/Makefile 2013-06-18 08:56:58.111172954 -0500
|
||||
@@ -3,7 +3,7 @@
|
||||
|
||||
|
||||
pigz: pigz.o yarn.o zopfli/deflate.o zopfli/blocksplitter.o zopfli/tree.o zopfli/lz77.o zopfli/cache.o zopfli/hash.o zopfli/util.o zopfli/squeeze.o zopfli/katajainen.o
|
||||
- $(CC) -o pigz $^ -lpthread -lz
|
||||
+ $(CC) -o pigz $^ -lpthread -lz -lm
|
||||
ln -f pigz unpigz
|
||||
|
||||
pigz.o: pigz.c yarn.h zopfli/deflate.h zopfli/util.h
|
|
@ -2,20 +2,38 @@
|
|||
|
||||
# Slackware build script for pigz
|
||||
|
||||
# Written by Max Miorim <miorimmax@gmail.com>
|
||||
|
||||
# Currently maintained by Patrick Verner <distrozilla@gmail.com> as of 6/29/2013
|
||||
# Changelog...
|
||||
# Patched to fix missing -lm flag in Makefile. math_fix.diff
|
||||
# Copyright 2010 Max Miorim <miorimmax@gmail.com>
|
||||
# Copyright 2010 Diogo Leal <diogo@diogoleal.com>
|
||||
# Copyright 2012 Matteo Bernardini <ponce@slackbuilds.org>
|
||||
# Copyright 2013 Patrick Verner <distrozilla@gmail.com>
|
||||
# Copyright 2020 Dominik Drobek <dominik.drobek (at) o2.pl>
|
||||
# All rights reserved.
|
||||
#
|
||||
# Redistribution and use of this script, with or without modification, is
|
||||
# permitted provided that the following conditions are met:
|
||||
#
|
||||
# 1. Redistributions of this script must retain the above copyright
|
||||
# notice, this list of conditions and the following disclaimer.
|
||||
#
|
||||
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
|
||||
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
|
||||
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
|
||||
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
||||
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
|
||||
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
|
||||
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
|
||||
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
|
||||
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
||||
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
|
||||
PRGNAM=pigz
|
||||
VERSION=${VERSION:-2.3}
|
||||
VERSION=${VERSION:-2.4}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
if [ -z "$ARCH" ]; then
|
||||
case "$( uname -m )" in
|
||||
i?86) ARCH=i486 ;;
|
||||
i?86) ARCH=i586 ;;
|
||||
arm*) ARCH=arm ;;
|
||||
*) ARCH=$( uname -m ) ;;
|
||||
esac
|
||||
|
@ -26,8 +44,8 @@ TMP=${TMP:-/tmp/SBo}
|
|||
PKG=$TMP/package-$PRGNAM
|
||||
OUTPUT=${OUTPUT:-/tmp}
|
||||
|
||||
if [ "$ARCH" = "i486" ]; then
|
||||
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
|
||||
if [ "$ARCH" = "i586" ]; then
|
||||
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
|
||||
LIBDIRSUFFIX=""
|
||||
elif [ "$ARCH" = "i686" ]; then
|
||||
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
|
||||
|
@ -40,7 +58,7 @@ else
|
|||
LIBDIRSUFFIX=""
|
||||
fi
|
||||
|
||||
set -e
|
||||
set -e
|
||||
|
||||
rm -rf $PKG
|
||||
mkdir -p $TMP $PKG $OUTPUT
|
||||
|
@ -50,30 +68,28 @@ tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
|
|||
cd $PRGNAM-$VERSION
|
||||
chown -R root:root .
|
||||
find -L . \
|
||||
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
|
||||
-exec chmod 755 {} \; -o \
|
||||
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
||||
-exec chmod 644 {} \;
|
||||
|
||||
sed -i "s/^CFLAGS=.*/CFLAGS=$SLKCFLAGS/g" Makefile
|
||||
|
||||
# Add missing -lm flag to Makefile
|
||||
patch -p1 < $CWD/math_fix.diff
|
||||
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
|
||||
-o -perm 511 \) -exec chmod 755 {} \; -o \
|
||||
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
|
||||
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
|
||||
|
||||
# append our SLKCFLAGS to CFLAGS in the Makefile:
|
||||
sed -i "/^CFLAGS=/s/$/\ $SLKCFLAGS/" Makefile
|
||||
make
|
||||
|
||||
install -D -m 0755 pigz $PKG/usr/bin/pigz
|
||||
install -D -m 0755 unpigz $PKG/usr/bin/unpigz
|
||||
install -D -m 0644 pigz.1 $PKG/usr/man/man1/pigz.1
|
||||
# don't install pigz binary as unpigz, make a symlink instead:
|
||||
( cd $PKG/usr/bin ; ln -sf pigz unpigz )
|
||||
|
||||
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
|
||||
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
|
||||
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
|
||||
|
||||
find $PKG/usr/man -type f -exec gzip -9 {} \;
|
||||
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
|
||||
|
||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp -a README $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp -a README pigz.pdf $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||
|
||||
mkdir -p $PKG/install
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
PRGNAM="pigz"
|
||||
VERSION="2.3"
|
||||
HOMEPAGE="http://www.zlib.net/pigz/"
|
||||
DOWNLOAD="http://ponce.cc/slackware/sources/repo/pigz-2.3.tar.gz"
|
||||
MD5SUM="042e3322534f2c3d761736350cac303f"
|
||||
VERSION="2.4"
|
||||
HOMEPAGE="https://www.zlib.net/pigz/"
|
||||
DOWNLOAD="https://www.zlib.net/pigz/pigz-2.4.tar.gz"
|
||||
MD5SUM="def2f6e19d9d8231445adc1349d346df"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES=""
|
||||
|
|
|
@ -6,14 +6,14 @@
|
|||
# customary to leave one space after the ':' except on otherwise blank lines.
|
||||
|
||||
|-----handy-ruler------------------------------------------------------|
|
||||
pigz: pigz (Parallel gzip)
|
||||
pigz: pigz (Parallel Implementation of GZip)
|
||||
pigz:
|
||||
pigz: pigz, which stands for parallel implementation of gzip, is a fully
|
||||
pigz: functional replacement for gzip that exploits multiple processors and
|
||||
pigz: multiple cores to the hilt when compressing data. pigz was written by
|
||||
pigz: Mark Adler, and uses the zlib and pthread libraries.
|
||||
pigz: pigz is a fully functional replacement for gzip that utilizes
|
||||
pigz: multiple processors and CPU cores when compressing data. pigz
|
||||
pigz: was written by Mark Adler, and uses zlib and pthread libraries.
|
||||
pigz:
|
||||
pigz: Homepage: https://www.zlib.net/pigz/
|
||||
pigz:
|
||||
pigz: Home page: http://www.zlib.net/pigz/
|
||||
pigz:
|
||||
pigz:
|
||||
pigz:
|
||||
|
|
Loading…
Reference in New Issue