libraries/libdockapp: Added to 12.2 repository

This commit is contained in:
Cezary M. Kruk 2010-05-12 23:30:28 +02:00 committed by Robby Workman
parent 4396f7c0f1
commit 178199f79f
5 changed files with 127 additions and 0 deletions

View File

@ -0,0 +1,17 @@
Don't hardcode SHAREDIR - use prefix/datadir (with DESTDIR as needed)
to ease packaging...
Signed-off-by: Robby Workman <rworkman@slackware.com>
diff -Nur libdockapp-0.6.2.orig/examples/Makefile.in libdockapp-0.6.2/examples/Makefile.in
--- libdockapp-0.6.2.orig/examples/Makefile.in 2008-05-01 04:17:34.000000000 -0500
+++ libdockapp-0.6.2/examples/Makefile.in 2009-05-16 02:04:30.843730264 -0500
@@ -161,7 +161,7 @@
target_alias = @target_alias@
top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
-SHAREDIR = $(DESTDIR)/usr/local/share
+SHAREDIR = $(DESTDIR)/@datadir@
BASICDIR = basic
BASICSRC = basic/Imakefile basic/README basic/ball_red.xpm basic/basic.c
RECTDIR = rectangles

View File

@ -0,0 +1,10 @@
libDockApp is a library for developing Window Maker dockapps.
libDockApp is a library that provides a framework for developing
dockapps. It provides functions and structures to define and display
command-line options, create a dockable icon, handle events, etc.
The goal of the library is to provide a simple, yet clean interface and
standardize the ways in which dockapps are developed. A dockapp
developed using libDockApp will automatically behave well under most
window managers, and especially well under Window Maker.

View File

@ -0,0 +1,73 @@
#!/bin/sh
# Slackware build script for libDockApp
# Written by Cezary M. Kruk (c.kruk@bigfoot.com)
#
# Modified by the SlackBuilds.org project.
PRGNAM=libdockapp
VERSION=${VERSION:-0.6.2}
ARCH=${ARCH:-i486}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
fi
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar -xvf $CWD/$PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION
chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
# Fixup the SHAREDIR in examples/Makefile.in
patch -p1 < $CWD/Fixup-examples-sharedir.patch
CFLAGS="$SLKCFLAGS" \
./configure \
--prefix=/usr \
--sysconfdir=/etc \
--localstatedir=/var \
--mandir=/usr/man \
--disable-debug \
--build=$ARCH-slackware-linux
make install DESTDIR=$PKG
( cd $PKG
find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
xargs strip --strip-unneeded 2> /dev/null || true
find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
xargs strip --strip-unneeded 2> /dev/null
)
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a AUTHORS BUGS COPYING ChangeLog INSTALL NEWS README \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz

View File

@ -0,0 +1,8 @@
PRGNAM="libdockapp"
VERSION="0.6.2"
HOMEPAGE="http://solfertje.student.utwente.nl/~dalroi/libdockapp/"
DOWNLOAD="http://solfertje.student.utwente.nl/~dalroi/libdockapp/files/libdockapp-0.6.2.tar.bz2"
MD5SUM="05a9a5f295d956397e6bb53bad3a0322"
MAINTAINER="Cezary M. Kruk"
EMAIL="c.kruk@bigfoot.com"
APPROVED="rworkman"

View File

@ -0,0 +1,19 @@
# HOW TO EDIT THIS FILE:
# The "handy ruler" below makes it easier to edit a package description. Line
# up the first '|' above the ':' following the base package name, and the '|'
# on the right side marks the last column you can put a character in. You must
# make exactly 11 lines for the formatting to be correct. It's also
# customary to leave one space after the ':'.
|-----handy-ruler------------------------------------------------------|
libdockapp: libdockapp (library for developing Window Maker dockapps)
libdockapp:
libdockapp: libDockApp is a library that provides a framework for developing
libdockapp: dockapps. It provides functions and structures to define and display
libdockapp: command-line options, create a dockable icon, handle events, etc.
libdockapp:
libdockapp: The goal of the library is to provide a simple, yet clean interface
libdockapp: and standardize the ways in which dockapps are developed. A dockapp
libdockapp: developed using libDockApp will automatically behave well under most
libdockapp: window managers, and especially well under Window Maker.
libdockapp: