network/fail2ban: Updated for version 0.9.1.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
beca46f916
commit
17796b6f58
|
@ -52,3 +52,5 @@ Upgraded to version 0.8.10.
|
|||
Upgraded to version 0.8.11
|
||||
09/25/2014
|
||||
Upgraded to version 0.9.0
|
||||
11/1/2014
|
||||
Upgraded to version 0.9.1
|
||||
|
|
|
@ -26,7 +26,7 @@
|
|||
# SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
|
||||
PRGNAM="fail2ban"
|
||||
VERSION=${VERSION:-0.9.0}
|
||||
VERSION=${VERSION:-0.9.1}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
|
@ -51,8 +51,6 @@ find -L . \
|
|||
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
|
||||
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
|
||||
|
||||
( cd fail2ban/client; patch -p0 < $CWD/patches/fail2banreader-logwarning-fix.patch )
|
||||
|
||||
python setup.py install --root=$PKG
|
||||
|
||||
# installing man pages
|
||||
|
@ -90,8 +88,7 @@ mkdir -p $PKG/var/{run,lib}/fail2ban
|
|||
rm -fr $PKG/usr/share/doc
|
||||
|
||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp -a COPYING ChangeLog README.md THANKS TODO DEVELOP \
|
||||
doc/run-rootless.txt $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp -a COPYING ChangeLog README.md THANKS TODO DEVELOP doc/run-rootless.txt $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||
|
||||
# building package
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
PRGNAM="fail2ban"
|
||||
VERSION="0.9.0"
|
||||
VERSION="0.9.1"
|
||||
HOMEPAGE="https://github.com/fail2ban/fail2ban/"
|
||||
DOWNLOAD="https://www.dropbox.com/s/rnitfx25uzjiaal/fail2ban-0.9.0.tar.xz"
|
||||
MD5SUM="3c092e4385f5c93b406d801c9054657e"
|
||||
DOWNLOAD="https://www.dropbox.com/s/mzfsm2bgkcyjlrv/fail2ban-0.9.1.tar.xz"
|
||||
MD5SUM="13aa1f1774369feccbe270eacce6e0d5"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES=""
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- fail2banreader.py.orig 2014-09-27 23:40:05.512547198 -0500
|
||||
+++ fail2banreader.py 2014-09-27 23:41:27.294412338 -0500
|
||||
@@ -45,7 +45,7 @@
|
||||
return ConfigReader.getOptions(self, "Definition", opts)
|
||||
|
||||
def getOptions(self):
|
||||
- opts = [["int", "loglevel", "INFO" ],
|
||||
+ opts = [["string", "loglevel", "INFO" ],
|
||||
["string", "logtarget", "STDERR"],
|
||||
["string", "dbfile", "/var/lib/fail2ban/fail2ban.sqlite3"],
|
||||
["int", "dbpurgeage", 86400]]
|
|
@ -1,11 +1,18 @@
|
|||
--- jail.conf.new.orig 2014-04-17 22:24:50.833320465 -0500
|
||||
+++ jail.conf.new 2014-04-17 22:25:12.317055028 -0500
|
||||
--- jail.conf.new.orig 2014-11-01 18:05:39.298887793 -0500
|
||||
+++ jail.conf.new 2014-11-01 18:06:07.763868656 -0500
|
||||
@@ -33,7 +33,7 @@
|
||||
[INCLUDES]
|
||||
|
||||
#before = paths-disto.conf
|
||||
#before = paths-distro.conf
|
||||
-before = paths-debian.conf
|
||||
+before = paths-slackware.conf
|
||||
|
||||
# The DEFAULT allows a global definition of the options. They can be overridden
|
||||
# in each jail afterwards.
|
||||
@@ -723,4 +723,4 @@
|
||||
[portsentry]
|
||||
enabled = false
|
||||
logpath = /var/lib/portsentry/portsentry.history
|
||||
-maxretry = 1
|
||||
\ No newline at end of file
|
||||
+maxretry = 1
|
||||
|
|
Loading…
Reference in New Issue