libraries/libdc1394: Updated for version 2.1.3.
Signed-off-by: Erik Hanson <erik@slackbuilds.org>
This commit is contained in:
parent
3adb386c50
commit
158369f364
|
@ -0,0 +1,39 @@
|
|||
diff --git a/libdc1394/dc1394/control.c b/libdc1394/dc1394/control.c
|
||||
index c62e0e2..f250f6a 100644
|
||||
--- a/libdc1394/dc1394/control.c
|
||||
+++ b/libdc1394/dc1394/control.c
|
||||
@@ -1955,7 +1955,7 @@ dc1394_new (void)
|
||||
windows_init (d);
|
||||
#endif
|
||||
#ifdef HAVE_LIBUSB
|
||||
- usb_init (d);
|
||||
+ dc1394_usb_init (d);
|
||||
#endif
|
||||
|
||||
int i;
|
||||
diff --git a/libdc1394/dc1394/internal.h b/libdc1394/dc1394/internal.h
|
||||
index b4d295a..c59e5d3 100644
|
||||
--- a/libdc1394/dc1394/internal.h
|
||||
+++ b/libdc1394/dc1394/internal.h
|
||||
@@ -74,7 +74,7 @@ void juju_init(dc1394_t *d);
|
||||
void linux_init(dc1394_t *d);
|
||||
void macosx_init(dc1394_t *d);
|
||||
void windows_init(dc1394_t *d);
|
||||
-void usb_init(dc1394_t *d);
|
||||
+void dc1394_usb_init(dc1394_t *d);
|
||||
|
||||
void register_platform (dc1394_t * d, const platform_dispatch_t * dispatch,
|
||||
const char * name);
|
||||
diff --git a/libdc1394/dc1394/usb/control.c b/libdc1394/dc1394/usb/control.c
|
||||
index 6509452..19a21a6 100644
|
||||
--- a/libdc1394/dc1394/usb/control.c
|
||||
+++ b/libdc1394/dc1394/usb/control.c
|
||||
@@ -378,7 +378,7 @@ usb_dispatch = {
|
||||
};
|
||||
|
||||
void
|
||||
-usb_init(dc1394_t * d)
|
||||
+dc1394_usb_init(dc1394_t * d)
|
||||
{
|
||||
register_platform (d, &usb_dispatch, "usb");
|
||||
}
|
|
@ -0,0 +1,53 @@
|
|||
From 2ee7e7f98dd6225b40d5cd570c240504be7bc86a Mon Sep 17 00:00:00 2001
|
||||
From: David Moore <david.moore@gmail.com>
|
||||
Date: Sun, 27 Mar 2011 22:48:15 -0700
|
||||
Subject: [PATCH 1/1] Conditionally compile dc1394_vloopback only when linux/videodev.h
|
||||
exists
|
||||
|
||||
---
|
||||
libdc1394/ChangeLog | 3 +++
|
||||
libdc1394/configure.in | 3 +++
|
||||
libdc1394/examples/Makefile.am | 2 ++
|
||||
3 files changed, 8 insertions(+), 0 deletions(-)
|
||||
|
||||
diff --git a/libdc1394/ChangeLog b/libdc1394/ChangeLog
|
||||
index e1355de..536ccae 100644
|
||||
--- a/libdc1394/ChangeLog
|
||||
+++ b/libdc1394/ChangeLog
|
||||
@@ -1,3 +1,6 @@
|
||||
+2011-03-27 David Moore <david.moore@gmail.com>
|
||||
+ * Conditionally compile dc1394_vloopback only when linux/video.h exists
|
||||
+
|
||||
2011-01-02 David Moore <david.moore@gmail.com>
|
||||
* dc1394/conversions.h: Fix typo in DC1394_STEREO_METHOD_MIN
|
||||
* Update NEWS, README, AUTHORS and version for release 2.1.3.
|
||||
diff --git a/libdc1394/configure.in b/libdc1394/configure.in
|
||||
index 69babab..bdddc9b 100644
|
||||
--- a/libdc1394/configure.in
|
||||
+++ b/libdc1394/configure.in
|
||||
@@ -75,6 +75,9 @@ AM_CONDITIONAL(HAVE_WINDOWS, test x$have_windows = xtrue)
|
||||
AM_CONDITIONAL(HAVE_LIBRAW1394, test x$libraw1394 = xtrue)
|
||||
AM_CONDITIONAL(HAVE_LIBUSB, test "x$LIBUSB_LIBS" != "x")
|
||||
|
||||
+AC_CHECK_HEADER([linux/videodev.h], [have_videodev=true])
|
||||
+AM_CONDITIONAL(HAVE_VIDEODEV, test x$have_videodev = xtrue)
|
||||
+
|
||||
AC_ARG_ENABLE([examples], [AS_HELP_STRING([--disable-examples], [don't build example programs])], [build_examples=$enableval], [build_examples=true])
|
||||
|
||||
AM_CONDITIONAL(MAKE_EXAMPLES, test x$build_examples = xtrue)
|
||||
diff --git a/libdc1394/examples/Makefile.am b/libdc1394/examples/Makefile.am
|
||||
index fcebf18..035612e 100644
|
||||
--- a/libdc1394/examples/Makefile.am
|
||||
+++ b/libdc1394/examples/Makefile.am
|
||||
@@ -8,7 +8,9 @@ A = grab_gray_image grab_partial_image grab_color_image \
|
||||
B = dc1394_reset_bus
|
||||
|
||||
if HAVE_LINUX
|
||||
+if HAVE_VIDEODEV
|
||||
B += dc1394_vloopback
|
||||
+endif
|
||||
if HAVE_XV
|
||||
A += dc1394_multiview
|
||||
endif
|
||||
--
|
||||
1.7.0.1
|
|
@ -3,16 +3,14 @@
|
|||
# Written by Larry Hajali <larryhaja[at]gmail[dot]com>
|
||||
|
||||
PRGNAM=libdc1394
|
||||
VERSION=${VERSION:-2.1.2}
|
||||
VERSION=${VERSION:-2.1.3}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
# Automatically determine the architecture we're building on:
|
||||
if [ -z "$ARCH" ]; then
|
||||
case "$( uname -m )" in
|
||||
i?86) ARCH=i486 ;;
|
||||
arm*) ARCH=arm ;;
|
||||
# Unless $ARCH is already set, use uname -m for all other archs:
|
||||
*) ARCH=$( uname -m ) ;;
|
||||
esac
|
||||
fi
|
||||
|
@ -51,33 +49,35 @@ find . \
|
|||
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
||||
-exec chmod 644 {} \;
|
||||
|
||||
patch -p2 < $CWD/libdc1394-usbinit.patch
|
||||
patch -p2 < $CWD/libdc1394-videodev.h.patch
|
||||
|
||||
autoreconf -ivf
|
||||
|
||||
CFLAGS="$SLKCFLAGS" \
|
||||
CXXFLAGS="$SLKCFLAGS" \
|
||||
./configure \
|
||||
--prefix=/usr \
|
||||
--libdir=/usr/lib${LIBDIRSUFFIX} \
|
||||
--sysconfdir=/etc \
|
||||
--localstatedir=/var \
|
||||
--mandir=/usr/man \
|
||||
--enable-doxygen-man \
|
||||
--enable-doxygen-html \
|
||||
--docdir=/usr/doc/$PRGNAM-$VERSION \
|
||||
--enable-static=no \
|
||||
--with-x \
|
||||
--build=$ARCH-slackware-linux
|
||||
|
||||
make
|
||||
make install-strip DESTDIR=$PKG
|
||||
make install DESTDIR=$PKG
|
||||
|
||||
( cd $PKG/usr/man
|
||||
find . -type f -exec gzip -9 {} \;
|
||||
for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
|
||||
)
|
||||
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
|
||||
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
|
||||
|
||||
find $PKG/usr/man -type f -exec gzip -9 {} \;
|
||||
|
||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp -a \
|
||||
AUTHORS ChangeLog COPYING INSTALL NEWS README doc/html \
|
||||
$PKG/usr/doc/$PRGNAM-$VERSION
|
||||
AUTHORS ChangeLog COPYING INSTALL NEWS README \
|
||||
$PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||
|
||||
mkdir -p $PKG/install
|
||||
|
|
|
@ -1,10 +1,10 @@
|
|||
PRGNAM="libdc1394"
|
||||
VERSION="2.1.2"
|
||||
VERSION="2.1.3"
|
||||
HOMEPAGE="http://damien.douxchamps.net/ieee1394/libdc1394/"
|
||||
DOWNLOAD="http://downloads.sourceforge.net/libdc1394/libdc1394-2.1.2.tar.gz"
|
||||
MD5SUM="b85f1ade88d8d96688d5965ed8603d53"
|
||||
DOWNLOAD="http://downloads.sourceforge.net/libdc1394/libdc1394-2.1.3.tar.gz"
|
||||
MD5SUM="d8b2cbfae1b329fdeaa638da80427334"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
MAINTAINER="Larry Hajali"
|
||||
EMAIL="larryhaja[at]gmail[dot]com"
|
||||
APPROVED="rworkman"
|
||||
APPROVED="rworkman,Erik Hanson"
|
||||
|
|
Loading…
Reference in New Issue