ham/dxcc: Added (DXCC command line lookup utility).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
d971af833b
commit
1538120989
|
@ -0,0 +1,22 @@
|
|||
--- Makefile 2008-02-25 16:14:17.000000000 -0600
|
||||
+++ Makefile 2014-07-12 22:08:21.050953719 -0500
|
||||
@@ -7,15 +7,16 @@
|
||||
@echo -e "dxcc - make [install|uninstall|clean|dist] \nCheck README for help."
|
||||
|
||||
install:
|
||||
- install -d -v $(DESTDIR)/share/man/man1/
|
||||
+ install -d -v $(DESTDIR)/man/man1/
|
||||
install -d -v $(DESTDIR)/share/dxcc/
|
||||
- install -m 0644 dxcc.1 $(DESTDIR)/share/man/man1/
|
||||
+ install -d -v $(DESTDIR)/bin/
|
||||
+ install -m 0644 dxcc.1 $(DESTDIR)/man/man1/
|
||||
install -m 0644 earth.gif $(DESTDIR)/share/dxcc/
|
||||
install -m 0755 dxcc $(DESTDIR)/bin/
|
||||
|
||||
uninstall:
|
||||
rm -f $(DESTDIR)/bin/dxcc
|
||||
- rm -f $(DESTDIR)/share/man/man1/dxcc.1
|
||||
+ rm -f $(DESTDIR)/man/man1/dxcc.1
|
||||
rm -f $(DESTDIR)/share/dxcc/earth.gif
|
||||
|
||||
clean:
|
|
@ -0,0 +1,3 @@
|
|||
dxcc is a small command line utility which determines the ARRL DXCC
|
||||
entity of a ham radio callsign, based on the cty.dat country file by
|
||||
Jim Reisert, AD1C.
|
File diff suppressed because it is too large
Load Diff
|
@ -0,0 +1,71 @@
|
|||
#!/bin/sh
|
||||
# Slackbuild for dxcc
|
||||
# Written by JK Wood <joshuakwood@gmail.com>
|
||||
|
||||
# Slackbuild is released under the Dog-on-Fire License:
|
||||
# If use of this script causes your dog to catch on fire,
|
||||
# you agree to send me five dollars. Or a picture
|
||||
# of the dog on fire.
|
||||
# Otherwise, you're on your own. I've tested the script
|
||||
# on my own computer, and it hasn't broken anything.
|
||||
# So if it does it on your computer, that falls in
|
||||
# the realm of "Not my problem."
|
||||
#
|
||||
# Of course, if you'll send a bug report to the above
|
||||
# email address, I may be able to see what you did
|
||||
# wrong and prevent it from happening in the future.
|
||||
# In which case, I may just send YOU five dollars.
|
||||
|
||||
# Oh, and feel free to copy it and modify it as you
|
||||
# see fit. Or as I see fit. Or as I fit. Although
|
||||
# that is unlikely, as I am rather tall.
|
||||
|
||||
PRGNAM=dxcc
|
||||
VERSION=${VERSION:-20080225}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
# This is a Perl script, architecture agnostic
|
||||
ARCH=noarch
|
||||
|
||||
CWD=$(pwd)
|
||||
TMP=${TMP:-/tmp/SBo}
|
||||
PKG=$TMP/package-$PRGNAM
|
||||
OUTPUT=${OUTPUT:-/tmp}
|
||||
|
||||
set -e
|
||||
rm -rf $PKG
|
||||
mkdir -p $TMP $PKG $OUTPUT
|
||||
cd $TMP
|
||||
rm -rf $PRGNAM-$VERSION
|
||||
tar -xvf $CWD/$PRGNAM-$VERSION.tar.gz
|
||||
cd $PRGNAM-$VERSION
|
||||
# Apply patch to allow make install to succeed
|
||||
patch -p0 < $CWD/Makefile.patch
|
||||
|
||||
chown -R root:root .
|
||||
find -L . \
|
||||
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
|
||||
-o -perm 511 \) -exec chmod 755 {} \; -o \
|
||||
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
|
||||
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
|
||||
|
||||
# Fix man path
|
||||
sed -i s#/share/man#/man#g Makefile
|
||||
|
||||
make install DESTDIR=$PKG/usr
|
||||
|
||||
find $PKG/usr/man -type f -exec gzip -9 {} \;
|
||||
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
|
||||
|
||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp -a COPYING ChangeLog README $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||
find $PKG/usr/doc -name "Makefile" -exec rm {} \;
|
||||
find $PKG/usr/doc -type f -exec chmod 644 {} \;
|
||||
cat $CWD/cty.dat > $PKG/usr/share/$PRGNAM/cty.dat
|
||||
|
||||
mkdir -p $PKG/install
|
||||
cat $CWD/slack-desc > $PKG/install/slack-desc
|
||||
|
||||
cd $PKG
|
||||
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
|
|
@ -0,0 +1,12 @@
|
|||
PRGNAM="dxcc"
|
||||
VERSION="20080225"
|
||||
HOMEPAGE="http://fkurz.net/ham/dxcc.html"
|
||||
DOWNLOAD="http://fkurz.net/ham/dxcc/dxcc-20080225.tar.gz \
|
||||
http://www.country-files.com/cty/cty.dat"
|
||||
MD5SUM="74167d4afef980701fb2bac269117808 \
|
||||
af196760b39277a24d39d06d25a56be2"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES=""
|
||||
MAINTAINER="JK Wood"
|
||||
EMAIL="joshuakwood@gmail.com"
|
|
@ -0,0 +1,19 @@
|
|||
# HOW TO EDIT THIS FILE:
|
||||
# The "handy ruler" below makes it easier to edit a package description.
|
||||
# Line up the first '|' above the ':' following the base package name, and
|
||||
# the '|' on the right side marks the last column you can put a character in.
|
||||
# You must make exactly 11 lines for the formatting to be correct. It's also
|
||||
# customary to leave one space after the ':' except on otherwise blank lines.
|
||||
|
||||
|-----handy-ruler------------------------------------------------------|
|
||||
dxcc: dxcc (DXCC command line lookup utility)
|
||||
dxcc:
|
||||
dxcc: dxcc is a command line utility that allows you to look up the ARRL
|
||||
dxcc: DXCC entity of a ham radio callsign, based on AD1C's cty.dat file.
|
||||
dxcc:
|
||||
dxcc:
|
||||
dxcc:
|
||||
dxcc:
|
||||
dxcc:
|
||||
dxcc: Homepage: http://fkurz.net/ham/dxcc.html
|
||||
dxcc:
|
Loading…
Reference in New Issue