libraries/ftgl: Patched tor build with gcc-4.7.x
Also added another to avoid autoreconf breaking compilation Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
This commit is contained in:
parent
db9974ef0c
commit
1479ce55c3
|
@ -24,7 +24,7 @@
|
|||
|
||||
PRGNAM=ftgl
|
||||
VERSION=${VERSION:-2.1.3_rc5}
|
||||
BUILD=${BUILD:-1}
|
||||
BUILD=${BUILD:-2}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
# Automatically determine the architecture we're building on:
|
||||
|
@ -68,6 +68,12 @@ cd $PRGNAM-$(echo $VERSION | tr _ \~)
|
|||
chown -R root:root .
|
||||
chmod -R a-s,u+rw,go+r-w .
|
||||
|
||||
# Fix building with gcc-4.7.x
|
||||
patch -p1 < $CWD/patches/gcc47.patch
|
||||
# Fix spam that breaks build after autoreconfing
|
||||
patch -p1 < $CWD/patches/spam.patch
|
||||
autoreconf -i
|
||||
|
||||
CFLAGS="$SLKCFLAGS" \
|
||||
CXXFLAGS="$SLKCFLAGS" \
|
||||
./configure \
|
||||
|
@ -78,7 +84,6 @@ CXXFLAGS="$SLKCFLAGS" \
|
|||
make GLUT_LIBS="-lglut -lGLU -lGL -lm"
|
||||
make install-strip DESTDIR=$PKG
|
||||
|
||||
|
||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp AUTHORS BUGS COPYING ChangeLog INSTALL NEWS README TODO \
|
||||
$PKG/usr/doc/$PRGNAM-$VERSION
|
||||
|
|
|
@ -0,0 +1,12 @@
|
|||
diff -Naur ftgl-2.1.3~rc5.orig/test/Makefile.am ftgl-2.1.3~rc5/test/Makefile.am
|
||||
--- ftgl-2.1.3~rc5.orig/test/Makefile.am 2008-06-02 03:10:10.000000000 +0200
|
||||
+++ ftgl-2.1.3~rc5/test/Makefile.am 2012-04-01 06:59:36.523040292 +0200
|
||||
@@ -52,7 +52,7 @@
|
||||
|
||||
CXXTest_CXXFLAGS = $(FT2_CFLAGS) $(GL_CFLAGS)
|
||||
CXXTest_LDFLAGS = $(FT2_LIBS) $(GLUT_LIBS) -lcppunit
|
||||
-CXXTest_LDADD = ../src/libftgl.la
|
||||
+CXXTest_LDADD = ../src/libftgl.la -lm
|
||||
|
||||
CTest_SOURCES = \
|
||||
CTest.c \
|
|
@ -0,0 +1,16 @@
|
|||
diff -Naur ftgl-2.1.3~rc5.orig/Makefile.am ftgl-2.1.3~rc5/Makefile.am
|
||||
--- ftgl-2.1.3~rc5.orig/Makefile.am 2008-05-12 20:04:08.000000000 +0200
|
||||
+++ ftgl-2.1.3~rc5/Makefile.am 2012-04-01 07:09:50.727996032 +0200
|
||||
@@ -26,12 +26,6 @@
|
||||
|
||||
# Print out an informative summary.
|
||||
all-local:
|
||||
- @$(ECHO) "Done."
|
||||
- @$(ECHO)
|
||||
- @if test "x$(MAKECMDGOALS)" = "xall-am" -o "x$(.TARGETS)" = "xall-am" -o "x$(MAKECMDGOALS)" = "x" -o "x$(.TARGETS)" = "x" ; then \
|
||||
- $(ECHO) "---" ;\
|
||||
- $(ECHO) "Run 'make install' to begin installation into $(prefix)" ;\
|
||||
- fi
|
||||
@$(ECHO)
|
||||
|
||||
# Upload documentation
|
Loading…
Reference in New Issue